aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2015-06-16 06:09:14 +0800
committerrakuco <rakuco@FreeBSD.org>2015-06-16 06:09:14 +0800
commit8cdaf6e64f64ca114264dfaab2fa5cb32d833ab2 (patch)
treeaad1c2d9fb7e56d1e6d82d061a0c91a8fbe0d630 /emulators
parent6591f7a18ee1e7d4043aaa22a71d2eaff09adc03 (diff)
downloadfreebsd-ports-gnome-8cdaf6e64f64ca114264dfaab2fa5cb32d833ab2.tar.gz
freebsd-ports-gnome-8cdaf6e64f64ca114264dfaab2fa5cb32d833ab2.tar.zst
freebsd-ports-gnome-8cdaf6e64f64ca114264dfaab2fa5cb32d833ab2.zip
Add upstream commit to find X11 directly.
Fixes the build with the upcoming CMake 3.2 update, since its FindOpenGL.cmake does not check for X11 anymore.
Diffstat (limited to 'emulators')
-rw-r--r--emulators/dolphin-emu/files/patch-git_148ce85b20
1 files changed, 20 insertions, 0 deletions
diff --git a/emulators/dolphin-emu/files/patch-git_148ce85b b/emulators/dolphin-emu/files/patch-git_148ce85b
new file mode 100644
index 000000000000..c71d2e2253ac
--- /dev/null
+++ b/emulators/dolphin-emu/files/patch-git_148ce85b
@@ -0,0 +1,20 @@
+Required for CMake 3.2 to work, precisely because FindOpenGL.cmake does not
+check for X11 anymore.
+
+commit 148ce85b26925e38ced2f196475086eb7884fb62
+Author: Maxime Gauduin <alucryd@gmail.com>
+Date: Fri Mar 13 12:58:08 2015 +0100
+
+ Include the FindX11 module
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -415,8 +445,7 @@
+ add_definitions(-DHAVE_WAYLAND=0)
+ endif(USE_WAYLAND AND WAYLAND_FOUND)
+
+- # Note: We do not need to explicitly check for X11 as it is done in the cmake
+- # FindOpenGL module on linux.
++ include(FindX11)
+ if(USE_X11 AND X11_FOUND)
+ set(USE_X11 1)
+ add_definitions(-DHAVE_X11=1)