aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorvd <vd@FreeBSD.org>2006-12-05 00:28:35 +0800
committervd <vd@FreeBSD.org>2006-12-05 00:28:35 +0800
commit8ed49a3d0aa4aa6d35ec8ff3508a17fcf55edf3c (patch)
treedaf14a87a810be8e2b4ef720e495210e5601ed91 /emulators
parenta79d4d481a10bf67610515baa4187fee9ff8919f (diff)
downloadfreebsd-ports-gnome-8ed49a3d0aa4aa6d35ec8ff3508a17fcf55edf3c.tar.gz
freebsd-ports-gnome-8ed49a3d0aa4aa6d35ec8ff3508a17fcf55edf3c.tar.zst
freebsd-ports-gnome-8ed49a3d0aa4aa6d35ec8ff3508a17fcf55edf3c.zip
Resurrect emulators/basiliskII and emulators/vmware-tools2 since there are
PRs with fixes for them: ports/105758 and ports/104594 respectively. Noticed by: pav
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile2
-rw-r--r--emulators/basiliskII/Makefile49
-rw-r--r--emulators/basiliskII/distinfo3
-rw-r--r--emulators/basiliskII/pkg-descr4
-rw-r--r--emulators/basiliskII/pkg-message8
-rw-r--r--emulators/basiliskII/pkg-plist5
-rw-r--r--emulators/vmware-tools2/Makefile43
-rw-r--r--emulators/vmware-tools2/distinfo2
-rw-r--r--emulators/vmware-tools2/pkg-descr14
-rw-r--r--emulators/vmware-tools2/pkg-message5
-rw-r--r--emulators/vmware-tools2/pkg-plist2
11 files changed, 137 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 9da435fbcce4..8109de1df02f 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -6,6 +6,7 @@
SUBDIR += adamem
SUBDIR += aftp
SUBDIR += atari800
+ SUBDIR += basiliskII
SUBDIR += bfe
SUBDIR += bochs
SUBDIR += bsvc
@@ -133,6 +134,7 @@
SUBDIR += vmware-guestd3
SUBDIR += vmware-guestd4
SUBDIR += vmware-guestd5
+ SUBDIR += vmware-tools2
SUBDIR += vmware-tools3
SUBDIR += vmware-tools4
SUBDIR += vmware-tools5
diff --git a/emulators/basiliskII/Makefile b/emulators/basiliskII/Makefile
new file mode 100644
index 000000000000..3c1ba52b5b28
--- /dev/null
+++ b/emulators/basiliskII/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: BasiliskII
+# Date created: 17 April 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= basiliskII
+PORTVERSION= 1.0
+PORTREVISION= 3
+CATEGORIES= emulators
+MASTER_SITES= http://www.gibix.net/projects/basilisk2/files/
+MASTER_SITE_SUBDIR= basilisk
+DISTNAME= BasiliskII_src_01052006
+
+MAINTAINER= mmendez@energyhq.be
+COMMENT= A free, portable, Open Source 68k Mac emulator
+
+BROKEN= Does not compile
+DEPRECATED= ${BROKEN}
+EXPIRATION_DATE=2006-12-01
+
+WRKSRC= ${WRKDIR}/BasiliskII-${PORTVERSION}/src/Unix
+
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+USE_GNOME= esound gtk20
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_ARGS= --disable-fbdev-dga --enable-fpe=uae
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+
+MAN1= BasiliskII.1
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 400012
+CFLAGS+= -fpermissive
+.endif
+
+.if ${ARCH} == amd64
+BROKEN= does not compile on AMD64 architectures
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/emulators/basiliskII/distinfo b/emulators/basiliskII/distinfo
new file mode 100644
index 000000000000..9f8c36c099c7
--- /dev/null
+++ b/emulators/basiliskII/distinfo
@@ -0,0 +1,3 @@
+MD5 (BasiliskII_src_01052006.tar.bz2) = dfe9e088649133485bae28a713979481
+SHA256 (BasiliskII_src_01052006.tar.bz2) = 6782f2ed3587d7790557a0994f5b7472d7a27ded0f1598b9380efabde16bd3cc
+SIZE (BasiliskII_src_01052006.tar.bz2) = 1310908
diff --git a/emulators/basiliskII/pkg-descr b/emulators/basiliskII/pkg-descr
new file mode 100644
index 000000000000..f3ebb4e742c2
--- /dev/null
+++ b/emulators/basiliskII/pkg-descr
@@ -0,0 +1,4 @@
+Basilisk II is a free, portable, Open Source 68k Mac emulator. It requires a
+copy of a 512K or 1MB Mac ROM and a copy of MacOS 7.x or 8.x to run.
+
+WWW: http://www.gibix.net/projects/basilisk2/
diff --git a/emulators/basiliskII/pkg-message b/emulators/basiliskII/pkg-message
new file mode 100644
index 000000000000..12929c1e3aad
--- /dev/null
+++ b/emulators/basiliskII/pkg-message
@@ -0,0 +1,8 @@
+********************************************************************************
+
+ NOTE: You have to get a copy of the original Mac ROM image and a copy of MacOS
+ to run BasiliskII. Be aware that the only legal way to get ROM image is
+ to rip it out from your Mac computer. See BasiliskII home page to get
+ details.
+
+********************************************************************************
diff --git a/emulators/basiliskII/pkg-plist b/emulators/basiliskII/pkg-plist
new file mode 100644
index 000000000000..95dfd91b2370
--- /dev/null
+++ b/emulators/basiliskII/pkg-plist
@@ -0,0 +1,5 @@
+bin/BasiliskII
+share/BasiliskII/fbdevices
+share/BasiliskII/keycodes
+share/BasiliskII/tunconfig
+@dirrm share/BasiliskII
diff --git a/emulators/vmware-tools2/Makefile b/emulators/vmware-tools2/Makefile
new file mode 100644
index 000000000000..edf7c269bf65
--- /dev/null
+++ b/emulators/vmware-tools2/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: VMware tools for FreeBSD
+# Date created: 10 Aug 2000
+# Whom: matusita@jp.FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= vmware-tools
+PORTVERSION= ${VMWARE_VER}.${BUILD_VER}
+CATEGORIES= emulators
+MASTER_SITES= http://vmware-svca.www.conxion.com/software/ \
+ http://vmware-chil.www.conxion.com/software/ \
+ http://vmware-heva.www.conxion.com/software/ \
+ http://vmware.wespe.de/software/ \
+ ftp://vmware.wespe.de/pub/software/
+DISTNAME= tools-for-freebsd-${BUILD_VER}
+
+MAINTAINER= matusita@FreeBSD.org
+COMMENT=VMware tools for guest OS (for VMware 2.x, FreeBSD version)
+
+BROKEN= Unfetchable
+DEPRECATED= ${BROKEN}
+EXPIRATION_DATE=2006-12-01
+
+WRKSRC= ${WRKDIR}/vmware-freebsd-tools
+
+ONLY_FOR_ARCHS= i386
+USE_X_PREFIX= yes
+NO_BUILD= yes
+NO_LATEST_LINK= yes
+
+RESTRICTED= "Not sure if we can redistribute this."
+NO_PACKAGE= ${RESTRICTED}
+
+VMWARE_VER= 2.0.4
+BUILD_VER= 307
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/XF86_VMware ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/XF86Config.dist ${PREFIX}/etc/XF86Config_VMware
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/emulators/vmware-tools2/distinfo b/emulators/vmware-tools2/distinfo
new file mode 100644
index 000000000000..2bbcea15b6b4
--- /dev/null
+++ b/emulators/vmware-tools2/distinfo
@@ -0,0 +1,2 @@
+MD5 (tools-for-freebsd-307.tar.gz) = c9e4b04abe26f7158003fa183bcfa48f
+SIZE (tools-for-freebsd-307.tar.gz) = 1232295
diff --git a/emulators/vmware-tools2/pkg-descr b/emulators/vmware-tools2/pkg-descr
new file mode 100644
index 000000000000..2c11f4f3e02b
--- /dev/null
+++ b/emulators/vmware-tools2/pkg-descr
@@ -0,0 +1,14 @@
+VMware tools support FreeBSD _guest_ OS running on VMware Workstation.
+Beware, this port is _not_ for FreeBSD _host_ OS.
+
+VMware tools for FreeBSD consist of vmware-toolbox which supports
+seamless operation between the Host and the Guest OS, dual-boot
+configulation files, and special X server for Guest OS. However,
+vmware-toolbox for FreeBSD lacks some features that vmware-toolbox for
+Linux has, and dual-boot configulation is broken because checkvm
+doesn't work.
+
+So this port installs X server ONLY. If you want vmware-toolbox,
+install ports/emulators/linux-vmware-toolbox2 on your FreeBSD _Guest_ OS.
+
+WWW: http://www.vmware.com/download/downloadtools.html
diff --git a/emulators/vmware-tools2/pkg-message b/emulators/vmware-tools2/pkg-message
new file mode 100644
index 000000000000..b067e3ceb4e2
--- /dev/null
+++ b/emulators/vmware-tools2/pkg-message
@@ -0,0 +1,5 @@
+XFree86 configulation file is in ${PREFIX}/etc/XF86Config_VMware.
+Copy this file to /etc/XF86Config before starting X.
+
+This package does not contain vmware-toolbox. You need to install
+ports/emulators/linux-vmware-toolbox2 if you want it.
diff --git a/emulators/vmware-tools2/pkg-plist b/emulators/vmware-tools2/pkg-plist
new file mode 100644
index 000000000000..fd515f110692
--- /dev/null
+++ b/emulators/vmware-tools2/pkg-plist
@@ -0,0 +1,2 @@
+bin/XF86_VMware
+etc/XF86Config_VMware