aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorjoe <joe@FreeBSD.org>2002-08-15 00:09:27 +0800
committerjoe <joe@FreeBSD.org>2002-08-15 00:09:27 +0800
commit961a12465b8bfb8e7d8027d92ffe3ebd9eae4702 (patch)
tree4f47cf7dc5180ec4eb9f760ab71d6566a0473639 /emulators
parentcd8f5c8376436e1879409c5dd8af7353801539c4 (diff)
downloadfreebsd-ports-gnome-961a12465b8bfb8e7d8027d92ffe3ebd9eae4702.tar.gz
freebsd-ports-gnome-961a12465b8bfb8e7d8027d92ffe3ebd9eae4702.tar.zst
freebsd-ports-gnome-961a12465b8bfb8e7d8027d92ffe3ebd9eae4702.zip
Fix vmware2 for -current so that it compiles again.
Submitted by: Mark Santcroos <marks@ripe.net>
Diffstat (limited to 'emulators')
-rw-r--r--emulators/vmware2/Makefile1
-rw-r--r--emulators/vmware2/files/kmoddeps.patch12
-rw-r--r--emulators/vmware3/Makefile1
-rw-r--r--emulators/vmware3/files/kmoddeps.patch12
4 files changed, 26 insertions, 0 deletions
diff --git a/emulators/vmware2/Makefile b/emulators/vmware2/Makefile
index 305ceeb18b29..012e592562fb 100644
--- a/emulators/vmware2/Makefile
+++ b/emulators/vmware2/Makefile
@@ -109,6 +109,7 @@ post-patch:
${WRKSRC}/vmmon-only/freebsd/*.c \
${WRKSRC}/vmware-distrib/vmmon-only/freebsd/*.c
.endif
+ cat ${FILESDIR}/kmoddeps.patch | (cd ${WRKSRC} && patch) > /dev/null 2>&1
setoptions:
${SED} -e 's;@@PREFIX@@;${PREFIX};' \
diff --git a/emulators/vmware2/files/kmoddeps.patch b/emulators/vmware2/files/kmoddeps.patch
new file mode 100644
index 000000000000..e282d8c20ff4
--- /dev/null
+++ b/emulators/vmware2/files/kmoddeps.patch
@@ -0,0 +1,12 @@
+--- vmmon-only/Makefile.FreeBSD.orig Fri Jun 14 08:45:33 2002
++++ vmmon-only/Makefile.FreeBSD Fri Jun 14 08:47:42 2002
+@@ -40,7 +40,9 @@
+ SRCS=
+
+ # For 4.0-STABLE
++.if ${OSVERSION} < 500002
+ KMODDEPS= linux
++.endif
+
+ INCLUDE = -I$(.CURDIR)/include -I$(.CURDIR)/common -I$(.CURDIR)/freebsd -I$(.CURDIR)/export/include -I/sys
+ INCLUDE += -I$(.CURDIR)/../vmnet-only/freebsd/
diff --git a/emulators/vmware3/Makefile b/emulators/vmware3/Makefile
index 305ceeb18b29..012e592562fb 100644
--- a/emulators/vmware3/Makefile
+++ b/emulators/vmware3/Makefile
@@ -109,6 +109,7 @@ post-patch:
${WRKSRC}/vmmon-only/freebsd/*.c \
${WRKSRC}/vmware-distrib/vmmon-only/freebsd/*.c
.endif
+ cat ${FILESDIR}/kmoddeps.patch | (cd ${WRKSRC} && patch) > /dev/null 2>&1
setoptions:
${SED} -e 's;@@PREFIX@@;${PREFIX};' \
diff --git a/emulators/vmware3/files/kmoddeps.patch b/emulators/vmware3/files/kmoddeps.patch
new file mode 100644
index 000000000000..e282d8c20ff4
--- /dev/null
+++ b/emulators/vmware3/files/kmoddeps.patch
@@ -0,0 +1,12 @@
+--- vmmon-only/Makefile.FreeBSD.orig Fri Jun 14 08:45:33 2002
++++ vmmon-only/Makefile.FreeBSD Fri Jun 14 08:47:42 2002
+@@ -40,7 +40,9 @@
+ SRCS=
+
+ # For 4.0-STABLE
++.if ${OSVERSION} < 500002
+ KMODDEPS= linux
++.endif
+
+ INCLUDE = -I$(.CURDIR)/include -I$(.CURDIR)/common -I$(.CURDIR)/freebsd -I$(.CURDIR)/export/include -I/sys
+ INCLUDE += -I$(.CURDIR)/../vmnet-only/freebsd/