aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authordbn <dbn@FreeBSD.org>2013-08-11 16:19:18 +0800
committerdbn <dbn@FreeBSD.org>2013-08-11 16:19:18 +0800
commit97383155e586452ef2e82d0eca90cdf8a3132780 (patch)
tree7d734db89e9f7fe9975d640afff3273e45abb0c7 /emulators
parent39b1551ebccb0f2884a58448e1fdc18331760764 (diff)
downloadfreebsd-ports-gnome-97383155e586452ef2e82d0eca90cdf8a3132780.tar.gz
freebsd-ports-gnome-97383155e586452ef2e82d0eca90cdf8a3132780.tar.zst
freebsd-ports-gnome-97383155e586452ef2e82d0eca90cdf8a3132780.zip
Update emulators/i386-wine-devel options with GECKO and MONO.
The binary package for amd64 systems does not bundle GECKO or MONO however it is useful (for some) to have those files installed, so allow the package to have a run-time dependency on the ports that provide Gecko and Mono support. PORTREVISION is not bumped since nothing changes in the default (BATCH) case.
Diffstat (limited to 'emulators')
-rw-r--r--emulators/i386-wine-devel/Makefile.i3865
-rw-r--r--emulators/i386-wine-devel/Makefile.inc15
2 files changed, 17 insertions, 3 deletions
diff --git a/emulators/i386-wine-devel/Makefile.i386 b/emulators/i386-wine-devel/Makefile.i386
index bf6ec59ce61e..9c9b4c281054 100644
--- a/emulators/i386-wine-devel/Makefile.i386
+++ b/emulators/i386-wine-devel/Makefile.i386
@@ -5,7 +5,6 @@ PKGNAMEPREFIX= i386-
MAINTAINER= dbn@FreeBSD.org
COMMENT= 32bit Microsoft Windows compatibility environment for 64bit FreeBSD
-LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}-devel
# Use the wine port to do most of the heavy lifting
MASTERDIR= ${.CURDIR}/../wine-devel
@@ -14,10 +13,12 @@ PKGDEINSTALL= ${PKGINSTALL}
RUN_DEPENDS= dri>0:${PORTSDIR}/graphics/dri
+CONFLICTS_INSTALL= i386-wine-1.6* wine-[0-9]*
+LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}-devel
+
ACTUAL-PACKAGE-DEPENDS= ${DO_NADA}
WINELIBDIR= ${PREFIX}/lib32
CONFIGURE_ARGS+= --bindir=${PREFIX}/bin32 --libdir=${WINELIBDIR}
-CONFLICTS_INSTALL= wine-[0-9]*
PLIST_REINPLACE+= winelib
PLIST_REINPLACE_WINELIB= s!lib/!lib32/!g
WINE_SLAVE_BUILD= yes
diff --git a/emulators/i386-wine-devel/Makefile.inc b/emulators/i386-wine-devel/Makefile.inc
index 7dea1f719aff..42827ebd9d02 100644
--- a/emulators/i386-wine-devel/Makefile.inc
+++ b/emulators/i386-wine-devel/Makefile.inc
@@ -18,10 +18,15 @@ LICENSE= LGPL21 LGPL3
LICENSE_COMB= dual
LICENSE_FILE= ${WRKDIR}/LICENSE
+OPTIONS_DEFINE= GECKO MONO
+GECKO_DESC= Bundle Gecko MSI package for Wine
+MONO_DESC= Bundle Mono MSI package for Wine
+
EXTRACT_AFTER_ARGS= -C / --exclude +COMPACT_MANIFEST --exclude +MANIFEST \
--exclude +MTREE_DIRS --exclude share/licenses/'*'
-CONFLICTS_INSTALL= wine-[0-9]*
+CONFLICTS_INSTALL= i386-wine-1.6* wine-[0-9]*
LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}-devel
+
NO_BUILD= yes
ONLY_FOR_ARCHS= i386 amd64
ONLY_FOR_ARCHS_REASON= wine only runs on x86 architecture
@@ -38,6 +43,14 @@ USE_XZ= yes
IGNORE= binaries compiled for FreeBSD 8.3+ and 9.1+
.endif
+.if ${PORT_OPTIONS:MGECKO}
+RUN_DEPENDS+= ${DATADIR}/gecko/wine_gecko-2.21-x86.msi:${PORTSDIR}/emulators/wine-gecko-devel
+.endif
+
+.if ${PORT_OPTIONS:MMONO}
+RUN_DEPENDS+= ${DATADIR}/mono/wine-mono-0.0.8.msi:${PORTSDIR}/emulators/wine-mono
+.endif
+
.if ${PREFIX} != /usr/local
EXTRACT_AFTER_ARGS+= -s '|/usr/local|${PREFIX}|gs'
.endif