aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2006-07-17 03:54:20 +0800
committerlinimon <linimon@FreeBSD.org>2006-07-17 03:54:20 +0800
commita286d21fc12a4d3d40b46f720342c06f814038d3 (patch)
tree2fd4bac58aa78b5dbbd117681edf42801e8dfaa6 /emulators
parent4caca9a620265598e1962b487da8b772524c52c9 (diff)
downloadfreebsd-ports-gnome-a286d21fc12a4d3d40b46f720342c06f814038d3.tar.gz
freebsd-ports-gnome-a286d21fc12a4d3d40b46f720342c06f814038d3.tar.zst
freebsd-ports-gnome-a286d21fc12a4d3d40b46f720342c06f814038d3.zip
Mark xmame broken on 5.X: gets internal gcc error.
While here, get rid of a .error usage.
Diffstat (limited to 'emulators')
-rw-r--r--emulators/xmame/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/emulators/xmame/Makefile b/emulators/xmame/Makefile
index 49781f0aa99c..33f9f5dd1870 100644
--- a/emulators/xmame/Makefile
+++ b/emulators/xmame/Makefile
@@ -67,7 +67,7 @@ PLIST_SUB+= MAMEONLY="" MESSONLY="@comment "
.if ${MAMEMESS} == "mess"
PLIST_SUB+= MAMEONLY="@comment " MESSONLY=""
.else
-.error MAMEMESS must be set to one of "mame" or "mess".
+IGNORE= cannot install: MAMEMESS must be set to one of "mame" or "mess".
.endif
.endif
@@ -119,11 +119,9 @@ ALLDOCS= ${GENERALDOCS} ${XMESSDOCS}
#
.include <bsd.port.pre.mk>
-#.if ${OSVERSION} < 500000
-#BROKEN= Doesn't build on FreeBSD < 5.x
-#.elif (${OSVERSION} < 600000 && ${MAMEMESS} == "mess")
-#BROKEN= Doesn't build on FreeBSD < 6.x
-#.endif
+.if (${OSVERSION} < 600000 && ${MAMEMESS} == "mess")
+BROKEN= internal gcc error on FreeBSD < 6.x
+.endif
.if (${MAMEMESS} == "mess" && ${OSVERSION} >= 500000)
USE_GCC= 3.4+