aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorscheidell <scheidell@FreeBSD.org>2012-02-18 00:54:12 +0800
committerscheidell <scheidell@FreeBSD.org>2012-02-18 00:54:12 +0800
commitc93315d95ad62fdb6c402a451f97e6e94bf10403 (patch)
treec95dd54ce846dc7a92be0882975df8cd3e38792a /emulators
parent92b949d85be7066335838e5f985a319e8190112c (diff)
downloadfreebsd-ports-gnome-c93315d95ad62fdb6c402a451f97e6e94bf10403.tar.gz
freebsd-ports-gnome-c93315d95ad62fdb6c402a451f97e6e94bf10403.tar.zst
freebsd-ports-gnome-c93315d95ad62fdb6c402a451f97e6e94bf10403.zip
- Back out all changes to date starting with this pr.
- changes that were applied by several people, one change (mine, the actual upgrade) made hgfs unloadable. - other changes along the way, attempting to fix it made port broken were also backed out - Only patches left were DougB's rc script patches - Bump PORTEPOCH PR: ports/161891 Submitted by: scheidell (me) Approved by: ports@ (maintainer, implicit), gabor (mentor)
Diffstat (limited to 'emulators')
-rw-r--r--emulators/open-vm-tools/Makefile20
-rw-r--r--emulators/open-vm-tools/distinfo4
-rw-r--r--emulators/open-vm-tools/files/patch-vmhgfs-Makefile15
-rw-r--r--emulators/open-vm-tools/files/pkg-message.in3
-rw-r--r--emulators/open-vm-tools/pkg-plist7
5 files changed, 10 insertions, 39 deletions
diff --git a/emulators/open-vm-tools/Makefile b/emulators/open-vm-tools/Makefile
index 489d55f3ae4a..3ff87b7428fc 100644
--- a/emulators/open-vm-tools/Makefile
+++ b/emulators/open-vm-tools/Makefile
@@ -4,11 +4,11 @@
#
# $FreeBSD$
#
+
PORTNAME= open-vm-tools
PORTVERSION= ${BUILD_VER}
-PORTREVISION= 1
CATEGORIES= emulators kld
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/stable-8.8.x
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/stable-8.6.x
DISTNAME= open-vm-tools-${RELEASE_VER}-${BUILD_VER}
MAINTAINER= ports@FreeBSD.org
@@ -17,15 +17,12 @@ COMMENT?= Open VMware tools for FreeBSD VMware guests
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN= does not package
-
-RELEASE_VER= 8.8.0
-BUILD_VER= 471268
+RELEASE_VER= 8.6.0
+BUILD_VER= 425873
WRKSRC= ${WRKDIR}/open-vm-tools-${RELEASE_VER}-${BUILD_VER}
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_AUTOTOOLS= automake
CONFIGURE_ARGS+= --without-procps --sysconfdir=${LOCALBASE}/etc
.if defined(WITHOUT_X11)
@@ -61,13 +58,6 @@ PLIST_SUB+= FUSE=""
PLIST_SUB+= FUSE="@comment "
.endif
-.if defined(WITH_LOAD_HGFS)
-PLIST_SUB+= NOLOAD=""
-BROKEN= remove this line to install broken vmhgfs.ko
-.else
-PLIST_SUB+= NOLOAD="@comment "
-.endif
-
CONFLICTS+= vmware-guestd[0-9]* vmware-tools[0-9]*
SUB_FILES= pkg-message
@@ -99,9 +89,7 @@ post-install:
${MKDIR} ${PREFIX}/lib/vmware-tools/modules/input
${INSTALL_DATA} ${WRKSRC}/modules/freebsd/vmmemctl.ko ${PREFIX}/lib/vmware-tools/modules/drivers/vmmemctl.ko
${INSTALL_DATA} ${WRKSRC}/modules/freebsd/vmxnet.ko ${PREFIX}/lib/vmware-tools/modules/drivers/vmxnet.ko
-.if defined(WITH_LOAD_HGFS)
${INSTALL_DATA} ${WRKSRC}/modules/freebsd/vmhgfs.ko ${PREFIX}/lib/vmware-tools/modules/drivers/vmhgfs.ko
-.endif
${INSTALL_DATA} ${WRKSRC}/modules/freebsd/vmblock.ko ${PREFIX}/lib/vmware-tools/modules/drivers/vmblock.ko
@-kldxref ${PREFIX}/lib/vmware-tools/modules/drivers 2>/dev/null
@${CAT} ${PKGMESSAGE}
diff --git a/emulators/open-vm-tools/distinfo b/emulators/open-vm-tools/distinfo
index 72f5417cadf2..0fa47bdb2244 100644
--- a/emulators/open-vm-tools/distinfo
+++ b/emulators/open-vm-tools/distinfo
@@ -1,2 +1,2 @@
-SHA256 (open-vm-tools-8.8.0-471268.tar.gz) = 642cf860c9910cd64424a588f8ac4ad500af358e5ca992862bfbd667224ff79c
-SIZE (open-vm-tools-8.8.0-471268.tar.gz) = 3760851
+SHA256 (open-vm-tools-8.6.0-425873.tar.gz) = 205768023fdf77962684f275f74c98644fba97961cb2afaa0a7d8aec5d074ebf
+SIZE (open-vm-tools-8.6.0-425873.tar.gz) = 3648242
diff --git a/emulators/open-vm-tools/files/patch-vmhgfs-Makefile b/emulators/open-vm-tools/files/patch-vmhgfs-Makefile
index 6eaae10cc489..e5c592f4c518 100644
--- a/emulators/open-vm-tools/files/patch-vmhgfs-Makefile
+++ b/emulators/open-vm-tools/files/patch-vmhgfs-Makefile
@@ -1,15 +1,6 @@
---- modules/freebsd/vmhgfs/Makefile.orig 2011-09-15 02:03:28.000000000 +0000
-+++ modules/freebsd/vmhgfs/Makefile 2012-01-08 16:11:28.000000000 +0000
-@@ -47,7 +47,7 @@
- .endif
-
- COMMON_HGFS_SRCS := debug.c
--COMMON_HGFS_SRCS := bdhandler.c
-+COMMON_HGFS_SRCS += bdhandler.c
- COMMON_HGFS_SRCS += request.c
- COMMON_HGFS_SRCS += worker.c
- COMMON_HGFS_SRCS += fsutil.c
-@@ -93,22 +93,7 @@
+--- ./modules/freebsd/vmhgfs/Makefile.orig 2010-10-20 05:19:54.000000000 +0900
++++ ./modules/freebsd/vmhgfs/Makefile 2010-11-11 23:06:07.000000000 +0900
+@@ -90,22 +90,7 @@
CFLAGS += -Ishared
.endif
diff --git a/emulators/open-vm-tools/files/pkg-message.in b/emulators/open-vm-tools/files/pkg-message.in
index c2f78883f2d0..ab2bf34dafe4 100644
--- a/emulators/open-vm-tools/files/pkg-message.in
+++ b/emulators/open-vm-tools/files/pkg-message.in
@@ -8,7 +8,4 @@ vmware_guest_vmmemctl_enable="YES"
vmware_guest_vmxnet_enable="YES"
vmware_guestd_enable="YES"
-NOTE: as of this writting, vmhfgs.ko load module is broken.
-To install and test/debug/fix this module, define WITH_LOAD_HGFS
-and remove BROKEN in Makefile
*******************************************************************
diff --git a/emulators/open-vm-tools/pkg-plist b/emulators/open-vm-tools/pkg-plist
index bb1d716c7899..c73f79066289 100644
--- a/emulators/open-vm-tools/pkg-plist
+++ b/emulators/open-vm-tools/pkg-plist
@@ -32,7 +32,7 @@ lib/libguestlib.so.0
libdata/pkgconfig/vmguestlib.pc
lib/vmware-tools/modules/drivers/linker.hints
lib/vmware-tools/modules/drivers/vmblock.ko
-%%NOLOAD%%lib/vmware-tools/modules/drivers/vmhgfs.ko
+lib/vmware-tools/modules/drivers/vmhgfs.ko
lib/vmware-tools/modules/drivers/vmmemctl.ko
lib/vmware-tools/modules/drivers/vmxnet.ko
include/vmGuestLib/includeCheck.h
@@ -41,8 +41,6 @@ include/vmGuestLib/vmSessionId.h
include/vmGuestLib/vm_basic_types.h
@exec mkdir -p %D/lib/vmware-tools/modules/input
sbin/mount_vmhgfs
-sbin/mount_vmblock
-@unexec rm /sbin/mount_vmblock
%%X11%%bin/vmware-toolbox
%%X11%%bin/vmware-user-suid-wrapper
share/vmware-tools/poweroff-vm-default
@@ -59,9 +57,6 @@ share/vmware-tools/scripts/vmware/network
@unexec if test -f %D/lib/vmware-tools/modules/drivers/linker.hints; then rm -f %D/lib/vmware-tools/modules/drivers/linker.hints; fi
@unexec if test -f %D/share/vmware-tools/tools.conf; then rm -f %D/share/vmware-tools/tools.conf; fi
@unexec if test -h %D/etc/vmware-tools/plugins; then rm -f %D/etc/vmware-tools/plugins; fi
-%%X11%%etc/xdg/autostart/vmware-user.desktop
-@dirrmtry etc/xdg/autostart
-@dirrmtry etc/xdg
@dirrmtry lib/vmware-tools/modules/drivers
@dirrmtry lib/vmware-tools/modules/input
@dirrmtry lib/vmware-tools/modules