aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2013-03-27 05:18:20 +0800
committermandree <mandree@FreeBSD.org>2013-03-27 05:18:20 +0800
commite39ce7e92ba236082567e3110e28f2c776d12697 (patch)
tree051025167241518f8a087f758933a0aa6eaec9c3 /emulators
parent6b5fc12e91d88faf799b9e2b39bde3c89a511745 (diff)
downloadfreebsd-ports-gnome-e39ce7e92ba236082567e3110e28f2c776d12697.tar.gz
freebsd-ports-gnome-e39ce7e92ba236082567e3110e28f2c776d12697.tar.zst
freebsd-ports-gnome-e39ce7e92ba236082567e3110e28f2c776d12697.zip
- Maintainer update to new version 2.2.1.1
- In addition to patch from PR, pick a newer compiler to avoid compilation trouble. Maintainer considers disabling SIMD instead, and might follow up with a new patch. PR: ports/174153 Submitted by: Green Dog <fiziologus@gmail.com> (update to 2.2.0) Submitted by: Chris Petrik <c.petrik.sosa@gmail.com> (update to 2.2.1.1) Approved by: Chris Petrik (maintainer)
Diffstat (limited to 'emulators')
-rw-r--r--emulators/fceux/Makefile128
-rw-r--r--emulators/fceux/distinfo4
-rw-r--r--emulators/fceux/files/patch-SConstruct113
-rw-r--r--emulators/fceux/files/patch-file.c10
-rw-r--r--emulators/fceux/pkg-descr2
-rw-r--r--emulators/fceux/pkg-plist113
6 files changed, 312 insertions, 58 deletions
diff --git a/emulators/fceux/Makefile b/emulators/fceux/Makefile
index da5799ad08f7..76943783d948 100644
--- a/emulators/fceux/Makefile
+++ b/emulators/fceux/Makefile
@@ -2,39 +2,135 @@
# $FreeBSD$
PORTNAME= fceux
-PORTVERSION= 2.1.5
+PORTVERSION= 2.2.1.1
CATEGORIES= emulators
-MASTER_SITES= SF/fceultra/Source%20Code/2.1.5%20src/
+MASTER_SITES= SF/fceultra/Source%20Code/${PORTVERSION:R}%20src/
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
MAINTAINER= c.petrik.sosa@gmail.com
-COMMENT= Portable NES/Famicom emulator based on Bero's original FCE
+COMMENT= A portable NES/Famicom emulator based on Bero's original FCE
-USE_BZIP2= yes
+USE_PKGCONFIG= build
USE_SCONS= yes
+SCONS_BUILDENV= CC="${CC}" CXX="${CXX}" \
+ CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
+ CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+SCONS_ARGS+= --prefix="${PREFIX}"
USE_SDL= sdl
USE_DOS2UNIX= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+RUN_DEPENDS+= zenity:${PORTSDIR}/x11/zenity
+
+MAN6= fceux.6 fceux-net-server.6
+
+OPTIONS_DEFINE= FRAMESKIP OPENGL DEBUG LUA CREATE_AVI LOGO
+OPTIONS_SINGLE= GUI
+OPTIONS_SINGLE_GUI= GTK2 GTK3
+OPTIONS_DEFAULT= FRAMESKIP OPENGL LUA NEWPPU CREATE_AVI LOGO GTK2
+
+FRAMESKIP_DESC= Enable frameskipping
+LUA_DESC= Enable Lua support
+CREATE_AVI_DESC= Enable avi creation support (SDL)
+LOGO_DESC= Enable a logoscreen when creating avis (SDL)
+GTK2_DESC= Enable GTK2 GUI (SDL)
+GTK3_DESC= Enable GTK3 GUI (SDL)
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MFRAMESKIP}
+SCONS_ARGS+= FRAMESKIP=1
+.else
+SCONS_ARGS+= FRAMESKIP=0
+.endif
+
+.if ${PORT_OPTIONS:MGTK2}
+SCONS_ARGS+= GTK=1
+USE_GNOME+= gtk20
+.else
+SCONS_ARGS+= GTK=0
+.endif
+
+.if ${PORT_OPTIONS:MGTK3}
+SCONS_ARGS+= GTK3=1
+USE_GNOME+= gtk30
+.else
+SCONS_ARGS+= GTK3=0
+.endif
+
+.if ${PORT_OPTIONS:MLUA}
+SCONS_ARGS+= LUA=1 SYSTEM_LUA=1
USE_LUA= yes
+.else
+SCONS_ARGS+= LUA=0
+.endif
-WRKSRC= ${WRKDIR}/fceu${PORTVERSION}
+.if ${PORT_OPTIONS:MLOGO}
+SCONS_ARGS+= LOGO=1 CREATE_AVI=1
+LIB_DEPENDS+= gd:${PORTSDIR}/graphics/gd
+.else
+SCONS_ARG+= LOGO=0
+.endif
-BUILD_DEPENDS+= zenity:${PORTSDIR}/x11/zenity
+.if ${PORT_OPTIONS:MOPENGL}
+SCONS_ARGS+= OPENGL=1
+USE_GL= gl
+.else
+SCONS_ARGS+= OPENGL=0
+.endif
-MAN6= fceux.6
+.if ${PORT_OPTIONS:MCREATE_AVI}
+SCONS_ARGS+= CREATE_AVI=1
+.else
+SCONS_ARGS+= CREATE_AVI=0
+.endif
+
+.if ${PORT_OPTIONS:MDEBUG}
+SCONS_ARGS+= DEBUG=1
+.else
+SCONS_ARGS+= DEBUG=0
+.endif
.include <bsd.port.pre.mk>
-post-extract:
- ${REINPLACE_CMD} -e 's/[[:cntrl:]]*$$//' \
- ${WRKSRC}/src/drivers/common/vidblit.cpp
- @${MV} ${WRKSRC}/documentation/fceux.6 ${WRKSRC}/
+# Go find a better compiler, base cc does not support mm3dnow.h,
+# breaking the build:
+#
+# In file included from src/drivers/videolog/rgbtorgb.cpp:14:
+# src/drivers/videolog/simd.h:13:56: error: mm3dnow.h: No such file or directory
+#
+# Use clang if in /usr/bin, else set USE_GCC:
+#
+.if (empty(CC:T:Mgcc4*) && empty(CC:T:Mclang*)) || (empty(CXX:T:Mg??4*) && empty(CXX:T:Mclang++*))
+.if (${OSVERSION} >= 900014) && (exists(/usr/bin/clang++) && exists(/usr/bin/clang))
+CC= /usr/bin/clang
+CXX= /usr/bin/clang++
+CPP= /usr/bin/clang-cpp
+.else
+USE_GCC= 4.6+
+.endif
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|%%PKGCONFIG%%|${LOCALBASE}/bin/pkg-config|g' \
+ -e 's|%%SDLCONFIG%%|${LOCALBASE}/bin/sdl-config|g' \
+ ${WRKSRC}/SConstruct
+ ${REINPLACE_CMD} -e 's|usr|usr/local|g' ${WRKSRC}/fceux.desktop
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/fceux ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/fceux.6 ${PREFIX}/man/man6
-.if !defined(NOPORTDOCS)
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
- cd ${WRKSRC}/documentation && ${COPYTREE_SHARE} . ${DOCSDIR}/
+.for file in TODO-PROJECT Videolog.txt cheat.html faq fcs.txt fm2.txt protocol.txt snes9x-lua.html
+ @${CP} ${WRKSRC}/documentation/${file} ${DOCSDIR}
+.endfor
+ @${MV} ${WRKSRC}/documentation/tech ${DOCSDIR}
.endif
+ ${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/fceux.desktop \
+ ${PREFIX}/share/applications/fceux.desktop
+ @${INSTALL_DATA} ${WRKSRC}/fceux.png \
+ ${PREFIX}/share/pixmaps/fceux.png
.include <bsd.port.post.mk>
diff --git a/emulators/fceux/distinfo b/emulators/fceux/distinfo
index af697e6e48ec..bb917d8e5b2e 100644
--- a/emulators/fceux/distinfo
+++ b/emulators/fceux/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fceux-2.1.5.src.tar.bz2) = ee6b1ee6a0347e325032f6655a5caa289e2b0458f7fccddccd5137f1cd63bf9f
-SIZE (fceux-2.1.5.src.tar.bz2) = 7322199
+SHA256 (fceux-2.2.1.1.src.tar.gz) = afb0b3b8e1d2eea40c59777ef538b69b16164ae53c406106e541099534db828c
+SIZE (fceux-2.2.1.1.src.tar.gz) = 8878420
diff --git a/emulators/fceux/files/patch-SConstruct b/emulators/fceux/files/patch-SConstruct
index 352c4433b7b8..5b0bd2d55f38 100644
--- a/emulators/fceux/files/patch-SConstruct
+++ b/emulators/fceux/files/patch-SConstruct
@@ -1,15 +1,104 @@
---- SConstruct.bak 2012-09-30 14:49:24.000000000 -0500
-+++ SConstruct 2012-09-30 14:50:46.000000000 -0500
-@@ -56,9 +56,9 @@
- else:
- conf = Configure(env)
- assert conf.CheckLibWithHeader('z', 'zlib.h', 'C', 'inflate;', 1), "please install: zlib"
-- if not conf.CheckLib('SDL'):
-- print 'Did not find libSDL or SDL.lib, exiting!'
-- Exit(1)
-+ ###if not conf.CheckLib('SDL'):
-+ ### print 'Did not find libSDL or SDL.lib, exiting!'
-+ ### Exit(1)
+--- SConstruct.bak 2013-03-24 08:54:38.000000000 +0000
++++ SConstruct 2013-03-24 09:04:53.000000000 +0000
+@@ -17,7 +17,7 @@
+ BoolVariable('FRAMESKIP', 'Enable frameskipping', 1),
+ BoolVariable('OPENGL', 'Enable OpenGL support', 1),
+ BoolVariable('LSB_FIRST', 'Least signficant byte first (non-PPC)', 1),
+- BoolVariable('DEBUG', 'Build with debugging symbols', 1),
++ BoolVariable('DEBUG', 'Build with debugging symbols', 0),
+ BoolVariable('LUA', 'Enable Lua support', 1),
+ BoolVariable('SYSTEM_LUA','Use system lua instead of static lua provided with fceux', 1),
+ BoolVariable('SYSTEM_MINIZIP', 'Use system minizip instead of static minizip provided with fceux', 0),
+@@ -35,8 +35,8 @@
+ env = Environment(options = opts)
+
+ #### Uncomment this for a public release ###
+-env.Append(CPPDEFINES=["PUBLIC_RELEASE"])
+-env['DEBUG'] = 0
++#env.Append(CPPDEFINES=["PUBLIC_RELEASE"])
++#env['DEBUG'] = 0
+ ############################################
+ # LSB_FIRST must be off for PPC to compile
+@@ -101,13 +101,13 @@
+ if not conf.CheckLib('SDL'):
+ print 'Did not find libSDL or SDL.lib, exiting!'
+ Exit(1)
+- env.ParseConfig('sdl-config --cflags --libs')
++ env.ParseConfig('%%SDLCONFIG%% --cflags --libs')
if env['GTK']:
+ if not conf.CheckLib('gtk-x11-2.0'):
+ print 'Could not find libgtk-2.0, exiting!'
+ Exit(1)
+ # Add compiler and linker flags from pkg-config
+- config_string = 'pkg-config --cflags --libs gtk+-2.0'
++ config_string = '%%PKGCONFIG%% --cflags --libs gtk+-2.0'
+ if env['PLATFORM'] == 'darwin':
+ config_string = 'PKG_CONFIG_PATH=/opt/X11/lib/pkgconfig/ ' + config_string
+ env.ParseConfig(config_string)
+@@ -115,7 +115,7 @@
+ env.Append(CCFLAGS = ["-D_GTK"])
+ if env['GTK3']:
# Add compiler and linker flags from pkg-config
+- config_string = 'pkg-config --cflags --libs gtk+-3.0'
++ config_string = '%%PKGCONFIG%% --cflags --libs gtk+-3.0'
+ if env['PLATFORM'] == 'darwin':
+ config_string = 'PKG_CONFIG_PATH=/opt/X11/lib/pkgconfig/ ' + config_string
+ env.ParseConfig(config_string)
+@@ -134,11 +134,11 @@
+ # Should work on any *nix
+ env.Append(CCFLAGS = ["-DLUA_USE_LINUX"])
+ lua_available = False
+- if conf.CheckLib('lua5.1'):
+- env.Append(LINKFLAGS = ["-ldl", "-llua5.1"])
++ if conf.CheckLib('lua-5.1'):
++ env.Append(LINKFLAGS = ["-llua-5.1"])
+ lua_available = True
+ elif conf.CheckLib('lua'):
+- env.Append(LINKFLAGS = ["-ldl", "-llua"])
++ env.Append(LINKFLAGS = ["-llua"])
+ lua_available = True
+ if lua_available == False:
+ print 'Could not find liblua, exiting!'
+@@ -156,6 +156,7 @@
+
+ if env['OPENGL'] and conf.CheckLibWithHeader('GL', 'GL/gl.h', 'c', autoadd=1):
+ conf.env.Append(CCFLAGS = "-DOPENGL")
++ env.ParseConfig('%%PKGCONFIG%% --cflags --libs gl')
+ conf.env.Append(CPPDEFINES = ['PSS_STYLE=1'])
+
+ env = conf.Finish()
+@@ -173,7 +174,7 @@
+ env.Append(CPPDEFINES=["_DEBUG"], CCFLAGS = ['-g'])
+ else:
+ env.Append(CCFLAGS = ['-O2'])
+-
++ env.Append(CPPDEFINES=["PUBLIC_RELEASE"])
+ if env['PLATFORM'] != 'win32' and env['PLATFORM'] != 'cygwin' and env['CREATE_AVI']:
+ env.Append(CPPDEFINES=["CREATE_AVI"])
+ else:
+@@ -200,18 +201,18 @@
+ auxlib_dst = 'bin/auxlib.lua'
+ auxlib_inst_dst = prefix + '/share/fceux/auxlib.lua'
+
+-fceux_h_src = 'src/drivers/win/help/fceux.chm'
+-fceux_h_dst = 'bin/fceux.chm'
++#fceux_h_src = 'src/drivers/win/help/fceux.chm'
++#fceux_h_dst = 'bin/fceux.chm'
+
+-env.Command(fceux_h_dst, fceux_h_src, [Copy(fceux_h_dst, fceux_h_src)])
+-env.Command(fceux_dst, fceux_src, [Copy(fceux_dst, fceux_src)])
++#env.Command(fceux_h_dst, fceux_h_src, [Copy(fceux_h_dst, fceux_h_src)])
++#env.Command(fceux_dst, fceux_src, [Copy(fceux_dst, fceux_src)])
+ env.Command(fceux_net_server_dst, fceux_net_server_src, [Copy(fceux_net_server_dst, fceux_net_server_src)])
+ env.Command(auxlib_dst, auxlib_src, [Copy(auxlib_dst, auxlib_src)])
+
+ man_src = 'documentation/fceux.6'
+ man_net_src = 'documentation/fceux-net-server.6'
+-man_dst = prefix + '/share/man/man6/fceux.6'
+-man_net_dst = prefix + '/share/man/man6/fceux-net-server.6'
++man_dst = prefix + '/man/man6/fceux.6'
++man_net_dst = prefix + '/man/man6/fceux-net-server.6'
+
+ share_src = 'output/'
+ share_dst = prefix + '/share/fceux/'
diff --git a/emulators/fceux/files/patch-file.c b/emulators/fceux/files/patch-file.c
deleted file mode 100644
index bd04b8b8cf4a..000000000000
--- a/emulators/fceux/files/patch-file.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/file.cpp.bak 2012-09-30 18:58:51.000000000 -0500
-+++ src/file.cpp 2012-09-30 18:59:15.000000000 -0500
-@@ -310,7 +310,7 @@
- if(magic==0x088b1f) {
- // maybe gzip...
-
-- void* gzfile = gzopen(fileToOpen.c_str(),"rb");
-+ gzFile gzfile = gzopen(fileToOpen.c_str(),"rb");
- if(gzfile) {
- delete fp;
diff --git a/emulators/fceux/pkg-descr b/emulators/fceux/pkg-descr
index e83ddac8d7f5..fcd65a88e11f 100644
--- a/emulators/fceux/pkg-descr
+++ b/emulators/fceux/pkg-descr
@@ -9,4 +9,4 @@ images, headerless and FWNES style FDS disk images, and NSF files.
FCE Ultra currently supports the following iNES mappers(many partially):
-WWW: http://fceultra.sourceforge.net/
+WWW: http://www.fceux.com/
diff --git a/emulators/fceux/pkg-plist b/emulators/fceux/pkg-plist
index 12e11670f824..130e73cd2077 100644
--- a/emulators/fceux/pkg-plist
+++ b/emulators/fceux/pkg-plist
@@ -1,30 +1,109 @@
bin/fceux
-%%PORTDOCS%%%%DOCSDIR%%/snes9x-lua.html
-%%PORTDOCS%%%%DOCSDIR%%/fcs.txt
-%%PORTDOCS%%%%DOCSDIR%%/protocol.txt
-%%PORTDOCS%%%%DOCSDIR%%/todo
+bin/fceux-net-server
+share/applications/fceux.desktop
+share/pixmaps/fceux.png
+%%DATADIR%%/auxlib.lua
+%%DATADIR%%/luaScripts/AVI-HeadsUpDisplay.lua
+%%DATADIR%%/luaScripts/BoulderDash_AmoebaAI.lua
+%%DATADIR%%/luaScripts/BugsBunnyBirthdayBlowout.lua
+%%DATADIR%%/luaScripts/ButtonCount.lua
+%%DATADIR%%/luaScripts/CustomLagIndicator_RvT.lua
+%%DATADIR%%/luaScripts/Excitingbike-speedometeronly.lua
+%%DATADIR%%/luaScripts/Excitingbike.lua
+%%DATADIR%%/luaScripts/FRKfunctions.lua
+%%DATADIR%%/luaScripts/GUI-iup_button.lua
+%%DATADIR%%/luaScripts/GUI-iup_example.lua
+%%DATADIR%%/luaScripts/Galaxian.lua
+%%DATADIR%%/luaScripts/Gradius-BulletHell.lua
+%%DATADIR%%/luaScripts/JumpingFCEUXWindow.lua
+%%DATADIR%%/luaScripts/Luabot.lua
+%%DATADIR%%/luaScripts/Machrider.lua
+%%DATADIR%%/luaScripts/MegamanII-LaserEyes.lua
+%%DATADIR%%/luaScripts/MemoryWatch.lua
+%%DATADIR%%/luaScripts/Multitrack.lua
+%%DATADIR%%/luaScripts/Multitrack2.lua
+%%DATADIR%%/luaScripts/NightmareElmStreet-4Player.lua
+%%DATADIR%%/luaScripts/PunchOutChallenge.lua
+%%DATADIR%%/luaScripts/PunchOutStats.lua
+%%DATADIR%%/luaScripts/PunchOutTraining.lua
+%%DATADIR%%/luaScripts/RBIBaseball.lua
+%%DATADIR%%/luaScripts/Registerfind(CheatSearch).lua
+%%DATADIR%%/luaScripts/Rewinder.lua
+%%DATADIR%%/luaScripts/SMB-AreaScrambler.lua
+%%DATADIR%%/luaScripts/SMB-CompetitionRecorder.lua
+%%DATADIR%%/luaScripts/SMB-HitBoxes.lua
+%%DATADIR%%/luaScripts/SMB-Jetpack.lua
+%%DATADIR%%/luaScripts/SMB-Lives&HPDisplay.lua
+%%DATADIR%%/luaScripts/SMB-Mouse.lua
+%%DATADIR%%/luaScripts/SMB-Snow.lua
+%%DATADIR%%/luaScripts/SMB2U.lua
+%%DATADIR%%/luaScripts/SMB3-RainbowRiding.lua
+%%DATADIR%%/luaScripts/ShowPalette.lua
+%%DATADIR%%/luaScripts/SoundDisplay.lua
+%%DATADIR%%/luaScripts/SoundDisplay2.lua
+%%DATADIR%%/luaScripts/Subtitler.lua
+%%DATADIR%%/luaScripts/TeenageMutantNinjaTurtles.lua
+%%DATADIR%%/luaScripts/UsingLuaBot-Documentation.txt
+%%DATADIR%%/luaScripts/UsingLuaScripting-Documentation.txt
+%%DATADIR%%/luaScripts/UsingLuaScripting-ListofFunctions.txt
+%%DATADIR%%/luaScripts/ZapperDisplay.lua
+%%DATADIR%%/luaScripts/ZapperFun.lua
+%%DATADIR%%/luaScripts/luabot_framework.lua
+%%DATADIR%%/luaScripts/m_utils.lua
+%%DATADIR%%/luaScripts/shapedefs.lua
+%%DATADIR%%/luaScripts/taseditor/InputDisplay_for_Selection.lua
+%%DATADIR%%/luaScripts/taseditor/InvertSelection.lua
+%%DATADIR%%/luaScripts/taseditor/RecordBackwards.lua
+%%DATADIR%%/luaScripts/taseditor/ShowNotes.lua
+%%DATADIR%%/luaScripts/taseditor/Swap1P2P.lua
+%%DATADIR%%/luaScripts/taseditor/TrackNoise.lua
+%%DATADIR%%/luaScripts/tetris.lua
+%%DATADIR%%/luaScripts/vnb.lua
+%%DATADIR%%/luaScripts/x_functions.lua
+%%DATADIR%%/luaScripts/x_interface.lua
+%%DATADIR%%/luaScripts/x_smb1enemylist.lua
+%%DATADIR%%/palettes/ASQ_realityA.pal
+%%DATADIR%%/palettes/ASQ_realityB.pal
+%%DATADIR%%/palettes/BMF_final2.pal
+%%DATADIR%%/palettes/BMF_final3.pal
+%%DATADIR%%/palettes/FCEU-13-default_nitsuja.pal
+%%DATADIR%%/palettes/FCEU-15-nitsuja_new.pal
+%%DATADIR%%/palettes/FCEUX.pal
+%%DATADIR%%/palettes/nestopia_rgb.pal
+%%DATADIR%%/palettes/nestopia_yuv.pal
+%%DATADIR%%/taseditor.chm
+%%DATADIR%%/tools/taseditor_patterns.txt
+%%PORTDOCS%%%%DOCSDIR%%/TODO-PROJECT
%%PORTDOCS%%%%DOCSDIR%%/Videolog.txt
-%%PORTDOCS%%%%DOCSDIR%%/fm2.txt
-%%PORTDOCS%%%%DOCSDIR%%/porting.txt
%%PORTDOCS%%%%DOCSDIR%%/cheat.html
-%%PORTDOCS%%%%DOCSDIR%%/tech/readme.now
-%%PORTDOCS%%%%DOCSDIR%%/tech/exp/vrcvii.txt
+%%PORTDOCS%%%%DOCSDIR%%/faq
+%%PORTDOCS%%%%DOCSDIR%%/fcs.txt
+%%PORTDOCS%%%%DOCSDIR%%/fm2.txt
+%%PORTDOCS%%%%DOCSDIR%%/protocol.txt
+%%PORTDOCS%%%%DOCSDIR%%/snes9x-lua.html
+%%PORTDOCS%%%%DOCSDIR%%/tech/cpu/4017.txt
+%%PORTDOCS%%%%DOCSDIR%%/tech/cpu/dmc.txt
+%%PORTDOCS%%%%DOCSDIR%%/tech/cpu/nessound-4th.txt
+%%PORTDOCS%%%%DOCSDIR%%/tech/cpu/nessound.txt
+%%PORTDOCS%%%%DOCSDIR%%/tech/exp/mmc5-e.txt
%%PORTDOCS%%%%DOCSDIR%%/tech/exp/smb2j.txt
%%PORTDOCS%%%%DOCSDIR%%/tech/exp/tengen.txt
-%%PORTDOCS%%%%DOCSDIR%%/tech/exp/mmc5-e.txt
%%PORTDOCS%%%%DOCSDIR%%/tech/exp/vrcvi.txt
-%%PORTDOCS%%%%DOCSDIR%%/tech/cpu/nessound.txt
-%%PORTDOCS%%%%DOCSDIR%%/tech/cpu/4017.txt
-%%PORTDOCS%%%%DOCSDIR%%/tech/cpu/nessound-4th.txt
-%%PORTDOCS%%%%DOCSDIR%%/tech/cpu/dmc.txt
+%%PORTDOCS%%%%DOCSDIR%%/tech/exp/vrcvii.txt
%%PORTDOCS%%%%DOCSDIR%%/tech/nsfspec.txt
-%%PORTDOCS%%%%DOCSDIR%%/tech/readme.sound
-%%PORTDOCS%%%%DOCSDIR%%/tech/ppu/loopy2.txt
%%PORTDOCS%%%%DOCSDIR%%/tech/ppu/2c02 technical operation.txt
%%PORTDOCS%%%%DOCSDIR%%/tech/ppu/loopy1.txt
-%%PORTDOCS%%%%DOCSDIR%%/faq
+%%PORTDOCS%%%%DOCSDIR%%/tech/ppu/loopy2.txt
+%%PORTDOCS%%%%DOCSDIR%%/tech/readme.now
+%%PORTDOCS%%%%DOCSDIR%%/tech/readme.sound
+@dirrm %%DATADIR%%/tools
+@dirrm %%DATADIR%%/palettes
+@dirrm %%DATADIR%%/luaScripts/taseditor
+@dirrm %%DATADIR%%/luaScripts
+@dirrm %%DATADIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%/tech/ppu
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/tech/cpu
%%PORTDOCS%%@dirrm %%DOCSDIR%%/tech/exp
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/tech/cpu
%%PORTDOCS%%@dirrm %%DOCSDIR%%/tech
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry share/applications