aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-09-28 02:25:34 +0800
committerjbeich <jbeich@FreeBSD.org>2016-09-28 02:25:34 +0800
commitea75ba0ee86bd00f935d933a270f746beee24eab (patch)
tree088f7f0fcd4546e2de39f14cb9fab94ede0a6be9 /emulators
parent65e5f08e428b22f40a49df3cd740714c8b6264e9 (diff)
downloadfreebsd-ports-gnome-ea75ba0ee86bd00f935d933a270f746beee24eab.tar.gz
freebsd-ports-gnome-ea75ba0ee86bd00f935d933a270f746beee24eab.tar.zst
freebsd-ports-gnome-ea75ba0ee86bd00f935d933a270f746beee24eab.zip
emulators/ppsspp: enslave GUI options
Catering package-only users that want Qt4 flavor or just SDL UI. COMMENT and pkg-descr (both plural) can be improved in future.
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile2
-rw-r--r--emulators/ppsspp-qt4/Makefile14
-rw-r--r--emulators/ppsspp-qt5/Makefile14
-rw-r--r--emulators/ppsspp/Makefile5
4 files changed, 33 insertions, 2 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 185c93291ad5..47d7919962f2 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -109,6 +109,8 @@
SUBDIR += pipelight
SUBDIR += playonbsd
SUBDIR += ppsspp
+ SUBDIR += ppsspp-qt4
+ SUBDIR += ppsspp-qt5
SUBDIR += py-gns3-converter
SUBDIR += q4wine
SUBDIR += qemu
diff --git a/emulators/ppsspp-qt4/Makefile b/emulators/ppsspp-qt4/Makefile
new file mode 100644
index 000000000000..c0f6f30344d9
--- /dev/null
+++ b/emulators/ppsspp-qt4/Makefile
@@ -0,0 +1,14 @@
+# $FreeBSD$
+
+PORTREVISION= 0
+PKGNAMESUFFIX= -qt4
+
+MASTERDIR= ${.CURDIR}/../ppsspp
+
+OPTIONS_SLAVE= QT4
+OPTIONS_EXCLUDE=${OPTIONS_SINGLE_GUI}
+
+# XXX Why OPTIONS_EXCLUDE doesn't trigger _OFF helpers?
+do-install-QT4-on: do-install-SDL-off
+
+.include "${MASTERDIR}/Makefile"
diff --git a/emulators/ppsspp-qt5/Makefile b/emulators/ppsspp-qt5/Makefile
new file mode 100644
index 000000000000..72ef6d9e15ac
--- /dev/null
+++ b/emulators/ppsspp-qt5/Makefile
@@ -0,0 +1,14 @@
+# $FreeBSD$
+
+PORTREVISION= 0
+PKGNAMESUFFIX= -qt5
+
+MASTERDIR= ${.CURDIR}/../ppsspp
+
+OPTIONS_SLAVE= QT5
+OPTIONS_EXCLUDE=${OPTIONS_SINGLE_GUI}
+
+# XXX Why OPTIONS_EXCLUDE doesn't trigger _OFF helpers?
+do-install-QT5-on: do-install-SDL-off
+
+.include "${MASTERDIR}/Makefile"
diff --git a/emulators/ppsspp/Makefile b/emulators/ppsspp/Makefile
index f7e8c7220fdb..3c85a17d50fd 100644
--- a/emulators/ppsspp/Makefile
+++ b/emulators/ppsspp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ppsspp
DISTVERSIONPREFIX= v
DISTVERSION?= 1.3
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= emulators
# XXX Get from Debian once #697821 lands
MASTER_SITES= https://bazaar.launchpad.net/~sergio-br2/${PORTNAME}/debian-sdl/download/5/${PORTNAME}.1-20140802045408-dd26dik367ztj5xg-8/:manpage
@@ -25,7 +25,7 @@ GH_ACCOUNT= hrydgard:DEFAULT,lang Kingcom:ext_armips
GH_PROJECT= ${PORTNAME}-lang:lang armips:ext_armips
GH_TAGNAME?= cdf4a8d:lang 1ffab37:ext_armips
-CONFLICTS_INSTALL?= ${PORTNAME}-devel-[0-9]*
+CONFLICTS_INSTALL= ${PORTNAME}-*
USES= compiler:c++11-lib localbase pkgconfig
EXCLUDE= glew snappy libzip zlib
@@ -47,6 +47,7 @@ DESKTOP_ENTRIES="PPSSPP" \
OPTIONS_DEFAULT=QT5
OPTIONS_SINGLE= GUI
OPTIONS_SINGLE_GUI= QT4 QT5 SDL
+OPTIONS_SLAVE?= SDL
QT4_USES= qmake:outsource
QT4_USE= QT4=qmake_build,moc_build,rcc_build,uic_build,linguisttools_build,gui,opengl