aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2013-09-20 20:54:54 +0800
committerbdrewery <bdrewery@FreeBSD.org>2013-09-20 20:54:54 +0800
commitd6c170198e97f1109801df05948762e423645c4b (patch)
treee61ab76efa292f985d8e20e449572329fa964c1c /emulators
parent6174635d1f2fb489f2267a3388ddd0cc658b8c00 (diff)
downloadfreebsd-ports-gnome-d6c170198e97f1109801df05948762e423645c4b.tar.gz
freebsd-ports-gnome-d6c170198e97f1109801df05948762e423645c4b.tar.zst
freebsd-ports-gnome-d6c170198e97f1109801df05948762e423645c4b.zip
SSP support has been added to ports with WITH_SSP for i386 and amd64
on FreeBSD 10, and amd64 on earlier versions. SSP_UNSAFE is added to disable in a port if it fails to build, but this should only be used in rare circumstances such as kernel modules. Otherwise, the port may just be failing due to lack of respecting LDFLAGS. On FreeBSD 10, this uses an ldscript in /usr/lib/libc.so to pull in libssp_nonshared.a to address issues linking on i386 [1]. On earlier FreeBSD versions the WITH_SSP knob will add -lssp_nonshared to LDFLAGS on i386. This is not needed on amd64. However, several hundred ports do not currently respect LDFLAGS, so this support is disabled currently as it causes build failures if a dependency is looking for the stack_chk symbols. Many thanks to jlh@ for this as he had many years of patience in getting all of the necessary pieces [1][2] in. [1] http://svnweb.freebsd.org/base/head/lib/libc/libc.ldscript?revision=251668&view=markup PR: ports/138228 [2] Submitted by: jlh (bsd.ssp.mk based on) Reviewed by: bapt With hat: portmgr exp-runs done: 37 over a month on 91i386,91amd64,10i386,10amd64
Diffstat (limited to 'emulators')
-rw-r--r--emulators/kqemu-kmod-devel/Makefile2
-rw-r--r--emulators/kqemu-kmod/Makefile2
-rw-r--r--emulators/open-vm-tools/Makefile2
-rw-r--r--emulators/parallels-tools/Makefile7
-rw-r--r--emulators/rtc/Makefile7
5 files changed, 10 insertions, 10 deletions
diff --git a/emulators/kqemu-kmod-devel/Makefile b/emulators/kqemu-kmod-devel/Makefile
index 181dde346e7d..63e78af63933 100644
--- a/emulators/kqemu-kmod-devel/Makefile
+++ b/emulators/kqemu-kmod-devel/Makefile
@@ -19,6 +19,8 @@ COMMENT= Kernel Accelerator for QEMU CPU Emulator (development version)
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+SSP_UNSAFE= kernel module does not support ssp
+
ONLY_FOR_ARCHS= i386 amd64
HAS_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/emulators/kqemu-kmod/Makefile b/emulators/kqemu-kmod/Makefile
index 7d9c5aad4ee1..3283821e51e7 100644
--- a/emulators/kqemu-kmod/Makefile
+++ b/emulators/kqemu-kmod/Makefile
@@ -19,6 +19,8 @@ COMMENT= Kernel Accelerator for QEMU CPU Emulator
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+SSP_UNSAFE= kernel module does not support ssp
+
ONLY_FOR_ARCHS= i386 amd64
HAS_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/emulators/open-vm-tools/Makefile b/emulators/open-vm-tools/Makefile
index a2caf938d450..45dca188c45c 100644
--- a/emulators/open-vm-tools/Makefile
+++ b/emulators/open-vm-tools/Makefile
@@ -24,6 +24,8 @@ USES= pkgconfig
USE_LDCONFIG= yes
CPPFLAGS+= -Wno-deprecated-declarations
+SSP_UNSAFE= kernel module does not support ssp
+
CONFIGURE_ARGS+= --without-procps --sysconfdir=${LOCALBASE}/etc
.if defined(WITHOUT_X11)
LIB_DEPENDS+= glib-2.0:${PORTSDIR}/devel/glib20
diff --git a/emulators/parallels-tools/Makefile b/emulators/parallels-tools/Makefile
index 034a37f6ce8f..690322a71fc1 100644
--- a/emulators/parallels-tools/Makefile
+++ b/emulators/parallels-tools/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: parallels-tools
-# Date created: 14 Jun 2009
-# Whom: Alexander Nedotsukov <bland@FreeBSD.org>
-#
+# Created by: Alexander Nedotsukov <bland@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= parallels-tools
PORTVERSION= 0.1.1
@@ -14,6 +10,7 @@ MASTER_SITE_SUBDIR= bland
MAINTAINER= bland@FreeBSD.org
COMMENT= Parallels Desktop Tools for FreeBSD
+SSP_UNSAFE= kernel module does not support ssp
USE_BZIP2= yes
ONLY_FOR_ARCHS= amd64 i386
diff --git a/emulators/rtc/Makefile b/emulators/rtc/Makefile
index ce5856a2af5e..6cddc08adeba 100644
--- a/emulators/rtc/Makefile
+++ b/emulators/rtc/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: rtc
-# Date created: 28 March 2000
-# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
-#
+# Created by: Akinori MUSHA aka knu <knu@idaemons.org>
# $FreeBSD$
-#
PORTNAME= rtc
PORTVERSION= 2004.02.24.1
@@ -17,6 +13,7 @@ COMMENT= Kernel module which provides /dev/rtc device support
WRKSRC= ${WRKDIR}/files
+SSP_UNSAFE= kernel module does not support ssp
NO_FETCH= yes
USE_LINUX= yes # because of ${DEVDIR}