aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2004-12-28 17:45:47 +0800
committerobrien <obrien@FreeBSD.org>2004-12-28 17:45:47 +0800
commit096bef1573e8e10c0282718c10dd95de7227f29f (patch)
tree91dc895acd1c16d873e3994dc92cd2996fff4629 /emulators
parentb233ea86f6fef48f45a91d1c743996b2bc5a7f01 (diff)
downloadfreebsd-ports-gnome-096bef1573e8e10c0282718c10dd95de7227f29f.tar.gz
freebsd-ports-gnome-096bef1573e8e10c0282718c10dd95de7227f29f.tar.zst
freebsd-ports-gnome-096bef1573e8e10c0282718c10dd95de7227f29f.zip
Use NO_MTREE to have a cleaner LINUXBASE.
Submitted by: trevor Pointed out by: kris
Diffstat (limited to 'emulators')
-rw-r--r--emulators/linux_base-gentoo-stage1/Makefile5
-rw-r--r--emulators/linux_dist-gentoo-stage1/Makefile5
2 files changed, 6 insertions, 4 deletions
diff --git a/emulators/linux_base-gentoo-stage1/Makefile b/emulators/linux_base-gentoo-stage1/Makefile
index af3c336da58e..642486d37387 100644
--- a/emulators/linux_base-gentoo-stage1/Makefile
+++ b/emulators/linux_base-gentoo-stage1/Makefile
@@ -24,7 +24,7 @@ USE_BZIP2= y
.if (${ARCH} == "amd64")
LATEST_LINK= ${PORTNAME:C/linux_base/linux32_base/}
-ARCH= i386
+ARCH= i386
.endif
.if (${ARCH} == "alpha")
@@ -45,6 +45,7 @@ DIST_SUBDIR= gentoo-linux
MD5_FILE= ${MASTERDIR}/distinfo.${ARCH}
PLIST= ${WRKDIR}/pkg-plist
PREFIX= ${LINUXBASE}
+NO_MTREE= y
NO_FILTER_SHLIBS=y
CONFLICTS= linux_base-6* linux_base-7* linux_base-8* linux_base-debian*
@@ -54,7 +55,7 @@ do-build:
> ${WRKDIR}/tarball-contents
${GREP} -v '/$$' ${WRKDIR}/tarball-contents >> ${PLIST}
${GREP} '/$$' ${WRKDIR}/tarball-contents | ${SED} -e "s:^:@dirrm :g" \
- | ${GREP} -v '@dirrm etc/' | ${SORT} -r >> ${PLIST}
+ | ${SORT} -r >> ${PLIST}
do-install:
@${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
diff --git a/emulators/linux_dist-gentoo-stage1/Makefile b/emulators/linux_dist-gentoo-stage1/Makefile
index af3c336da58e..642486d37387 100644
--- a/emulators/linux_dist-gentoo-stage1/Makefile
+++ b/emulators/linux_dist-gentoo-stage1/Makefile
@@ -24,7 +24,7 @@ USE_BZIP2= y
.if (${ARCH} == "amd64")
LATEST_LINK= ${PORTNAME:C/linux_base/linux32_base/}
-ARCH= i386
+ARCH= i386
.endif
.if (${ARCH} == "alpha")
@@ -45,6 +45,7 @@ DIST_SUBDIR= gentoo-linux
MD5_FILE= ${MASTERDIR}/distinfo.${ARCH}
PLIST= ${WRKDIR}/pkg-plist
PREFIX= ${LINUXBASE}
+NO_MTREE= y
NO_FILTER_SHLIBS=y
CONFLICTS= linux_base-6* linux_base-7* linux_base-8* linux_base-debian*
@@ -54,7 +55,7 @@ do-build:
> ${WRKDIR}/tarball-contents
${GREP} -v '/$$' ${WRKDIR}/tarball-contents >> ${PLIST}
${GREP} '/$$' ${WRKDIR}/tarball-contents | ${SED} -e "s:^:@dirrm :g" \
- | ${GREP} -v '@dirrm etc/' | ${SORT} -r >> ${PLIST}
+ | ${SORT} -r >> ${PLIST}
do-install:
@${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL