aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-01-01 21:42:54 +0800
committerjbeich <jbeich@FreeBSD.org>2018-01-01 21:42:54 +0800
commit19a63bf6383364ed5252a57b59c80c095b02cf7b (patch)
tree38db9f1d8ee32af4ab5c52ef2f7c2b9aef2a174d /emulators
parentbe214fa55f98d07d26bc2bc15cbea7862456485c (diff)
downloadfreebsd-ports-gnome-19a63bf6383364ed5252a57b59c80c095b02cf7b.tar.gz
freebsd-ports-gnome-19a63bf6383364ed5252a57b59c80c095b02cf7b.tar.zst
freebsd-ports-gnome-19a63bf6383364ed5252a57b59c80c095b02cf7b.zip
Improve CMake style in my ports
- Convert to CMAKE_{ON,OFF} helpers - Convert to _CMAKE_BOOL option helpers - android-file-transfer: Share _CMAKE_BOOL via _IMPLIES - Annotate types
Diffstat (limited to 'emulators')
-rw-r--r--emulators/ppsspp/Makefile3
-rw-r--r--emulators/rpcs3/Makefile2
2 files changed, 3 insertions, 2 deletions
diff --git a/emulators/ppsspp/Makefile b/emulators/ppsspp/Makefile
index 6b699d087cc1..4d82fef3a2cc 100644
--- a/emulators/ppsspp/Makefile
+++ b/emulators/ppsspp/Makefile
@@ -35,7 +35,8 @@ EXCLUDE= libzip zlib
EXTRACT_AFTER_ARGS=${EXCLUDE:S,^,--exclude ,}
USE_GL= gl glew glu
USE_SDL= sdl2 # joystick
-CMAKE_ARGS= -DUSING_EGL=off -DUSE_SYSTEM_FFMPEG=on
+CMAKE_ON= USE_SYSTEM_FFMPEG
+CMAKE_OFF= USING_EGL
SUB_FILES= pkg-message
PORTDATA= assets ${PORTNAME}
diff --git a/emulators/rpcs3/Makefile b/emulators/rpcs3/Makefile
index 7969a5d6c831..16be7eca32e2 100644
--- a/emulators/rpcs3/Makefile
+++ b/emulators/rpcs3/Makefile
@@ -40,7 +40,7 @@ USE_XORG= x11
EXTRA_PATCHES+= ${EXTRA_PATCHES_${OPSYS}_${OSREL}}
EXTRA_PATCHES_FreeBSD_10.3= ${PATCHDIR}/extra-patch-no-thread_local
CONFIGURE_ENV+= TRAVIS=1 # XXX Rename to be less generic
-CMAKE_ARGS+= -DCMAKE_SKIP_RPATH=on -DUSE_SYSTEM_LIBPNG=on -DUSE_SYSTEM_FFMPEG=on
+CMAKE_ON= CMAKE_SKIP_RPATH USE_SYSTEM_FFMPEG USE_SYSTEM_LIBPNG
CXXFLAGS+= -D_GLIBCXX_USE_C99 # XXX ports/193528
CXXFLAGS+= -Wno-macro-redefined # __STDC_*_MACROS sys/cdefs.h vs. llvm-config
LDFLAGS+= -Wl,--as-needed # GLU