aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-10-21 20:51:40 +0800
committermat <mat@FreeBSD.org>2016-10-21 20:51:40 +0800
commit316cf6317eb621c4567d3b8e337fa9ba3097ea56 (patch)
tree5b70e6802d6d9dfe8b4564fc4f09f2d0a5156343 /emulators
parent5b45061f15be292aed8143f0ec15163936e69baf (diff)
downloadfreebsd-ports-gnome-316cf6317eb621c4567d3b8e337fa9ba3097ea56.tar.gz
freebsd-ports-gnome-316cf6317eb621c4567d3b8e337fa9ba3097ea56.tar.zst
freebsd-ports-gnome-316cf6317eb621c4567d3b8e337fa9ba3097ea56.zip
${RM} already has -f.
PR: 213570 Submitted by: mat Exp-run by: antoine Sponsored by: Absolight
Diffstat (limited to 'emulators')
-rw-r--r--emulators/i386-wine-devel/Makefile.inc4
-rw-r--r--emulators/i386-wine/Makefile.inc4
-rw-r--r--emulators/ia64sim/Makefile2
-rw-r--r--emulators/mupen64plus-core/Makefile.common2
-rw-r--r--emulators/vice/Makefile2
-rw-r--r--emulators/virtio-kmod/Makefile2
-rw-r--r--emulators/visualboyadvance-m/Makefile2
-rw-r--r--emulators/x49gp/Makefile2
8 files changed, 10 insertions, 10 deletions
diff --git a/emulators/i386-wine-devel/Makefile.inc b/emulators/i386-wine-devel/Makefile.inc
index aa1861cfffd8..7ed54198adb6 100644
--- a/emulators/i386-wine-devel/Makefile.inc
+++ b/emulators/i386-wine-devel/Makefile.inc
@@ -75,7 +75,7 @@ DISTFILES=
.endif
do-extract:
- @${RM} -rf ${WRKDIR}
+ @${RM} -r ${WRKDIR}
@${MKDIR} ${WRKDIR}
${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/${EXTRACT_ONLY} -C ${WRKDIR} --include '/usr/local/share/licenses/${DISTNAME}/LICENSE' -s '|/usr/local/share/licenses/${DISTNAME}/||g'
@@ -87,7 +87,7 @@ ${PLIST}: fetch
${TAR} -tf ${_DISTDIR}/${EXTRACT_ONLY} ${EXTRACT_AFTER_ARGS} | ${GREP} -v '/$$\|ldconfig32' | ${SED} 's|/usr/local/||g' | sort > ${PLIST}
port-update:
- ${RM} -f ${SLAVEDIR}/distinfo ${SLAVEDIR}/distinfo~ ${SLAVEDIR}/pkg-plist.*
+ ${RM} ${SLAVEDIR}/distinfo ${SLAVEDIR}/distinfo~ ${SLAVEDIR}/pkg-plist.*
.for osrel in 9 10 11 12
.for suffix in -devel -staging
${MAKE} fetch OSREL=${osrel} OSVERSION=${osrel}99999 UNAME_r=${osrel} PKGNAMESUFFIX=${suffix}
diff --git a/emulators/i386-wine/Makefile.inc b/emulators/i386-wine/Makefile.inc
index 98f60d8209ec..852a4a2507c5 100644
--- a/emulators/i386-wine/Makefile.inc
+++ b/emulators/i386-wine/Makefile.inc
@@ -63,7 +63,7 @@ DISTFILES=
.endif
do-extract:
- @${RM} -rf ${WRKDIR}
+ @${RM} -r ${WRKDIR}
@${MKDIR} ${WRKDIR}
${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/${EXTRACT_ONLY} -C ${WRKDIR} --include '/usr/local/share/licenses/${DISTNAME}/LICENSE' -s '|/usr/local/share/licenses/${DISTNAME}/||g'
@@ -74,7 +74,7 @@ ${PLIST}: fetch
${TAR} -tf ${_DISTDIR}/${EXTRACT_ONLY} ${EXTRACT_AFTER_ARGS} | ${GREP} -v '/$$\|ldconfig32' | ${SED} 's|/usr/local/||g' | sort > ${PLIST}
port-update:
- ${RM} -f ${SLAVEDIR}/distinfo ${SLAVEDIR}/distinfo~ ${SLAVEDIR}/pkg-plist.*
+ ${RM} ${SLAVEDIR}/distinfo ${SLAVEDIR}/distinfo~ ${SLAVEDIR}/pkg-plist.*
.for osrel in 9 10 11 12
${MAKE} fetch OSREL=${osrel} OSVERSION=${osrel}99999 UNAME_r=${osrel}
${MAKE} makesum OSREL=${osrel} OSVERSION=${osrel}99999 UNAME_r=${osrel}
diff --git a/emulators/ia64sim/Makefile b/emulators/ia64sim/Makefile
index 2dc43b7c5492..bb781901dce9 100644
--- a/emulators/ia64sim/Makefile
+++ b/emulators/ia64sim/Makefile
@@ -25,7 +25,7 @@ PORTDOCS= ia64user.txt readme
OPTIONS_DEFINE= DOCS
pre-build:
- @${RM} -f ${WRKSRC}/obj/*.o ${WRKSRC}/ia64sim
+ @${RM} ${WRKSRC}/obj/*.o ${WRKSRC}/ia64sim
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ia64sim ${STAGEDIR}${PREFIX}/bin
diff --git a/emulators/mupen64plus-core/Makefile.common b/emulators/mupen64plus-core/Makefile.common
index 4ffcb2c7b9f1..7f419af1fcfc 100644
--- a/emulators/mupen64plus-core/Makefile.common
+++ b/emulators/mupen64plus-core/Makefile.common
@@ -42,7 +42,7 @@ post-patch:
. endif
pre-install:
- @${RM} -f ${PLIST}
+ @${RM} ${PLIST}
. if ${PKGNAMESUFFIX} == "-video-rice"
@${ECHO_CMD} "%%DATADIR%%/RiceVideoLinux.ini" >> ${PLIST}
. endif
diff --git a/emulators/vice/Makefile b/emulators/vice/Makefile
index 6872edf04945..4b53e46ef6ab 100644
--- a/emulators/vice/Makefile
+++ b/emulators/vice/Makefile
@@ -142,7 +142,7 @@ USE_SDL= sdl
.endif
post-extract:
- @${RM} -f ${WRKSRC}/doc/vice.info*
+ @${RM} ${WRKSRC}/doc/vice.info*
post-patch:
${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" \
diff --git a/emulators/virtio-kmod/Makefile b/emulators/virtio-kmod/Makefile
index 15c235571f4f..5fadbcb4c9e4 100644
--- a/emulators/virtio-kmod/Makefile
+++ b/emulators/virtio-kmod/Makefile
@@ -68,7 +68,7 @@ maintainer-tar:
cd ${EXPDIR} && svn export -r ${SVN_REV} ${SVN_MIRROR}/stable/9/sys/dev/virtio dev/virtio
cd ${EXPDIR} && svn export -r ${SVN_REV} ${SVN_MIRROR}/stable/9/sys/modules/virtio modules/virtio
cd ${EXPDIR} && ${TAR} cfvz ${DISTDIR}/${FILE_9} dev modules
- cd ${EXPDIR} && ${RM} -rf dev modules
+ cd ${EXPDIR} && ${RM} -r dev modules
cd ${EXPDIR} && svn export -r ${SVN_REV} ${SVN_MIRROR}/stable/8/sys/dev/virtio dev/virtio
cd ${EXPDIR} && svn export -r ${SVN_REV} ${SVN_MIRROR}/stable/8/sys/modules/virtio modules/virtio
cd ${EXPDIR} && ${TAR} cfvz ${DISTDIR}/${FILE_8} dev modules
diff --git a/emulators/visualboyadvance-m/Makefile b/emulators/visualboyadvance-m/Makefile
index 0d1b4562edfe..2cf9571fee01 100644
--- a/emulators/visualboyadvance-m/Makefile
+++ b/emulators/visualboyadvance-m/Makefile
@@ -134,7 +134,7 @@ maint-gen-distfile:
svn export -r${SVN_REV} \
https://svn.code.sf.net/p/vbam/code/trunk/ ${DISTNAME}
${TAR} jcf ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}
- ${RM} -rf ${DISTNAME}
+ ${RM} -r ${DISTNAME}
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/vbam
diff --git a/emulators/x49gp/Makefile b/emulators/x49gp/Makefile
index 37d1e22ae154..b09406031b5a 100644
--- a/emulators/x49gp/Makefile
+++ b/emulators/x49gp/Makefile
@@ -89,7 +89,7 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/x49gp ${STAGEDIR}${PREFIX}/bin/x49gp-bin
${INSTALL_SCRIPT} ${WRKDIR}/hp50g.sh ${STAGEDIR}${PREFIX}/bin/hp50g
- ${RM} -f ${STAGEDIR}${PREFIX}/bin/hp49g+
+ ${RM} ${STAGEDIR}${PREFIX}/bin/hp49g+
${LN} ${STAGEDIR}${PREFIX}/bin/hp50g ${STAGEDIR}${PREFIX}/bin/hp49g+
${INSTALL_DATA} ${DISTDIR}/sdcard64.tar.gz ${STAGEDIR}${DATADIR}/