aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-01-04 01:06:49 +0800
committerjbeich <jbeich@FreeBSD.org>2017-01-04 01:06:49 +0800
commit35c2e924fb42c40faceb06c6ff4d7a400a8ddea2 (patch)
tree0c4d0c1f381f4e3e76b7e77408205f35afe358fa /emulators
parentd25310f9b4145788c026d4bcec327bf8f633e309 (diff)
downloadfreebsd-ports-gnome-35c2e924fb42c40faceb06c6ff4d7a400a8ddea2.tar.gz
freebsd-ports-gnome-35c2e924fb42c40faceb06c6ff4d7a400a8ddea2.tar.zst
freebsd-ports-gnome-35c2e924fb42c40faceb06c6ff4d7a400a8ddea2.zip
Assume "pkg-config zlib" works after 9.x reached EOL
Many ports passed ZLIB_CFLAGS="-I/usr/include" ZLIB_LIBS="-L/usr/lib -lz" which is unsafe at least with lang/gcc* that override some system headers and have newer libgcc_s.so that our old version in base may not be forward-compatible with.
Diffstat (limited to 'emulators')
-rw-r--r--emulators/mupen64plus-core/files/patch-source_mupen64plus-core_projects_unix_Makefile26
-rw-r--r--emulators/mupen64plus-video-glide64mk2/files/patch-source-mupen64plus-video-glide64mk2-projects-unix_Makefile11
2 files changed, 0 insertions, 37 deletions
diff --git a/emulators/mupen64plus-core/files/patch-source_mupen64plus-core_projects_unix_Makefile b/emulators/mupen64plus-core/files/patch-source_mupen64plus-core_projects_unix_Makefile
deleted file mode 100644
index 04a8ee08832f..000000000000
--- a/emulators/mupen64plus-core/files/patch-source_mupen64plus-core_projects_unix_Makefile
+++ /dev/null
@@ -1,26 +0,0 @@
---- source/mupen64plus-core/projects/unix/Makefile 2015-04-26 17:42:49.000000000 -0500
-+++ source/mupen64plus-core/projects/unix/Makefile 2015-06-12 17:54:03.000000000 -0500
-@@ -227,6 +227,10 @@
- ZLIB_LDLIBS += -lz
- endif
-
-+ifeq ($(OS), FREEBSD) # use system zlib on FreeBSD
-+ ZLIB_LDLIBS += -lz
-+endif
-+
- ifeq ($(origin ZLIB_CFLAGS) $(origin ZLIB_LDLIBS), undefined undefined)
- ifeq ($(shell $(PKG_CONFIG) --modversion zlib 2>/dev/null),)
- $(error No zlib development libraries found!)
-@@ -247,6 +251,12 @@
- CFLAGS += $(LIBPNG_CFLAGS)
- LDLIBS += $(LIBPNG_LDLIBS)
-
-+ifeq ($(OS), FREEBSD)
-+ SDL_CFLAGS += $(shell $(SDL2_CONFIG) --cflags)
-+ SDL_LDLIBS += $(shell $(SDL2_CONFIG) --libs)
-+endif
-+
-+
- # test for presence of SDL
- ifeq ($(origin SDL_CFLAGS) $(origin SDL_LDLIBS), undefined undefined)
- SDL_CONFIG = $(CROSS_COMPILE)sdl2-config
diff --git a/emulators/mupen64plus-video-glide64mk2/files/patch-source-mupen64plus-video-glide64mk2-projects-unix_Makefile b/emulators/mupen64plus-video-glide64mk2/files/patch-source-mupen64plus-video-glide64mk2-projects-unix_Makefile
index b0022b62df36..51b6739041b3 100644
--- a/emulators/mupen64plus-video-glide64mk2/files/patch-source-mupen64plus-video-glide64mk2-projects-unix_Makefile
+++ b/emulators/mupen64plus-video-glide64mk2/files/patch-source-mupen64plus-video-glide64mk2-projects-unix_Makefile
@@ -17,17 +17,6 @@
endif
ifeq ($(origin PKG_CONFIG), undefined)
-@@ -199,6 +200,10 @@
- ZLIB_LDLIBS += -lz
- endif
-
-+ifeq ($(OS), FREEBSD) # use system zlib on FreeBSD
-+ ZLIB_LDLIBS += -lz
-+endif
-+
- ifeq ($(origin ZLIB_CFLAGS) $(origin ZLIB_LDLIBS), undefined undefined)
- ifeq ($(shell $(PKG_CONFIG) --modversion zlib 2>/dev/null),)
- $(error No zlib development libraries found!)
@@ -292,8 +297,8 @@
endif