aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2005-01-16 11:56:35 +0800
committerobrien <obrien@FreeBSD.org>2005-01-16 11:56:35 +0800
commit50c11e89af6d1496e6c2c07431c6908f48384ab9 (patch)
tree4fe56cefc5dff7b5acc2d2ad2c7152d8f9a7d47b /emulators
parent4cad8f2036e1dd4dd4ec9249fe571b9d2dbd468f (diff)
downloadfreebsd-ports-gnome-50c11e89af6d1496e6c2c07431c6908f48384ab9.tar.gz
freebsd-ports-gnome-50c11e89af6d1496e6c2c07431c6908f48384ab9.tar.zst
freebsd-ports-gnome-50c11e89af6d1496e6c2c07431c6908f48384ab9.zip
Follow the porter's handbook and allow 'make all' to be run by a moral user.
Diffstat (limited to 'emulators')
-rw-r--r--emulators/linux_base-8/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/emulators/linux_base-8/Makefile b/emulators/linux_base-8/Makefile
index a4726a2945da..b7205815b727 100644
--- a/emulators/linux_base-8/Makefile
+++ b/emulators/linux_base-8/Makefile
@@ -49,6 +49,7 @@ DISTFILES= redhat-release-8.0-8.noarch.rpm \
libgcc-3.2-7.${ARCH}.rpm \
freetype-2.1.5-0.ximian.5.1.${ARCH}.rpm:ft \
zlib-1.1.4-8.8x.${ARCH}.rpm:new
+EXTRACT_ONLY=
MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= Base set of packages needed in Linux mode (only for i386)
@@ -98,7 +99,7 @@ FALLBACK_ELF_MIB= kern.fallback_elf_brand
LINUX_ELF= 3
PREVIOUS_ELF!= /sbin/sysctl -n ${FALLBACK_ELF_MIB}
-do-extract:
+do-install:
#
# Handle the loading of the linux loadable kernel module if required.
@${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
@@ -142,14 +143,16 @@ do-extract:
${RM} -f ${WRKSRC}/$$F; \
done
@${LN} -sf /var/tmp ${WRKSRC}/usr/tmp
-
-pre-install:
+#
+# Create PLIST
+#
${RM} -f ${PLIST}
cd ${WRKSRC} && ${FIND} -s . -type f -o -type l | \
${CUT} -c3-999 >> ${PLIST} \
&& ${FIND} -d * -type d | ${SED} -e 's:^:@dirrm :' >> ${PLIST}
-
-do-install:
+#
+# The real do-install:
+#
cd ${WRKSRC} && ${FIND} * | ${CPIO} -dmp ${PREFIX}
${FIND} ${PREFIX} -type d -exec ${CHMOD} 755 \{\} \;