aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authordbn <dbn@FreeBSD.org>2015-04-02 02:37:29 +0800
committerdbn <dbn@FreeBSD.org>2015-04-02 02:37:29 +0800
commit66e63ec862379bcb54548603cb4a8f9901510008 (patch)
tree6ceacaf861f750247c23da0e34be185e5c3ed42c /emulators
parent2915dc123807683885f1fd6b7ac7293415f715f2 (diff)
downloadfreebsd-ports-gnome-66e63ec862379bcb54548603cb4a8f9901510008.tar.gz
freebsd-ports-gnome-66e63ec862379bcb54548603cb4a8f9901510008.tar.zst
freebsd-ports-gnome-66e63ec862379bcb54548603cb4a8f9901510008.zip
emulators/wine-devel: unbreak build.
Changes: * Add CPPBIN="${CPP}" to CONFIGURE_ENV as Wine uses $CPPBIN, instead of $CPP, in ./configure * Use CHOSEN_COMPILER_TYPE instead of COMPILER_TYPE. The later is what the base compiler is whereas the former to what is chosen to satisfy USES=compiler:c11 PR: 199098 Reported by: pkg-fallout, gerald@
Diffstat (limited to 'emulators')
-rw-r--r--emulators/wine-devel/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index e720b928de21..ef5b733c016a 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -37,7 +37,7 @@ CONFIGURE_ARGS+=--verbose --disable-tests \
--without-sane \
--without-tiff \
--without-xinerama
-CONFIGURE_ENV= FLEX="${LOCALBASE}/bin/flex"
+CONFIGURE_ENV= CPPBIN="${CPP}" FLEX="${LOCALBASE}/bin/flex"
WINELIBDIR?= ${PREFIX}/lib
.if !defined(USE_LDCONFIG32)
USE_LDCONFIG= ${WINELIBDIR} ${WINELIBDIR}/wine
@@ -120,7 +120,7 @@ X11_LIB_DEPENDS= libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
CONFIGURE_ARGS+= --enable-win64 --libdir=${PREFIX}/lib
PLIST_SUB+= WINE32="@comment " WINE64=""
-.if ${COMPILER_TYPE} == clang
+.if ${CHOSEN_COMPILER_TYPE} == clang
CPPFLAGS+= -D__builtin_ms_va_list=__builtin_va_list \
-D__builtin_ms_va_start=__builtin_va_start \
-D__builtin_ms_va_end=__builtin_va_end \