aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-04-21 16:43:45 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-04-21 16:43:45 +0800
commit91b09a908007af30f92b070caee5dd096c8a1ba8 (patch)
tree763286ad75def2cd6f02a545baf3261646b80932 /emulators
parentd8dafa942b791ed1bfa603b80d3dd5c616e2edeb (diff)
downloadfreebsd-ports-gnome-91b09a908007af30f92b070caee5dd096c8a1ba8.tar.gz
freebsd-ports-gnome-91b09a908007af30f92b070caee5dd096c8a1ba8.tar.zst
freebsd-ports-gnome-91b09a908007af30f92b070caee5dd096c8a1ba8.zip
- Add LICENSE
- Fix shebangs - Add NO_ARCH - Regenerate patches - Fix WWW:
Diffstat (limited to 'emulators')
-rw-r--r--emulators/dynagui/Makefile9
-rw-r--r--emulators/dynagui/files/patch-dynagui.py8
-rw-r--r--emulators/dynagui/files/patch-libs_canvas.py6
-rw-r--r--emulators/dynagui/files/patch-libs_gui__c7200.py (renamed from emulators/dynagui/files/patch-libs_gui_c7200.py)6
-rw-r--r--emulators/dynagui/files/patch-setup.py4
-rw-r--r--emulators/dynagui/pkg-descr2
6 files changed, 20 insertions, 15 deletions
diff --git a/emulators/dynagui/Makefile b/emulators/dynagui/Makefile
index 5d834cf21ee8..bb28f60a3ba0 100644
--- a/emulators/dynagui/Makefile
+++ b/emulators/dynagui/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dynagui
PORTVERSION= 0.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= dynagui
@@ -11,11 +11,16 @@ DIST_SUBDIR= dynagui
MAINTAINER= ports@FreeBSD.org
COMMENT= GUI frontend to the dynamips router simulator
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= dynagen:emulators/dynagen
-USES= python
+USES= python shebangfix
+SHEBANG_FILES= dynagui.py
USE_PYTHON= distutils
IMGDIR= ${STAGEDIR}${PREFIX}/share/${PORTNAME}/img
+NO_ARCH= yes
post-install:
@${MKDIR} ${IMGDIR}
diff --git a/emulators/dynagui/files/patch-dynagui.py b/emulators/dynagui/files/patch-dynagui.py
index 80c0f5bfef4c..c012b977e6a9 100644
--- a/emulators/dynagui/files/patch-dynagui.py
+++ b/emulators/dynagui/files/patch-dynagui.py
@@ -1,6 +1,6 @@
---- dynagui.py.orig 2007-12-13 16:04:43.000000000 -0500
-+++ dynagui.py 2009-02-05 18:42:36.000000000 -0500
-@@ -27,17 +27,17 @@
+--- dynagui.py.orig 2007-12-13 21:04:43 UTC
++++ dynagui.py
+@@ -27,17 +27,17 @@ import sys
import pygtk; pygtk.require('2.0')
import gtk
import gobject
@@ -29,7 +29,7 @@
ui_popup = \
-@@ -509,7 +509,7 @@
+@@ -509,7 +509,7 @@ class DynaguiFrame(gtk.Window):
if len(lab.devices)>0:
text = 'Select routers from which to extract configuration'
rcd = RouterSelectionDialog(lab.devices, text, show_path=True)
diff --git a/emulators/dynagui/files/patch-libs_canvas.py b/emulators/dynagui/files/patch-libs_canvas.py
index 9f23d501a668..1fae1548d50a 100644
--- a/emulators/dynagui/files/patch-libs_canvas.py
+++ b/emulators/dynagui/files/patch-libs_canvas.py
@@ -1,6 +1,6 @@
---- libs/canvas.py.orig 2007-09-24 17:33:03.000000000 -0400
-+++ libs/canvas.py 2009-02-05 18:43:07.000000000 -0500
-@@ -25,19 +25,19 @@
+--- libs/canvas.py.orig 2007-09-24 21:33:03 UTC
++++ libs/canvas.py
+@@ -25,19 +25,19 @@ import gtk
import time
from gtk import gdk
import dynamips_lib
diff --git a/emulators/dynagui/files/patch-libs_gui_c7200.py b/emulators/dynagui/files/patch-libs_gui__c7200.py
index db6b3a1435d3..620ab4dcbc76 100644
--- a/emulators/dynagui/files/patch-libs_gui_c7200.py
+++ b/emulators/dynagui/files/patch-libs_gui__c7200.py
@@ -1,6 +1,6 @@
---- libs/gui_c7200.py.orig 2009-02-09 14:29:55.000000000 -0500
-+++ libs/gui_c7200.py 2009-02-09 14:30:28.000000000 -0500
-@@ -412,7 +412,7 @@
+--- libs/gui_c7200.py.orig 2007-10-31 18:55:27 UTC
++++ libs/gui_c7200.py
+@@ -412,7 +412,7 @@ class GuiC7200_IO_2FE(PA_C7200_IO_2FE):
class GuiC7200(C7200, GuiRouter):
pixmap = cairo.ImageSurface.create_from_png(
diff --git a/emulators/dynagui/files/patch-setup.py b/emulators/dynagui/files/patch-setup.py
index ecb888d654c5..c7bab1f8c026 100644
--- a/emulators/dynagui/files/patch-setup.py
+++ b/emulators/dynagui/files/patch-setup.py
@@ -1,5 +1,5 @@
---- setup.py.orig 1969-12-31 19:00:00.000000000 -0500
-+++ setup.py 2009-02-09 11:03:10.000000000 -0500
+--- setup.py.orig 2017-04-20 14:00:44 UTC
++++ setup.py
@@ -0,0 +1,20 @@
+#!/usr/bin/env python
+
diff --git a/emulators/dynagui/pkg-descr b/emulators/dynagui/pkg-descr
index 41f310387009..b59d71687404 100644
--- a/emulators/dynagui/pkg-descr
+++ b/emulators/dynagui/pkg-descr
@@ -2,4 +2,4 @@ Dynagui is a GUI frontend to the dynamips Cisco 7200/36XX router
simulator. It uses the dyna-gen library in order to communicate
with the dynamips hypervisor.
-WWW: http://dynagui.sourceforge.net
+WWW: http://dynagui.sourceforge.net/