aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-05-21 21:48:32 +0800
committerjylefort <jylefort@FreeBSD.org>2005-05-21 21:48:32 +0800
commita82fae4ee8cb8bb5b0341993754b14d4071990c5 (patch)
treecd0a85807eeeeb8f9d8083e70a3c244481555d4b /emulators
parenta169c70ecc556789aebc9a9ada35bf00ac1ec0f4 (diff)
downloadfreebsd-ports-gnome-a82fae4ee8cb8bb5b0341993754b14d4071990c5.tar.gz
freebsd-ports-gnome-a82fae4ee8cb8bb5b0341993754b14d4071990c5.tar.zst
freebsd-ports-gnome-a82fae4ee8cb8bb5b0341993754b14d4071990c5.zip
Update to 0.7.0
PR: ports/81064 Submitted by: Miguel Mendez <flynn@energyhq.es.eu.org> Approved by: maintainer
Diffstat (limited to 'emulators')
-rw-r--r--emulators/fuse/Makefile55
-rw-r--r--emulators/fuse/distinfo4
-rw-r--r--emulators/fuse/files/patch-osssound.c4
-rw-r--r--emulators/fuse/files/patch-ui_ggi_ggikeyboard.c.patch11
-rw-r--r--emulators/fuse/files/patch-z80_z80.pl15
-rw-r--r--emulators/fuse/pkg-plist37
6 files changed, 52 insertions, 74 deletions
diff --git a/emulators/fuse/Makefile b/emulators/fuse/Makefile
index 0de296d8e280..a2e2ab9fd4e5 100644
--- a/emulators/fuse/Makefile
+++ b/emulators/fuse/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= fuse
-PORTVERSION= 0.6.1.1
-PORTREVISION= 1
+PORTVERSION= 0.7.0
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= fuse-emulator
@@ -15,17 +14,28 @@ MASTER_SITE_SUBDIR= fuse-emulator
MAINTAINER= kemm@in-line.ru
COMMENT= Free Unix (Sinclair ZX-)Spectrum Emulator
-LIB_DEPENDS= spectrum.2:${PORTSDIR}/emulators/libspectrum \
- 765.3:${PORTSDIR}/emulators/lib765 \
+LIB_DEPENDS= spectrum.4:${PORTSDIR}/emulators/libspectrum \
+ 765.4:${PORTSDIR}/emulators/lib765 \
xml2.5:${PORTSDIR}/textproc/libxml2 \
png.5:${PORTSDIR}/graphics/png
+WANT_GNOME= yes
+WANT_SDL= yes
USE_XLIB= yes
USE_PERL5_BUILD= yes
USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-plus3-disk-prefix=${LOCALBASE}
+OPTIONS= SMALLMEM "Low memory compile needed" off \
+ GTK "Use GTK1 user interface" off \
+ GTK2 "Use GTK2 user interface" on \
+ SDL "Use SDL user interface" on \
+ SVGALIB "Use SVGAlib user interface" off \
+ GCRYPT "Support digital signing of .RZX files" off
+
+.include <bsd.port.pre.mk>
+
.if defined(WITH_SMALLMEM)
CONFIGURE_ARGS+= --enable-smallmem
.endif
@@ -36,6 +46,11 @@ USE_GNOME= gtk12
CONFIGURE_ARGS+= --without-gtk
.endif
+.if defined(WITH_GTK2)
+CONFIGURE_ARGS+= --with-gtk2
+USE_GNOME+= gtk20
+.endif
+
.if defined(WITH_SDL)
CONFIGURE_ARGS+= --with-sdl
USE_SDL= yes
@@ -46,42 +61,18 @@ CONFIGURE_ARGS+= --with-svgalib
LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
.endif
-.if defined(WITH_GGI)
-CONFIGURE_ARGS+= --with-ggi
-LIB_DEPENDS+= ggi.2:${PORTSDIR}/graphics/libggi
-.endif
-
-.if defined(WITH_GTK2)
-CONFIGURE_ARGS+= --with-gtk2
-USE_GNOME+= gtk20
-.endif
-
.if defined(WITH_GCRYPT) || exists(${LOCALBASE}/include/gcrypt.h)
CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
-LIB_DEPENDS+= gcrypt.6:${PORTSDIR}/security/libgcrypt
+LIB_DEPENDS+= gcrypt.13:${PORTSDIR}/security/libgcrypt
.endif
MAN1= fuse.1
-DOCS= AUTHORS ChangeLog README THANKS
-
-pre-everything::
- @${ECHO_MSG} ${CONFIGURE_ARGS}
- @${ECHO_MSG} ""
- @${ECHO_MSG} "You may use the following build options:"
- @${ECHO_MSG} ""
- @${ECHO_MSG} " WITH_SMALLMEM=yes low memory compile needed"
- @${ECHO_MSG} " WITHOUT_GTK=yes don't use GTK1 user interface"
- @${ECHO_MSG} " WITH_SDL=yes use SDL user interface"
- @${ECHO_MSG} " WITH_SVGALIB=yes use SVGAlib user interface"
- @${ECHO_MSG} " WITH_GGI=yes use GGI user interface"
- @${ECHO_MSG} " WITH_GTK2=yes use GTK2 user interface"
- @${ECHO_MSG} " WITH_GCRYPT=yes support digital signing of .RZX files"
- @${ECHO_MSG} ""
.if !defined(NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} AUTHORS ChangeLog README THANKS \
+ ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/emulators/fuse/distinfo b/emulators/fuse/distinfo
index d7a0ebe5d297..4a4c4a8809bb 100644
--- a/emulators/fuse/distinfo
+++ b/emulators/fuse/distinfo
@@ -1,2 +1,2 @@
-MD5 (fuse-0.6.1.1.tar.gz) = 6738574d0f01f758ed352a6d3cb5f4b1
-SIZE (fuse-0.6.1.1.tar.gz) = 509597
+MD5 (fuse-0.7.0.tar.gz) = d81ad260cd6a8dd533af01ee6a5f9527
+SIZE (fuse-0.7.0.tar.gz) = 872031
diff --git a/emulators/fuse/files/patch-osssound.c b/emulators/fuse/files/patch-osssound.c
index 4e3be61c9282..a91dc2cddf76 100644
--- a/emulators/fuse/files/patch-osssound.c
+++ b/emulators/fuse/files/patch-osssound.c
@@ -1,5 +1,5 @@
---- osssound.c.orig Sat Sep 13 16:53:12 2003
-+++ osssound.c Tue Oct 28 17:19:06 2003
+--- sound/osssound.c.orig Sat Sep 13 16:53:12 2003
++++ sound/osssound.c Tue Oct 28 17:19:06 2003
@@ -107,6 +107,7 @@
return 1;
}
diff --git a/emulators/fuse/files/patch-ui_ggi_ggikeyboard.c.patch b/emulators/fuse/files/patch-ui_ggi_ggikeyboard.c.patch
deleted file mode 100644
index f8a68f9bfbc9..000000000000
--- a/emulators/fuse/files/patch-ui_ggi_ggikeyboard.c.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ui/ggi/ggikeyboard.c.orig Sat Sep 13 16:53:48 2003
-+++ ui/ggi/ggikeyboard.c Tue Oct 28 14:52:14 2003
-@@ -43,6 +43,8 @@
- #include "widget/widget.h"
- #endif /* #ifdef USE_WIDGET */
-
-+#include "fuse.h"
-+
- void
- ggikeyboard_keypress( int keysym )
- {
diff --git a/emulators/fuse/files/patch-z80_z80.pl b/emulators/fuse/files/patch-z80_z80.pl
deleted file mode 100644
index 3abf1f8b92f1..000000000000
--- a/emulators/fuse/files/patch-z80_z80.pl
+++ /dev/null
@@ -1,15 +0,0 @@
---- z80/z80.pl.orig Sat Sep 13 16:53:54 2003
-+++ z80/z80.pl Tue Oct 28 13:00:53 2003
-@@ -1128,9 +1128,10 @@
-
- {
- no strict qw( refs );
-+ my $func = "opcode_$opcode";
-
-- if( exists &{ "opcode_$opcode" } ) {
-- "opcode_$opcode"->( @arguments );
-+ if( defined (&$func) ) {
-+ &$func( @arguments );
- }
- }
-
diff --git a/emulators/fuse/pkg-plist b/emulators/fuse/pkg-plist
index 437869634baa..d72ca2490c0f 100644
--- a/emulators/fuse/pkg-plist
+++ b/emulators/fuse/pkg-plist
@@ -1,30 +1,43 @@
@comment $FreeBSD$
bin/fuse
+share/fuse/128-0.rom
+share/fuse/128-1.rom
+share/fuse/128p-0.rom
+share/fuse/128p-1.rom
+share/fuse/256s-0.rom
+share/fuse/256s-1.rom
+share/fuse/256s-2.rom
+share/fuse/256s-3.rom
+share/fuse/48.rom
+share/fuse/cassette.bmp
share/fuse/disk_plus3.z80
share/fuse/keyboard.scr
+share/fuse/plus2-0.rom
+share/fuse/plus2-1.rom
+share/fuse/plus3-0.rom
+share/fuse/plus3-1.rom
+share/fuse/plus3-2.rom
+share/fuse/plus3-3.rom
+share/fuse/plus3disk.bmp
+share/fuse/plus3e-0.rom
+share/fuse/plus3e-1.rom
+share/fuse/plus3e-2.rom
+share/fuse/plus3e-3.rom
+share/fuse/se-0.rom
+share/fuse/se-1.rom
share/fuse/tape_128.z80
share/fuse/tape_16.z80
share/fuse/tape_2048.z80
share/fuse/tape_2068.z80
share/fuse/tape_48.z80
+share/fuse/tape_pentagon.z80
share/fuse/tape_plus2.z80
share/fuse/tape_plus2a.z80
share/fuse/tape_plus3.z80
-share/fuse/tape_pentagon.z80
-share/fuse/128-0.rom
-share/fuse/128-1.rom
-share/fuse/48.rom
-share/fuse/plus2-0.rom
-share/fuse/plus2-1.rom
-share/fuse/plus3-0.rom
-share/fuse/plus3-1.rom
-share/fuse/plus3-2.rom
-share/fuse/plus3-3.rom
+share/fuse/tape_scorpion.z80
share/fuse/tc2048.rom
share/fuse/tc2068-0.rom
share/fuse/tc2068-1.rom
-share/fuse/128p-0.rom
-share/fuse/128p-1.rom
share/fuse/trdos.rom
@dirrm share/fuse
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS