aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2008-05-21 03:06:15 +0800
committeracm <acm@FreeBSD.org>2008-05-21 03:06:15 +0800
commitb679b6dd09ef4967c988e95d4ec39dbe925deb14 (patch)
treeb675819236a1aa85e1f22abff94d34b02e10a280 /emulators
parente7419a96e55cdec60adbcb7a36b732da8c100ca5 (diff)
downloadfreebsd-ports-gnome-b679b6dd09ef4967c988e95d4ec39dbe925deb14.tar.gz
freebsd-ports-gnome-b679b6dd09ef4967c988e95d4ec39dbe925deb14.tar.zst
freebsd-ports-gnome-b679b6dd09ef4967c988e95d4ec39dbe925deb14.zip
- New port: emulators/mupen64plus-sdlinput
An input plugin for Mupen64Plus emulator
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/mupen64plus-input-sdl/Makefile24
-rw-r--r--emulators/mupen64plus-input-sdl/files/patch-blight_input_SDL_ttf.c19
-rw-r--r--emulators/mupen64plus-sdlinput/Makefile24
-rw-r--r--emulators/mupen64plus-sdlinput/files/patch-blight_input_SDL_ttf.c19
5 files changed, 87 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 24e8b6acf10f..873c9fed88e8 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -115,6 +115,7 @@
SUBDIR += mupen64plus-rice
SUBDIR += mupen64plus-rsp
SUBDIR += mupen64plus-sdlaudio
+ SUBDIR += mupen64plus-sdlinput
SUBDIR += nonpareil
SUBDIR += o2em
SUBDIR += ods2reader
diff --git a/emulators/mupen64plus-input-sdl/Makefile b/emulators/mupen64plus-input-sdl/Makefile
new file mode 100644
index 000000000000..62db916570da
--- /dev/null
+++ b/emulators/mupen64plus-input-sdl/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: mupen64plus-sdlinput
+# Date created: 2008-05-16
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PKGNAMESUFFIX= -sdlinput
+
+COMMENT= Blight's SDL input plugin for Mupen64plus
+
+LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+
+FIXFILES= #
+
+USE_SDL= sdl ttf
+
+PLUGIN_NAME= blight_input
+
+MASTERDIR= ${.CURDIR}/../mupen64plus-base
+
+OPTIONS= #
+
+.include "${MASTERDIR}/Makefile"
diff --git a/emulators/mupen64plus-input-sdl/files/patch-blight_input_SDL_ttf.c b/emulators/mupen64plus-input-sdl/files/patch-blight_input_SDL_ttf.c
new file mode 100644
index 000000000000..54d968d417df
--- /dev/null
+++ b/emulators/mupen64plus-input-sdl/files/patch-blight_input_SDL_ttf.c
@@ -0,0 +1,19 @@
+--- blight_input/SDL_ttf.c 2007-10-08 01:36:42.000000000 -0500
++++ blight_input/SDL_ttf.c 2007-10-08 01:39:03.000000000 -0500
+@@ -48,7 +48,6 @@
+ #include <freetype/ftoutln.h>
+ #include <freetype/ttnameid.h>
+ */
+-#include <freetype/internal/ftobjs.h>
+
+ #ifndef FT_OPEN_STREAM
+ #define FT_OPEN_STREAM ft_open_stream
+@@ -275,7 +274,7 @@
+ }
+ memset(stream, 0, sizeof(*stream));
+
+- stream->memory = library->memory;
++ stream->memory = NULL;
+ stream->read = RWread;
+ stream->descriptor.pointer = src;
+ stream->pos = (unsigned long)position;
diff --git a/emulators/mupen64plus-sdlinput/Makefile b/emulators/mupen64plus-sdlinput/Makefile
new file mode 100644
index 000000000000..62db916570da
--- /dev/null
+++ b/emulators/mupen64plus-sdlinput/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: mupen64plus-sdlinput
+# Date created: 2008-05-16
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PKGNAMESUFFIX= -sdlinput
+
+COMMENT= Blight's SDL input plugin for Mupen64plus
+
+LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+
+FIXFILES= #
+
+USE_SDL= sdl ttf
+
+PLUGIN_NAME= blight_input
+
+MASTERDIR= ${.CURDIR}/../mupen64plus-base
+
+OPTIONS= #
+
+.include "${MASTERDIR}/Makefile"
diff --git a/emulators/mupen64plus-sdlinput/files/patch-blight_input_SDL_ttf.c b/emulators/mupen64plus-sdlinput/files/patch-blight_input_SDL_ttf.c
new file mode 100644
index 000000000000..54d968d417df
--- /dev/null
+++ b/emulators/mupen64plus-sdlinput/files/patch-blight_input_SDL_ttf.c
@@ -0,0 +1,19 @@
+--- blight_input/SDL_ttf.c 2007-10-08 01:36:42.000000000 -0500
++++ blight_input/SDL_ttf.c 2007-10-08 01:39:03.000000000 -0500
+@@ -48,7 +48,6 @@
+ #include <freetype/ftoutln.h>
+ #include <freetype/ttnameid.h>
+ */
+-#include <freetype/internal/ftobjs.h>
+
+ #ifndef FT_OPEN_STREAM
+ #define FT_OPEN_STREAM ft_open_stream
+@@ -275,7 +274,7 @@
+ }
+ memset(stream, 0, sizeof(*stream));
+
+- stream->memory = library->memory;
++ stream->memory = NULL;
+ stream->read = RWread;
+ stream->descriptor.pointer = src;
+ stream->pos = (unsigned long)position;