aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-08-30 18:51:41 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-08-30 18:51:41 +0800
commitbab65f32b1f5669a676066a93c42fdc6646881dd (patch)
treef88dcbbad388d7e4a3460de9c549fc2e33b15c1a /emulators
parent2cd95c013282c858603eee63f5cd5c43ef9bc6ab (diff)
downloadfreebsd-ports-gnome-bab65f32b1f5669a676066a93c42fdc6646881dd.tar.gz
freebsd-ports-gnome-bab65f32b1f5669a676066a93c42fdc6646881dd.tar.zst
freebsd-ports-gnome-bab65f32b1f5669a676066a93c42fdc6646881dd.zip
- Add LICENSE
- Pet portlint - Switch to @sample Approved by: portmgr blanket
Diffstat (limited to 'emulators')
-rw-r--r--emulators/qemu/Makefile9
-rw-r--r--emulators/qemu/pkg-plist8
2 files changed, 8 insertions, 9 deletions
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index a88ef53ab569..d8859b953530 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -12,8 +12,11 @@ DIST_SUBDIR= qemu
MAINTAINER= nox@FreeBSD.org
COMMENT= QEMU CPU Emulator
+LICENSE= GPLv2 # or later
+LICENSE_FILE= ${WRKSRC}/COPYING
+
HAS_CONFIGURE= yes
-USES= cpe gmake perl5 compiler:features
+USES= compiler:features cpe gmake perl5
USE_PERL5= build
PATCH_STRIP= -p1
MAKE_ENV+= BSD_MAKE="${MAKE}"
@@ -156,7 +159,7 @@ post-configure:
${WRKSRC}/config-host.mak
post-install:
- @${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifup.sample ${STAGEDIR}${PREFIX}/etc
- @${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifdown.sample ${STAGEDIR}${PREFIX}/etc
+ ${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifup.sample ${STAGEDIR}${PREFIX}/etc
+ ${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifdown.sample ${STAGEDIR}${PREFIX}/etc
.include <bsd.port.post.mk>
diff --git a/emulators/qemu/pkg-plist b/emulators/qemu/pkg-plist
index d6f1ffb01a7d..21fa8e8c1c46 100644
--- a/emulators/qemu/pkg-plist
+++ b/emulators/qemu/pkg-plist
@@ -18,12 +18,8 @@ bin/qemu-img
bin/qemu-system-x86_64
man/man1/qemu.1.gz
man/man1/qemu-img.1.gz
-@unexec if cmp -s %D/etc/qemu-ifup.sample %D/etc/qemu-ifup; then rm -f %D/etc/qemu-ifup; fi
-etc/qemu-ifup.sample
-@exec if [ ! -f %D/etc/qemu-ifup ] ; then cp -p %D/%F %B/qemu-ifup; fi
-@unexec if cmp -s %D/etc/qemu-ifdown.sample %D/etc/qemu-ifdown; then rm -f %D/etc/qemu-ifdown; fi
-etc/qemu-ifdown.sample
-@exec if [ ! -f %D/etc/qemu-ifdown ] ; then cp -p %D/%F %B/qemu-ifdown; fi
+@sample etc/qemu-ifup.sample
+@sample etc/qemu-ifdown.sample
%%PORTDOCS%%%%DOCSDIR%%/qemu-doc.html
%%PORTDOCS%%%%DOCSDIR%%/qemu-tech.html
%%DATADIR%%/bios.bin