aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-09-10 21:11:23 +0800
committermat <mat@FreeBSD.org>2018-09-10 21:11:23 +0800
commitc6f82ca14271d2d9433ac4938a2188b9b6d092c1 (patch)
treeb47b12c2614f4db455f6a6733adce11a1cbba4b5 /emulators
parentb5f636d426adfd976e881a414696f678f16edcb8 (diff)
downloadfreebsd-ports-gnome-c6f82ca14271d2d9433ac4938a2188b9b6d092c1.tar.gz
freebsd-ports-gnome-c6f82ca14271d2d9433ac4938a2188b9b6d092c1.tar.zst
freebsd-ports-gnome-c6f82ca14271d2d9433ac4938a2188b9b6d092c1.zip
After an include, PLIST_SUB must be appended to, not overwritten.
If it is overwritten, many values will be clobbered, and pain will ensue. PR: 230864 Submitted by: mat exp-runs by: antoine
Diffstat (limited to 'emulators')
-rw-r--r--emulators/mame/Makefile2
-rw-r--r--emulators/mtools/Makefile4
2 files changed, 3 insertions, 3 deletions
diff --git a/emulators/mame/Makefile b/emulators/mame/Makefile
index 84a97a673120..1bcf8c1d021d 100644
--- a/emulators/mame/Makefile
+++ b/emulators/mame/Makefile
@@ -62,7 +62,7 @@ EMULATOR= ${MSUBTARGET}64
.else
EMULATOR= ${MSUBTARGET}
.endif
-PLIST_SUB= EMULATOR=${EMULATOR}
+PLIST_SUB+= EMULATOR=${EMULATOR}
post-patch:
@${RM} ${WRKSRC}/3rdparty/bx/include/compat/freebsd/dirent.h
diff --git a/emulators/mtools/Makefile b/emulators/mtools/Makefile
index f4d4c2673136..a9bd61c457ce 100644
--- a/emulators/mtools/Makefile
+++ b/emulators/mtools/Makefile
@@ -38,10 +38,10 @@ CONFIGURE_ENV+= ac_cv_header_iconv_h=no
.if ${PORT_OPTIONS:MX11}
USE_XORG= x11 sm ice xau
-PLIST_SUB= X11=""
+PLIST_SUB+= X11=""
.else
CONFIGURE_ARGS+= --without-x
-PLIST_SUB= X11="@comment "
+PLIST_SUB+= X11="@comment "
MAKE_ENV+= WITHOUT_X11=yes
.endif