aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2005-01-18 03:37:47 +0800
committerobrien <obrien@FreeBSD.org>2005-01-18 03:37:47 +0800
commitcec518fab74ff7654c77a107130e679cc2168be0 (patch)
tree15ea0e63d47eae57c601f17c07506641a1ec674b /emulators
parentff51199c7a53c35b9bee780f9fc1efe759a89a4e (diff)
downloadfreebsd-ports-gnome-cec518fab74ff7654c77a107130e679cc2168be0.tar.gz
freebsd-ports-gnome-cec518fab74ff7654c77a107130e679cc2168be0.tar.zst
freebsd-ports-gnome-cec518fab74ff7654c77a107130e679cc2168be0.zip
Get the PLIST generation out of do-install and into pre-instal.
Reported by: sf
Diffstat (limited to 'emulators')
-rw-r--r--emulators/linux_base-8/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/emulators/linux_base-8/Makefile b/emulators/linux_base-8/Makefile
index b7205815b727..9929f41b49b7 100644
--- a/emulators/linux_base-8/Makefile
+++ b/emulators/linux_base-8/Makefile
@@ -99,7 +99,7 @@ FALLBACK_ELF_MIB= kern.fallback_elf_brand
LINUX_ELF= 3
PREVIOUS_ELF!= /sbin/sysctl -n ${FALLBACK_ELF_MIB}
-do-install:
+pre-install:
#
# Handle the loading of the linux loadable kernel module if required.
@${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
@@ -150,9 +150,8 @@ do-install:
cd ${WRKSRC} && ${FIND} -s . -type f -o -type l | \
${CUT} -c3-999 >> ${PLIST} \
&& ${FIND} -d * -type d | ${SED} -e 's:^:@dirrm :' >> ${PLIST}
-#
-# The real do-install:
-#
+
+do-install:
cd ${WRKSRC} && ${FIND} * | ${CPIO} -dmp ${PREFIX}
${FIND} ${PREFIX} -type d -exec ${CHMOD} 755 \{\} \;