aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2016-03-01 19:12:14 +0800
committermadpilot <madpilot@FreeBSD.org>2016-03-01 19:12:14 +0800
commitd52485c96f122036e15e936c3122aabdf73e999b (patch)
tree122b9c14c700d7443bb09b34b973ae6edc77918f /emulators
parent8c070b4420344bf5f9eb360a0a2348a8bce0a29a (diff)
downloadfreebsd-ports-gnome-d52485c96f122036e15e936c3122aabdf73e999b.tar.gz
freebsd-ports-gnome-d52485c96f122036e15e936c3122aabdf73e999b.tar.zst
freebsd-ports-gnome-d52485c96f122036e15e936c3122aabdf73e999b.zip
- Update to 0.6.4
- Update MASTER_SITES and unbreak - Use option helpers and targets - Update pkg-descr PR: 205204 Submitted by: Ports fury
Diffstat (limited to 'emulators')
-rw-r--r--emulators/quasi88/Makefile43
-rw-r--r--emulators/quasi88/distinfo4
-rw-r--r--emulators/quasi88/pkg-descr5
3 files changed, 27 insertions, 25 deletions
diff --git a/emulators/quasi88/Makefile b/emulators/quasi88/Makefile
index fcb7b5940559..6174b20b4041 100644
--- a/emulators/quasi88/Makefile
+++ b/emulators/quasi88/Makefile
@@ -2,49 +2,47 @@
# $FreeBSD$
PORTNAME= quasi88
-PORTVERSION= 0.6.3
-PORTREVISION= 5
+PORTVERSION= 0.6.4
CATEGORIES= emulators
-MASTER_SITES= http://www.117.ne.jp/~show/pc8801/
+MASTER_SITES= http://www.eonet.ne.jp/~showtime/quasi88/release/
MAINTAINER= ports@FreeBSD.org
COMMENT= PC-8801 emulator for X
-BROKEN= unfetchable
-
USE_XORG= x11 xext
USES= gmake tar:tgz
MAKE_ENV= DATADIR="${DATADIR}" _CC="${CC}" _CFLAGS="${CFLAGS}" \
_CXX="${CXX}" LD="${CXX}" PROGRAM="${PORTNAME}"
MAKE_ARGS= ARCH="freebsd"
+DESKTOP_ENTRIES="Quasi88" "" "" "quasi88" "" ""
+
PORTDOCS= FAQ.TXT FORMAT.TXT GET-IMAGE.TXT HISTORY.TXT MANUAL.TXT \
QUASI88.TXT
-PORTEXAMPLES= *
+PORTEXAMPLES= keyconf.rc quasi88.rc
PLIST_FILES= bin/quasi88
MAKE_JOBS_UNSAFE= yes
OPTIONS_DEFINE= DOCS EXAMPLES SDL
+OPTIONS_DEFAULT= SDL
-.include <bsd.port.options.mk>
+SDL_USE= sdl=sdl
+SDL_MAKE_ENV= SDL_VERSION=1 X11_JOYSTICK="joy_sdl"
+SDL_MAKE_ENV_OFF= X11_VERSION=1 X11_JOYSTICK="joy_bsd_usb"
-.if ${ARCH} == "i386"
-MAKE_ENV+= LSB_FIRST=1
-.endif
+.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MSDL}
-USE_SDL= sdl
-MAKE_ENV+= SDL_VERSION=1 JOYSTICK="joy_sdl"
-.else
-MAKE_ENV+= X11_VERSION=1 JOYSTICK="joy_bsd_usb"
+.if ${ARCH} == amd64 || ${ARCH} == i386
+MAKE_ENV+= X11_LSB_FIRST=1
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|^X11_|# X11_|g ; \
+ @${REINPLACE_CMD} -e \
+ 's|^X11_VERSION|# X11_VERSION|g ; \
s|~/quasi88|$${DATADIR}|g ; \
- s|^LSB_|# LSB_|g ; \
- s|^JOY|# JOY|g ; \
+ s|^X11_LSB|# X11_LSB|g ; \
+ s|^X11_JOY|# X11_JOY|g ; \
s|^SDL_|# SDL_|g ; \
s|gcc|$${_CC}|g ; \
s|-O2|$${_CFLAGS}|g ; \
@@ -56,10 +54,15 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/quasi88 ${STAGEDIR}${PREFIX}/bin
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/*.rc ${STAGEDIR}${EXAMPLESDIR}
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC}/document && ${INSTALL_DATA} ${PORTDOCS} \
${STAGEDIR}${DOCSDIR})
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTEXAMPLES} \
+ ${STAGEDIR}${EXAMPLESDIR})
+
.include <bsd.port.mk>
diff --git a/emulators/quasi88/distinfo b/emulators/quasi88/distinfo
index b06554917b82..8b04c12fc8e0 100644
--- a/emulators/quasi88/distinfo
+++ b/emulators/quasi88/distinfo
@@ -1,2 +1,2 @@
-SHA256 (quasi88-0.6.3.tgz) = 01814e62b33f78b98f8ea9a8073bebf17d61917dc2caa3d08ec88e6a9f169699
-SIZE (quasi88-0.6.3.tgz) = 732695
+SHA256 (quasi88-0.6.4.tgz) = 2c4329f9f77e02a1e1f23c941be07fbe6e4a32353b5d012531f53b06996881ff
+SIZE (quasi88-0.6.4.tgz) = 1107470
diff --git a/emulators/quasi88/pkg-descr b/emulators/quasi88/pkg-descr
index 16708db92ad0..9e9125d63cb5 100644
--- a/emulators/quasi88/pkg-descr
+++ b/emulators/quasi88/pkg-descr
@@ -1,4 +1,3 @@
-This is a PC-8801 emulator for X.
-See http://www.117.ne.jp/~show/pc8801/pc88emu.html for further information.
+PC-8801 emulator for X.
-WWW: http://www.117.ne.jp/~show/pc8801/pc88emu.html
+WWW: http://www.eonet.ne.jp/~showtime/quasi88/