aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-04-29 05:20:28 +0800
committerbapt <bapt@FreeBSD.org>2013-04-29 05:20:28 +0800
commit0a21cb686357d0c6c0c66b1980acd9c7c9bc7949 (patch)
tree17f3405d36f74dd57d11bda9e7ecc80c2929914c /emulators
parent394c57853a58fa1d046fd083ec8bb59d504821e6 (diff)
downloadfreebsd-ports-gnome-0a21cb686357d0c6c0c66b1980acd9c7c9bc7949.tar.gz
freebsd-ports-gnome-0a21cb686357d0c6c0c66b1980acd9c7c9bc7949.tar.zst
freebsd-ports-gnome-0a21cb686357d0c6c0c66b1980acd9c7c9bc7949.zip
Convert emulators to new options framework
Diffstat (limited to 'emulators')
-rw-r--r--emulators/dynamips-community/Makefile13
-rw-r--r--emulators/fmsx/Makefile26
-rw-r--r--emulators/gngeo/Makefile28
-rw-r--r--emulators/gxemul/Makefile21
-rw-r--r--emulators/loemu/Makefile28
-rw-r--r--emulators/pearpc/Makefile19
-rw-r--r--emulators/snes9x-gtk/Makefile40
-rw-r--r--emulators/snes9x/Makefile40
-rw-r--r--emulators/xcpc/Makefile17
-rw-r--r--emulators/yabause/Makefile12
10 files changed, 109 insertions, 135 deletions
diff --git a/emulators/dynamips-community/Makefile b/emulators/dynamips-community/Makefile
index 797806ff4e0a..cbac80f69aa0 100644
--- a/emulators/dynamips-community/Makefile
+++ b/emulators/dynamips-community/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: dynamips
-# Date created: 17 Apr 2011
-# Whom: Pavel I Volkov <pavelivolkov@googlemail.com>
-#
+# Created by: Pavel I Volkov <pavelivolkov@googlemail.com>
# $FreeBSD$
-#
PORTNAME= dynamips
PORTVERSION= 0.2.8
@@ -25,7 +21,8 @@ CONFLICTS= dynamips-[0-9]* dynamips-devel-[0-9]*
USE_GMAKE= yes
MAKE_JOBS_UNSAFE= yes
-OPTIONS= UNSTABLE "development code (x64 Mac)" off
+OPTIONS_DEFINE= UNSTABLE
+UNSTABLE_DESC= development code (x64 Mac)
LDFLAGS+= -luuid
MAKE_ENV= \
@@ -43,7 +40,7 @@ MAN1= ${PORTNAME}.1 nvram_export.1
MAN7= hypervisor_mode.7
.endif
-.if defined(WITH_UNSTABLE)
+.if ${PORT_OPTIONS:MUNSTABLE}
DYNAMIPS_CODE= "unstable"
.else
DYNAMIPS_CODE= "stable"
@@ -65,7 +62,7 @@ DYNAMIPS_ARCH= "nojit"
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}.${DYNAMIPS_CODE} ${PREFIX}/bin/${PORTNAME}
${INSTALL_PROGRAM} ${WRKSRC}/${DYNAMIPS_CODE}/nvram_export ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.community ${DOCSDIR}
diff --git a/emulators/fmsx/Makefile b/emulators/fmsx/Makefile
index c9bc2f8b320b..c7815566abd8 100644
--- a/emulators/fmsx/Makefile
+++ b/emulators/fmsx/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: fMSX
-# Date created: 15 Oct 1996
-# Whom: dk
-#
+# Created by: dk
# $FreeBSD$
-#
PORTNAME= fmsx
PORTVERSION= 3.5.1
@@ -31,10 +27,12 @@ WRKSRC= ${WRKDIR}
BROKEN= does not build
-OPTIONS= BPP8 "With BPP8" Off \
- BPP16 "With BPP16" Off \
- BPP24 "With BPP24" Off \
- BPP32 "With BPP32 (see pkg-message)" On
+OPTIONS_DEFINE= BPP8 BPP16 BPP24 BPP32 DOCS
+OPTIONS_DEFAULT= BPP32
+BPP8_DESC= With BPP8
+BPP16_DESC= With BPP16
+BPP24_DESC= With BPP24
+BPP32_DESC= With BPP32 (see pkg-message)
.include <bsd.port.pre.mk>
@@ -42,16 +40,16 @@ post-patch:
${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},' \
${WRKSRC}/fMSX/Unix/Makefile \
${WRKSRC}/EMULib/Rules.Unix
-.ifdef(WITH_BPP32) || defined(PACKAGE_BUILDING) || defined(BATCH)
+.if ${PORT_OPTIONS:MBPP32) || defined(PACKAGE_BUILDING) || defined(BATCH}
${REINPLACE_CMD} -e 's/BPP16/BPP32/' ${WRKSRC}/fMSX/Unix/Makefile
.endif
-.ifdef(WITH_BPP24)
+.if ${PORT_OPTIONS:MBPP24}
${REINPLACE_CMD} -e 's/BPP16/BPP24/' ${WRKSRC}/fMSX/Unix/Makefile
.endif
-.ifdef(WITH_BPP16)
+.if ${PORT_OPTIONS:MBPP16}
${REINPLACE_CMD} -e 's/BPP16/BPP16/' ${WRKSRC}/fMSX/Unix/Makefile
.endif
-.ifdef(WITH_BPP8)
+.if ${PORT_OPTIONS:MBPP8}
${REINPLACE_CMD} -e 's/BPP16/BPP8/' ${WRKSRC}/fMSX/Unix/Makefile
.endif
@@ -65,7 +63,7 @@ do-install:
${MKDIR} ${PREFIX}/share/fmsx
${INSTALL_DATA} ${WRKSRC}/fMSX/ROMs/*.FNT ${DATADIR}
${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/*.ROM ${DATADIR}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/fMSX/*.html ${DOCSDIR}
.endif
diff --git a/emulators/gngeo/Makefile b/emulators/gngeo/Makefile
index 7e2b88a6c604..8e94e226d990 100644
--- a/emulators/gngeo/Makefile
+++ b/emulators/gngeo/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gngeo
-# Date created: 17 Aug 2005
-# Whom: Alejandro Pulver <alejandro@varnet.biz>
-#
+# Created by: Alejandro Pulver <alejandro@varnet.biz>
# $FreeBSD$
-#
PORTNAME= gngeo
PORTVERSION= 0.7
@@ -28,39 +24,41 @@ LDFLAGS+= `${SDL_CONFIG} --libs` -L${LOCALBASE}/lib
SUB_FILES= pkg-message
-OPTIONS= GUI "Enable GUI support (experimental)" off \
- I386ASM "Use i386 optimization" on \
- RAZE "Use Raze as z80 emulator (only for i386)" on \
- STAR "Use Starscream as 68k emulator (only for i386)" on
+OPTIONS_DEFINE= GUI
+OPTIONS_DEFINE_i386= ASM RAZE STAR
+OPTIONS_DEFAULT_i386= ASM RAZE STAR
+GUI_DESC= Enable GUI support (experimental)
+RAZE_DESC= Use Raze as z80 emulator
+STAR_DESC= Use Starscream as 68k emulator
MAN1= gngeo.1
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_I386ASM) || !defined(WITHOUT_RAZE) || \
- !defined(WITHOUT_STAR)
+.if ${PORT_OPTIONS:MI386ASM} || ${PORT_OPTIONS:MRAZE} || \
+ ${PORT_OPTIONS:MSTAR}
BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
.endif
-.if defined(WITH_GUI)
+.if ${PORT_OPTIONS:MGUI}
CONFIGURE_ARGS+= --enable-gui
.else
CONFIGURE_ARGS+= --disable-gui
.endif
-.if !defined(WITHOUT_I386ASM) && ${ARCH} == "i386"
+.if ${PORT_OPTIONS:MI386ASM}
CONFIGURE_ARGS+= --enable-i386asm
.else
CONFIGURE_ARGS+= --disable-i386asm
.endif
-.if !defined(WITHOUT_RAZE) && ${ARCH} == "i386"
+.if ${PORT_OPTIONS:MRAZE}
CONFIGURE_ARGS+= --enable-raze
.else
CONFIGURE_ARGS+= --enable-mamez80
.endif
-.if !defined(WITHOUT_STAR) && ${ARCH} == "i386"
+.if ${PORT_OPTIONS:MSTAR}
CONFIGURE_ARGS+= --enable-starscream
.else
CONFIGURE_ARGS+= --enable-gen68k
diff --git a/emulators/gxemul/Makefile b/emulators/gxemul/Makefile
index b6b348c4a158..6698e1c86e71 100644
--- a/emulators/gxemul/Makefile
+++ b/emulators/gxemul/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gxemul
-# Date created: 15 May 2005
-# Whom: Janni
-#
+# Created by: Janni
# $FreeBSD$
-#
PORTNAME= gxemul
PORTVERSION= 0.6.0
@@ -14,7 +10,8 @@ MASTER_SITES= http://gxemul.sourceforge.net/src/ \
MAINTAINER= imp@FreeBSD.org
COMMENT= Instruction-level machine emulator
-OPTIONS= X11 "X11 support" on
+OPTIONS_DEFINE= X11 DOCS
+OPTIONS_DEFAULT= X11
HAS_CONFIGURE= yes
ALL_TARGET= build
@@ -24,12 +21,12 @@ MAN1= gxemul.1
PORTDOCS= *
PLIST_FILES= bin/gxemul
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_X11)
-CONFIGURE_ARGS+=--disable-x
-.else
+.if ${PORT_OPTIONS:MX11}
USE_XORG= x11
+.else
+CONFIGURE_ARGS+=--disable-x
.endif
post-patch:
@@ -41,7 +38,7 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gxemul ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/man/gxemul.1 ${MAN1PREFIX}/man/man1
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${MKDIR} -p ${DOCSDIR}/components
${MKDIR} -p ${DOCSDIR}/machines
@@ -50,4 +47,4 @@ do-install:
${INSTALL_DATA} `find ${WRKSRC}/doc/ -type f -depth 1` ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/loemu/Makefile b/emulators/loemu/Makefile
index e632ea12da8a..1babe8988c05 100644
--- a/emulators/loemu/Makefile
+++ b/emulators/loemu/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: loemu
-# Date created: 2007-02-27
-# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
-#
+# Created by: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= loemu
PORTVERSION= 0.3.1
@@ -23,26 +19,28 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
NO_BUILD= yes
-OPTIONS= MAME "Install mame emulator" on \
- XMAME "Install xmame emulator" off \
- SNES9X "Install snes9x emulator" on \
- ZSNES "Install zsnes emulator" off
+OPTIONS_DEFINE= MAME XMAME SNES9X ZSNES
+OPTIONS_DEFAULT= MAME SNES9X
+MAME_DESC= Install mame emulator
+XMAME_DESC= Install xmame emulator
+SNES9X_DESC= Install snes9x emulator
+ZSNES_DESC= Install zsnes emulator
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_MAME)
+.if ${PORT_OPTIONS:MMAME}
RUN_DEPENDS+= mame:${PORTSDIR}/emulators/mame
.endif
-.if defined(WITH_XMAME)
+.if ${PORT_OPTIONS:MXMAME}
RUN_DEPENDS+= xmame:${PORTSDIR}/emulators/xmame
.endif
-.if !defined(WITHOUT_SNES9X)
+.if ${PORT_OPTIONS:MSNES9X}
RUN_DEPENDS+= snes9x:${PORTSDIR}/emulators/snes9x
.endif
-.if defined(WITH_ZSNES)
+.if ${PORT_OPTIONS:MZSNES}
RUN_DEPENDS+= zsnes:${PORTSDIR}/emulators/zsnes
.endif
@@ -56,4 +54,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|%%PYTHON_CMD%%|${PYTHON_CMD}|g' \
${WRKSRC}/setup.py
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/pearpc/Makefile b/emulators/pearpc/Makefile
index b549ee505d7f..95869df0b714 100644
--- a/emulators/pearpc/Makefile
+++ b/emulators/pearpc/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: PearPC
-# Date created: 22 May 2004
-# Whom: Roman Bogorodskiy <novel@FreeBSD.org>
-#
+# Created by: Roman Bogorodskiy <novel@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= pearpc
PORTVERSION= 0.4
@@ -24,9 +20,8 @@ SUB_FILES= pkg-message
PLIST_FILES= bin/ppc etc/ppccfg.example %%DATADIR%%/video.x
PLIST_DIRS= %%DATADIR%%
-OPTIONS= SDL "Use SDL for user interface" off \
- OPTIMIZED_CFLAGS "Make an optimized build" off \
- DEBUG "Make debug+profiled build" off
+OPTIONS_DEFINE= SDL OPTIMIZED_CFLAGS DEBUG
+SDL_DESC= Use SDL for user interface
.include <bsd.port.pre.mk>
@@ -36,7 +31,7 @@ BROKEN= Internal compiler error on ia64
# GTK and QT interfaces are broken in this version
#
-#.if defined(WITH_QT)
+#.if ${PORT_OPTIONS:MQT}
#CONFIGURE_ARGS+= --enable-ui=qt
#USE_QT_VER= 3
#QTDIR?= ${QT_PREFIX}
@@ -45,20 +40,20 @@ BROKEN= Internal compiler error on ia64
#CONFIGURE_ARGS+= --enable-ui=nogui
#.endif
-.if defined(WITH_SDL)
+.if ${PORT_OPTIONS:MSDL}
CONFIGURE_ARGS+= --enable-ui=sdl
USE_SDL= sdl
.else
CONFIGURE_ARGS+= --enable-ui=x11
.endif
-.if defined(WITH_OPTIMIZED_CFLAGS)
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
CFLAGS+= -O3 -ffast-math
.else
CONFIGURE_ARGS+= --disable-fpo
.endif
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --enable-profiling # implies --enable-debug
.endif
diff --git a/emulators/snes9x-gtk/Makefile b/emulators/snes9x-gtk/Makefile
index 69d8746915da..d3e793e56c7a 100644
--- a/emulators/snes9x-gtk/Makefile
+++ b/emulators/snes9x-gtk/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: snes9x-gtk
-# Date created: 2009-12-12
-# Whom: okeeblow <root@cooltrainer.org>
-#
+# Created by: okeeblow <root@cooltrainer.org>
# $FreeBSD$
-#
PORTNAME= snes9x
PORTVERSION= 1.52r79
@@ -32,65 +28,63 @@ CONFIGURE_ARGS+= --without-alsa
WRKSRC= ${WRKDIR}/${DISTNAME}/gtk
-OPTIONS= DEBUG "Enable debug information" off \
- OPENGL "Enable OpenGL support" off \
- X86_ASM "Use i386 optimization (only for i386)" on \
- MMX "Enable MMX (only for i386)" off \
- JMA "Enable JMA archive decompression support" on \
- NETPLAY "Enable network support" on \
- XV "Enable XVideo output on GTK" on \
- XRANDR "Enable XRandR support on GTK" on
+OPTIONS_DEFINE= DEBUG OPENGL JMA NETPLAY XV XRANDR
+OPTIONS_DEFAULT= JMA NETPLAY XV XRANDR
+OPTIONS_DEFINE_i386= ASM MMX
+OPTIONS_DEFAULT_i386= ASM
+JMA_DESC= Enable JMA archive decompression support
+NETPLAY_DESC= Enable network support
+XV_DESC= Enable XVideo output on GTK
+XRANDR_DESC= Enable XRandR support on GTK
.include <bsd.port.pre.mk>
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --with-debug
.else
CONFIGURE_ARGS+= --without-debug
.endif
-.if ${ARCH} == "i386"
-.if !defined(WITHOUT_X86_ASM)
+.if ${PORT_OPTIONS:MASM}
BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
CONFIGURE_ARGS+= --with-assembler
.else
CONFIGURE_ARGS+= --without-assembler
.endif
-.if defined(WITH_MMX) && !defined(PACKAGE_BUILDING)
+.if ${PORT_OPTIONS:MMMX} && !defined(PACKAGE_BUILDING)
CONFIGURE_ARGS+= --with-mmx
.else
CONFIGURE_ARGS+= --without-mmx
.endif
-.endif
-.if !defined(WITHOUT_OPENGL)
+.if ${PORT_OPTIONS:MOPENGL}
CONFIGURE_ARGS+= --with-opengl
USE_GL= glu
.else
CONFIGURE_ARGS+= --without-opengl
.endif
-.if !defined(WITHOUT_JMA)
+.if ${PORT_OPTIONS:MJMA}
CONFIGURE_ARGS+= --with-jma-decomp
.else
CONFIGURE_ARGS+= --without-jma-decomp
.endif
-.if !defined(WITHOUT_NETPLAY)
+.if ${PORT_OPTIONS:MNETPLAY}
CONFIGURE_ARGS+= --with-netplay
.else
CONFIGURE_ARGS+= --without-netplay
.endif
-.if !defined(WITHOUT_XV)
+.if ${PORT_OPTIONS:MXV}
CONFIGURE_ARGS+= --with-xv
USE_XORG+= xv
.else
CONFIGURE_ARGS+= --without-xv
.endif
-.if !defined(WITHOUT_XRANDR)
+.if ${PORT_OPTIONS:MXRANDR}
CONFIGURE_ARGS+= --with-xrandr
USE_XORG+= xrandr
.else
diff --git a/emulators/snes9x/Makefile b/emulators/snes9x/Makefile
index 621940706c6d..2d72351115bc 100644
--- a/emulators/snes9x/Makefile
+++ b/emulators/snes9x/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: snes9x
-# Date created: 20 July 1997
-# Whom: Yukihiro Nakai<Nakai@Mlab.t.u-tokyo.ac.jp>
-#
+# Created by: Yukihiro Nakai<Nakai@Mlab.t.u-tokyo.ac.jp>
# $FreeBSD$
-#
PORTNAME= snes9x
PORTVERSION= 1.51
@@ -33,44 +29,46 @@ WRKSRC= ${WRKDIR}/${DISTNAME}
PLIST_FILES= bin/${PORTNAME}
SUB_FILES= pkg-message
-OPTIONS= DEBUG "Enable debug information" off \
- OPENGL "Enable OpenGL support" off \
- SCREENSHOT "Enable screenshot support" on \
- X86_ASM "Use i386 optimization (only for i386)" on \
- MMX "Enable MMX (only for i386)" off \
- JMA "Enable JMA archive decompression support" on \
- NETPLAY "Enable network support" on
+OPTIONS_DEFINE= DEBUG OPENGL SCREENSHOT JMA NETPLAY DOCS
+OPTIONS_DEFINE_i386= ASM MMX
+OPTIONS_DEFAULT_i386= MMX
+OPTIONS_DEFAULT= SCREENSHOT JMA NETPLAY
+
+SCREENSHOT_DESC= Enable screenshot support
+MMX_DESC= Enable MMX
+JMA_DESC= Enable JMA archive decompression support
+NETPLAY_DESC= Enable network support
.include <bsd.port.pre.mk>
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= controls.txt control-inputs.txt changes.txt hardware.txt \
porting.html faqs.txt snapshots.txt snes9x.conf.default \
README
.endif
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --with-debug
.else
CONFIGURE_ARGS+= --without-debug
.endif
.if ${ARCH} == "i386"
-.if !defined(WITHOUT_X86_ASM)
+.if ${PORT_OPTIONS:MX86_ASM}
BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
CONFIGURE_ARGS+= --with-assembler
.else
CONFIGURE_ARGS+= --without-assembler
.endif
-.if defined(WITH_MMX) && !defined(PACKAGE_BUILDING)
+.if ${PORT_OPTIONS:MMMX) && !defined(PACKAGE_BUILDING}
CONFIGURE_ARGS+= --with-mmx
.else
CONFIGURE_ARGS+= --without-mmx
.endif
.endif
-.if defined(WITH_OPENGL)
+.if ${PORT_OPTIONS:MOPENGL}
USE_GL= yes
CONFIGURE_ARGS+= --with-opengl
SNES9X_BIN= osnes9x
@@ -78,20 +76,20 @@ SNES9X_BIN= osnes9x
SNES9X_BIN= snes9x
.endif
-.if !defined(WITHOUT_SCREENSHOT)
+.if ${PORT_OPTIONS:MSCREENSHOT}
LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
CONFIGURE_ARGS+= --with-screenshot
.else
CONFIGURE_ARGS+= --without-screenshot
.endif
-.if !defined(WITHOUT_JMA)
+.if ${PORT_OPTIONS:MJMA}
CONFIGURE_ARGS+= --with-jma-decomp
.else
CONFIGURE_ARGS+= --without-jma-decomp
.endif
-.if !defined(WITHOUT_NETPLAY)
+.if ${PORT_OPTIONS:MNETPLAY}
CONFIGURE_ARGS+= --with-netplay
.else
CONFIGURE_ARGS+= --without-netplay
@@ -107,7 +105,7 @@ post-patch:
@${REINPLACE_CMD} -i "" -e 's|Pitch2|Pitch|g' ${WRKSRC}/unix/opengl.cpp
do-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for FILE in control* changes.txt hardware.txt porting.html faqs.txt \
snapshots.txt snes9x.conf.default
diff --git a/emulators/xcpc/Makefile b/emulators/xcpc/Makefile
index 3f3fef5556c0..131fef2865ee 100644
--- a/emulators/xcpc/Makefile
+++ b/emulators/xcpc/Makefile
@@ -23,33 +23,34 @@ LIB_DEPENDS+= icui18n:${PORTSDIR}/devel/icu \
pcre.3:${PORTSDIR}/devel/pcre \
dsk.5:${PORTSDIR}/emulators/libdsk
-OPTIONS= MOTIF "With Motif widget set" on \
- ATHENA "With Athen widget set" off \
- XSHM "With XShm support" on \
- DEBUG "Turn debugging on" off
+OPTIONS_DEFINE= MOTIF ATHENA XSHM DEBUG
+OPTIONS_DEFAULT= MOTIF XSHM
+MOTIF_DESC= With Motif widget set
+ATHENA_DESC= With Athen widget set
+XSHM_DESC= With XShm support
.include <bsd.port.pre.mk>
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+=--enable-debug
.else
CONFIGURE_ARGS+=--disable-debug
.endif
-.if defined(WITH_XSHM)
+.if ${PORT_OPTIONS:MXSHM}
CONFIGURE_ARGS+=--enable-xshm
.else
CONFIGURE_ARGS+=--disable-xshm
.endif
-.if defined(WITH_MOTIF)
+.if ${PORT_OPTIONS:MMOTIF}
USE_MOTIF=yes
CONFIGURE_ARGS+=--with-motif1
.else
CONFIGURE_ARGS+=--without-motif1
.endif
-.if defined(WITH_ATHENA)
+.if ${PORT_OPTIONS:MATHENA}
LIB_DEPENDS+= Xaw.8:${PORTSDIR}/x11-toolkits/libXaw
CONFIGURE_ARGS+=--with-athena
.else
diff --git a/emulators/yabause/Makefile b/emulators/yabause/Makefile
index ae19e37574ec..9b90effe99a8 100644
--- a/emulators/yabause/Makefile
+++ b/emulators/yabause/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: yabause
-# Date created: 2006-08-23
-# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
-#
+# Created by: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= yabause
PORTVERSION= 0.9.11.1
@@ -27,11 +23,13 @@ USE_SDL= yes
SUB_FILES= pkg-message
MAN1= yabause.1
-OPTIONS= QT4 "Build wit qt4 interface instead of gtk2 one" on
+OPTIONS_DEFINE= QT4
+OPTIONS_DEFAULT= QT4
+QT4_DESC= Build wit qt4 interface instead of gtk2 one
.include <bsd.port.options.mk>
-.if defined(WITH_QT4)
+.if ${PORT_OPTIONS:MQT4}
USE_QT4= corelib gui opengl
CONFIGURE_ARGS+= --with-port=qt
.else