aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2007-04-11 02:29:39 +0800
committerbsam <bsam@FreeBSD.org>2007-04-11 02:29:39 +0800
commit193f8dbc64ecb8501874431a7f2eabd6a6864174 (patch)
tree8b8d613200f9a02a6a00e5ea0032639192d8ee86 /emulators
parent78410ae9d3667c41e540c068687106afdebde03e (diff)
downloadfreebsd-ports-gnome-193f8dbc64ecb8501874431a7f2eabd6a6864174.tar.gz
freebsd-ports-gnome-193f8dbc64ecb8501874431a7f2eabd6a6864174.tar.zst
freebsd-ports-gnome-193f8dbc64ecb8501874431a7f2eabd6a6864174.zip
Get rid of annoying message when do a "make index" at the system without
linuxolator started: ----- sysctl: unknown oid 'compat.linux.osrelease' ----- Reported by: netchild, rafan, chinsan Suggested by: rafan
Diffstat (limited to 'emulators')
-rw-r--r--emulators/linux_base-c6/Makefile2
-rw-r--r--emulators/linux_base-f10/Makefile2
-rw-r--r--emulators/linux_base-f7/Makefile2
-rw-r--r--emulators/linux_base-f8/Makefile2
-rw-r--r--emulators/linux_base-f9/Makefile2
-rw-r--r--emulators/linux_base-f9/linux_base-f8/Makefile2
-rw-r--r--emulators/linux_base-fc6/Makefile2
-rw-r--r--emulators/linux_base-fc7/Makefile2
8 files changed, 8 insertions, 8 deletions
diff --git a/emulators/linux_base-c6/Makefile b/emulators/linux_base-c6/Makefile
index c16024b93308..9fb92628100f 100644
--- a/emulators/linux_base-c6/Makefile
+++ b/emulators/linux_base-c6/Makefile
@@ -121,7 +121,7 @@ PLIST= pkg-plist
.include <bsd.port.pre.mk>
-LINUX_OSRELEASE!= ${SYSCTL} -n compat.linux.osrelease
+LINUX_OSRELEASE!= ${ECHO} `${SYSCTL} -n compat.linux.osrelease 2>/dev/null`
.if ${LINUX_OSRELEASE} == "2.4.2"
IGNORE= compat.linux.osrelease: 2.4.2 is not supported
diff --git a/emulators/linux_base-f10/Makefile b/emulators/linux_base-f10/Makefile
index c16024b93308..9fb92628100f 100644
--- a/emulators/linux_base-f10/Makefile
+++ b/emulators/linux_base-f10/Makefile
@@ -121,7 +121,7 @@ PLIST= pkg-plist
.include <bsd.port.pre.mk>
-LINUX_OSRELEASE!= ${SYSCTL} -n compat.linux.osrelease
+LINUX_OSRELEASE!= ${ECHO} `${SYSCTL} -n compat.linux.osrelease 2>/dev/null`
.if ${LINUX_OSRELEASE} == "2.4.2"
IGNORE= compat.linux.osrelease: 2.4.2 is not supported
diff --git a/emulators/linux_base-f7/Makefile b/emulators/linux_base-f7/Makefile
index c16024b93308..9fb92628100f 100644
--- a/emulators/linux_base-f7/Makefile
+++ b/emulators/linux_base-f7/Makefile
@@ -121,7 +121,7 @@ PLIST= pkg-plist
.include <bsd.port.pre.mk>
-LINUX_OSRELEASE!= ${SYSCTL} -n compat.linux.osrelease
+LINUX_OSRELEASE!= ${ECHO} `${SYSCTL} -n compat.linux.osrelease 2>/dev/null`
.if ${LINUX_OSRELEASE} == "2.4.2"
IGNORE= compat.linux.osrelease: 2.4.2 is not supported
diff --git a/emulators/linux_base-f8/Makefile b/emulators/linux_base-f8/Makefile
index c16024b93308..9fb92628100f 100644
--- a/emulators/linux_base-f8/Makefile
+++ b/emulators/linux_base-f8/Makefile
@@ -121,7 +121,7 @@ PLIST= pkg-plist
.include <bsd.port.pre.mk>
-LINUX_OSRELEASE!= ${SYSCTL} -n compat.linux.osrelease
+LINUX_OSRELEASE!= ${ECHO} `${SYSCTL} -n compat.linux.osrelease 2>/dev/null`
.if ${LINUX_OSRELEASE} == "2.4.2"
IGNORE= compat.linux.osrelease: 2.4.2 is not supported
diff --git a/emulators/linux_base-f9/Makefile b/emulators/linux_base-f9/Makefile
index c16024b93308..9fb92628100f 100644
--- a/emulators/linux_base-f9/Makefile
+++ b/emulators/linux_base-f9/Makefile
@@ -121,7 +121,7 @@ PLIST= pkg-plist
.include <bsd.port.pre.mk>
-LINUX_OSRELEASE!= ${SYSCTL} -n compat.linux.osrelease
+LINUX_OSRELEASE!= ${ECHO} `${SYSCTL} -n compat.linux.osrelease 2>/dev/null`
.if ${LINUX_OSRELEASE} == "2.4.2"
IGNORE= compat.linux.osrelease: 2.4.2 is not supported
diff --git a/emulators/linux_base-f9/linux_base-f8/Makefile b/emulators/linux_base-f9/linux_base-f8/Makefile
index c16024b93308..9fb92628100f 100644
--- a/emulators/linux_base-f9/linux_base-f8/Makefile
+++ b/emulators/linux_base-f9/linux_base-f8/Makefile
@@ -121,7 +121,7 @@ PLIST= pkg-plist
.include <bsd.port.pre.mk>
-LINUX_OSRELEASE!= ${SYSCTL} -n compat.linux.osrelease
+LINUX_OSRELEASE!= ${ECHO} `${SYSCTL} -n compat.linux.osrelease 2>/dev/null`
.if ${LINUX_OSRELEASE} == "2.4.2"
IGNORE= compat.linux.osrelease: 2.4.2 is not supported
diff --git a/emulators/linux_base-fc6/Makefile b/emulators/linux_base-fc6/Makefile
index c16024b93308..9fb92628100f 100644
--- a/emulators/linux_base-fc6/Makefile
+++ b/emulators/linux_base-fc6/Makefile
@@ -121,7 +121,7 @@ PLIST= pkg-plist
.include <bsd.port.pre.mk>
-LINUX_OSRELEASE!= ${SYSCTL} -n compat.linux.osrelease
+LINUX_OSRELEASE!= ${ECHO} `${SYSCTL} -n compat.linux.osrelease 2>/dev/null`
.if ${LINUX_OSRELEASE} == "2.4.2"
IGNORE= compat.linux.osrelease: 2.4.2 is not supported
diff --git a/emulators/linux_base-fc7/Makefile b/emulators/linux_base-fc7/Makefile
index c16024b93308..9fb92628100f 100644
--- a/emulators/linux_base-fc7/Makefile
+++ b/emulators/linux_base-fc7/Makefile
@@ -121,7 +121,7 @@ PLIST= pkg-plist
.include <bsd.port.pre.mk>
-LINUX_OSRELEASE!= ${SYSCTL} -n compat.linux.osrelease
+LINUX_OSRELEASE!= ${ECHO} `${SYSCTL} -n compat.linux.osrelease 2>/dev/null`
.if ${LINUX_OSRELEASE} == "2.4.2"
IGNORE= compat.linux.osrelease: 2.4.2 is not supported