aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authortrasz <trasz@FreeBSD.org>2009-02-15 18:01:07 +0800
committertrasz <trasz@FreeBSD.org>2009-02-15 18:01:07 +0800
commit267d632e679e0f4fe8dfed4db68f87f7bb0c7646 (patch)
tree941597f12ddabb50da9b969627f9c0a5d6d35b93 /emulators
parente7dc75dbfa23c2334e1630df1ea585a13710d662 (diff)
downloadfreebsd-ports-gnome-267d632e679e0f4fe8dfed4db68f87f7bb0c7646.tar.gz
freebsd-ports-gnome-267d632e679e0f4fe8dfed4db68f87f7bb0c7646.tar.zst
freebsd-ports-gnome-267d632e679e0f4fe8dfed4db68f87f7bb0c7646.zip
Update to V3.8-1.
Diffstat (limited to 'emulators')
-rw-r--r--emulators/simh/Makefile5
-rw-r--r--emulators/simh/distinfo6
-rw-r--r--emulators/simh/files/patch-VAX-vax_sysdev.c23
3 files changed, 17 insertions, 17 deletions
diff --git a/emulators/simh/Makefile b/emulators/simh/Makefile
index f55edd59797e..267081cd3bf3 100644
--- a/emulators/simh/Makefile
+++ b/emulators/simh/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= simh
-PORTVERSION= 3.8.0
-PORTREVISION= 1
+PORTVERSION= 3.8.1
CATEGORIES= emulators
MASTER_SITES= http://simh.trailing-edge.com/sources/
-DISTNAME= ${PORTNAME}v38-0
+DISTNAME= ${PORTNAME}v38-1
MAINTAINER= trasz@FreeBSD.org
COMMENT= Emulates classic DEC, HP, GRI, IBM, Altair, SDS, Honeywell, and others
diff --git a/emulators/simh/distinfo b/emulators/simh/distinfo
index 751b30667273..0528bb79dcaf 100644
--- a/emulators/simh/distinfo
+++ b/emulators/simh/distinfo
@@ -1,3 +1,3 @@
-MD5 (simhv38-0.zip) = d4bf6b7708e1f429e1e9b3c9e3e93b24
-SHA256 (simhv38-0.zip) = 5ed1843b2d80aeea467b60202483d86ce3ee311e0fd8a6920a1a0c12f380e6b7
-SIZE (simhv38-0.zip) = 2775593
+MD5 (simhv38-1.zip) = e15f65a82e21ea49e14b438326d93d5c
+SHA256 (simhv38-1.zip) = 4fe294fa5285b1d6d0bd69f60889c00e518ce2be5f00abc2bd4adfa8daa85b06
+SIZE (simhv38-1.zip) = 2954982
diff --git a/emulators/simh/files/patch-VAX-vax_sysdev.c b/emulators/simh/files/patch-VAX-vax_sysdev.c
index f9821dc3d69a..84fc18d8e6ca 100644
--- a/emulators/simh/files/patch-VAX-vax_sysdev.c
+++ b/emulators/simh/files/patch-VAX-vax_sysdev.c
@@ -1,17 +1,18 @@
---- VAX/vax_sysdev.c.orig Sat Mar 24 09:13:42 2007
-+++ VAX/vax_sysdev.c Sat Mar 24 09:17:45 2007
-@@ -1524,8 +1524,15 @@
- if (sim_log) fprintf (sim_log,
- "Loading boot code from ka655x.bin\n");
+--- VAX/vax_sysdev.c.orig 2008-11-23 11:57:54.000000000 +0100
++++ VAX/vax_sysdev.c 2009-02-12 06:24:49.000000000 +0100
+@@ -1553,9 +1553,15 @@
+ if (sim_log)
+ fprintf (sim_log, "Loading boot code from ka655x.bin\n");
r = load_cmd (0, "-R ka655x.bin");
-- if (r != SCPE_OK) return r;
+- if (r != SCPE_OK)
+- return r;
+ if (r != SCPE_OK) {
-+ printf ("Loading boot code from %%PREFIX%%/share/simh/ka655x.bin\n");
-+ if (sim_log) fprintf (sim_log,
-+ "Loading boot code from %%PREFIX%%/share/simh/ka655x.bin\n");
-+ r = load_cmd (0, "-R %%PREFIX%%/share/simh/ka655x.bin");
++ printf ("Loading boot code from /usr/local/share/simh/ka655x.bin\n");
++ if (sim_log)
++ fprintf (sim_log, "Loading boot code from /usr/local/share/simh/ka655x.bin\n");
++ r = load_cmd (0, "-R /usr/local/share/simh/ka655x.bin");
+ if (r != SCPE_OK)
-+ return r;
++ return r;
}
+}
return SCPE_OK;