aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2011-12-21 07:50:04 +0800
committeracm <acm@FreeBSD.org>2011-12-21 07:50:04 +0800
commit32892a230c2ff6d1045baaa70f5e07749f266523 (patch)
tree6e8bd5a390d55e280bfbfbf241d927218a3975ac /emulators
parente9ec5e44b6a17455b8c4eb722fca1ed21f9eb684 (diff)
downloadfreebsd-ports-gnome-32892a230c2ff6d1045baaa70f5e07749f266523.tar.gz
freebsd-ports-gnome-32892a230c2ff6d1045baaa70f5e07749f266523.tar.zst
freebsd-ports-gnome-32892a230c2ff6d1045baaa70f5e07749f266523.zip
- New port: emulators/mupen64plus-video-glide64
Glide64 video plugin for Mupen64Plus
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/mupen64plus-video-glide64/Makefile30
2 files changed, 31 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index a7ee257d2f3b..527985e3a2e9 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -116,6 +116,7 @@
SUBDIR += mupen64plus-rsp-z64
SUBDIR += mupen64plus-ui-console
SUBDIR += mupen64plus-video-arachnoid
+ SUBDIR += mupen64plus-video-glide64
SUBDIR += mupen64plus-video-rice
SUBDIR += nonpareil
SUBDIR += o2em
diff --git a/emulators/mupen64plus-video-glide64/Makefile b/emulators/mupen64plus-video-glide64/Makefile
new file mode 100644
index 000000000000..7625bf4bd098
--- /dev/null
+++ b/emulators/mupen64plus-video-glide64/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: mupen64plus-video-glide64
+# Date created: 2011-12-20
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+PKGNAMESUFFIX= -video-glide64
+DISTFILES= ${PORTNAME}${PKGNAMESUFFIX}-src-${PORTVERSION}${EXTRACT_SUFX}:plugin
+
+COMMENT= Glide64 video plugin for Mupen64Plus
+
+LIB_DEPENDS= mupen64plus.2:${PORTSDIR}/emulators/mupen64plus-core
+
+USE_GL= gl
+USE_SDL= yes
+
+MASTERDIR= ${.CURDIR}/../mupen64plus-core
+
+OPTIONS= #
+
+CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/${PORTNAME}
+LDFLAGS+= -L${LOCALBASE}/lib
+
+EXTRACT_AFTER_ARGS= | ${TAR} -xf -
+BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}${PKGNAMESUFFIX}/projects/unix
+WRKSRC= ${WRKDIR}
+
+.include "${MASTERDIR}/Makefile"