aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2017-10-07 02:53:00 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 05:40:53 +0800
commit3cb507407577f1992f676baf8777155918aa03dc (patch)
treedd0afd55346ee57c204e85750dcf6aea6ff28ac1 /emulators
parentc9383ee962797ad1cd4ac1536d5f4b3f8c6387e4 (diff)
downloadfreebsd-ports-gnome-3cb507407577f1992f676baf8777155918aa03dc.tar.gz
freebsd-ports-gnome-3cb507407577f1992f676baf8777155918aa03dc.tar.zst
freebsd-ports-gnome-3cb507407577f1992f676baf8777155918aa03dc.zip
emulators/qemu: Fix build without DOCS
- While here also add missing X11 dependencies to the GTK2 option /usr/bin/install -c -c -m 0644 docs/qemu-qmp-ref.7 "/wrkdirs/usr/ports/emulators/qemu/work/stage/usr/local/man/man7" install: docs/qemu-qmp-ref.7: No such file or directory gmake[1]: *** [Makefile:576: install-doc] Error 71 gmake[1]: Leaving directory '/wrkdirs/usr/ports/emulators/qemu/work/qemu-2.9.0' PR: 221749 Submitted by: smh Reviewed by: novel Approved by: bofh MFH: 2017Q4
Diffstat (limited to 'emulators')
-rw-r--r--emulators/qemu/Makefile2
-rw-r--r--emulators/qemu/files/patch-Makefile16
2 files changed, 15 insertions, 3 deletions
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index 6fc68a641374..414d982fe1b0 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -47,7 +47,7 @@ OPTIONS_DEFAULT=X11 GTK2 OPENGL GNUTLS SASL JPEG PNG CDROM_DMA CURL PCAP GNS3 NC
OPTIONS_SUB= yes
X11_USE= SDL=sdl XORG=x11,xext GNOME=gdkpixbuf2
X11_CONFIGURE_ENABLE= sdl
-GTK2_USE= GNOME=gtk20,vte
+GTK2_USE= GNOME=gtk20,vte,gdkpixbuf2 XORG=x11,xext
GTK2_USES= gettext
GTK2_CONFIGURE_OFF= --disable-gtk --disable-vte
GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
diff --git a/emulators/qemu/files/patch-Makefile b/emulators/qemu/files/patch-Makefile
index 0a8a735a7072..0c64d70244ac 100644
--- a/emulators/qemu/files/patch-Makefile
+++ b/emulators/qemu/files/patch-Makefile
@@ -1,11 +1,12 @@
--- Makefile.orig 2017-04-20 14:57:00 UTC
+++ Makefile
-@@ -206,9 +206,13 @@ LIBS+=-lz $(LIBS_TOOLS)
+@@ -206,9 +206,14 @@ LIBS+=-lz $(LIBS_TOOLS)
HELPERS-$(CONFIG_LINUX) = qemu-bridge-helper$(EXESUF)
ifdef BUILD_DOCS
+ifdef NOPORTDOCS
+DOCS=qemu.1 qemu-img.1 qemu-nbd.8 qemu-ga.8
++DOCS+=docs/qemu-qmp-ref.7 docs/qemu-ga-ref.7
+else
DOCS=qemu-doc.html qemu-doc.txt qemu.1 qemu-img.1 qemu-nbd.8 qemu-ga.8
DOCS+=docs/qemu-qmp-ref.html docs/qemu-qmp-ref.txt docs/qemu-qmp-ref.7
@@ -14,7 +15,7 @@
ifdef CONFIG_VIRTFS
DOCS+=fsdev/virtfs-proxy-helper.1
endif
-@@ -558,11 +562,13 @@ BLOBS=
+@@ -558,11 +563,13 @@ BLOBS=
endif
install-doc: $(DOCS)
@@ -28,3 +29,14 @@
ifdef CONFIG_POSIX
$(INSTALL_DIR) "$(DESTDIR)$(mandir)/man1"
$(INSTALL_DATA) qemu.1 "$(DESTDIR)$(mandir)/man1"
+@@ -575,8 +582,10 @@ ifneq ($(TOOLS),)
+ endif
+ ifneq (,$(findstring qemu-ga,$(TOOLS)))
+ $(INSTALL_DATA) qemu-ga.8 "$(DESTDIR)$(mandir)/man8"
++ifndef NOPORTDOCS
+ $(INSTALL_DATA) docs/qemu-ga-ref.html "$(DESTDIR)$(qemu_docdir)"
+ $(INSTALL_DATA) docs/qemu-ga-ref.txt "$(DESTDIR)$(qemu_docdir)"
++endif
+ $(INSTALL_DATA) docs/qemu-ga-ref.7 "$(DESTDIR)$(mandir)/man7"
+ endif
+ endif