aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2015-07-19 15:42:21 +0800
committerjbeich <jbeich@FreeBSD.org>2015-07-19 15:42:21 +0800
commit4393951e2f03b2c04ad5041a2e1ca206c1265605 (patch)
treee4f10c30a8c04f8d60e32e86e645cc614c9b2850 /emulators
parentd30e9ad8be622d2f666e8810616c6cf61165aec7 (diff)
downloadfreebsd-ports-gnome-4393951e2f03b2c04ad5041a2e1ca206c1265605.tar.gz
freebsd-ports-gnome-4393951e2f03b2c04ad5041a2e1ca206c1265605.tar.zst
freebsd-ports-gnome-4393951e2f03b2c04ad5041a2e1ca206c1265605.zip
Convert my ports to target option helpers
Diffstat (limited to 'emulators')
-rw-r--r--emulators/ppsspp/Makefile26
1 files changed, 14 insertions, 12 deletions
diff --git a/emulators/ppsspp/Makefile b/emulators/ppsspp/Makefile
index dd080882e9dc..be666750b00e 100644
--- a/emulators/ppsspp/Makefile
+++ b/emulators/ppsspp/Makefile
@@ -70,7 +70,18 @@ post-patch:
${WRKSRC}/Qt/Settings.pri
do-install:
-.if ! ${PORT_OPTIONS:MQT*}
+# XXX Vendor install is incomplete
+ ${INSTALL_DATA} ${WRKSRC}/debian/${PORTNAME}.desktop \
+ ${STAGEDIR}${DESKTOPDIR}
+ ${INSTALL_MAN} ${WRKSRC}/debian/${PORTNAME}.1 \
+ ${STAGEDIR}${MAN1PREFIX}/man/man1
+ (cd ${WRKSRC}/assets/unix-icons && ${COPYTREE_SHARE} \
+ "hicolor" ${STAGEDIR}${PREFIX}/share/icons)
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps
+ ${INSTALL_DATA} ${WRKSRC}/assets/unix-icons/icon-512.svg \
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps/${PORTNAME}.svg
+
+post-install-SDL-on:
# cmake doesn't pack assets into the app unlike qmake
# XXX Convert to ${PORTDATA:N${PORTNAME}} once fmake is EOL
(cd ${INSTALL_WRKSRC} && ${COPYTREE_SHARE} \
@@ -79,18 +90,9 @@ do-install:
${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/${PORTNAME:tu}* \
${STAGEDIR}${DATADIR}/${PORTNAME}
${LN} -sf ${DATADIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
-.else
+
+post-install-SDL-off:
${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/${PORTNAME} \
${STAGEDIR}${PREFIX}/bin
-.endif
- ${INSTALL_DATA} ${WRKSRC}/debian/${PORTNAME}.desktop \
- ${STAGEDIR}${DESKTOPDIR}
- ${INSTALL_MAN} ${WRKSRC}/debian/${PORTNAME}.1 \
- ${STAGEDIR}${MAN1PREFIX}/man/man1
- (cd ${WRKSRC}/assets/unix-icons && ${COPYTREE_SHARE} \
- "hicolor" ${STAGEDIR}${PREFIX}/share/icons)
- ${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps
- ${INSTALL_DATA} ${WRKSRC}/assets/unix-icons/icon-512.svg \
- ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps/${PORTNAME}.svg
.include <bsd.port.mk>