aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-11-15 04:56:45 +0800
committerjbeich <jbeich@FreeBSD.org>2016-11-15 04:56:45 +0800
commit45747d6f4da00ae4266a379eafe0c59e2a37ce3f (patch)
tree08b904202a522d08393baf77dab1fe6c0c5dbe16 /emulators
parent5a802988ac5801f4d23cd7622ff18c88df629f24 (diff)
downloadfreebsd-ports-gnome-45747d6f4da00ae4266a379eafe0c59e2a37ce3f.tar.gz
freebsd-ports-gnome-45747d6f4da00ae4266a379eafe0c59e2a37ce3f.tar.zst
freebsd-ports-gnome-45747d6f4da00ae4266a379eafe0c59e2a37ce3f.zip
emulators/ppsspp: link to upstream issue for BROKEN
Diffstat (limited to 'emulators')
-rw-r--r--emulators/ppsspp/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/emulators/ppsspp/Makefile b/emulators/ppsspp/Makefile
index cba162795e04..8890f1270e7e 100644
--- a/emulators/ppsspp/Makefile
+++ b/emulators/ppsspp/Makefile
@@ -27,6 +27,11 @@ GH_TUPLE?= hrydgard:${PORTNAME}-lang:cdf4a8d:lang/lang \
CONFLICTS_INSTALL= ${PORTNAME}-*
+# [QT4] FakeJit.cpp:42:37: error: no matching constructor for initialization of 'JitBlockCache'
+# [QT5] c++: error: the clang compiler does not support '-march=armv7-a'
+# [SDL] SplineCommon.cpp:639:17: error: use of undeclared identifier 'AllocateAlignedMemory'
+BROKEN_aarch64= https://github.com/hrydgard/ppsspp/issues/9032
+
USES= compiler:c++11-lib localbase:ldflags pkgconfig
EXCLUDE= glew snappy libzip zlib
EXTRACT_AFTER_ARGS=${EXCLUDE:S,^,--exclude ,}
@@ -58,8 +63,6 @@ SDL_BUILD_DEPENDS= png>=1.6:graphics/png
SDL_LIB_DEPENDS= libpng.so:graphics/png
SDL_VARS= PORTDATA+="assets ${PORTNAME}"
-BROKEN_aarch64= Fails to compile: error: use of undeclared identifier AllocateAlignedMemory
-
post-patch:
@${REINPLACE_CMD} -e 's,/usr/share,${PREFIX}/share,' \
${WRKSRC}/UI/NativeApp.cpp