aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorgrembo <grembo@FreeBSD.org>2014-06-02 00:39:41 +0800
committergrembo <grembo@FreeBSD.org>2014-06-02 00:39:41 +0800
commit48473102a3e4f8dc76ab3937411cd71b2bba3e0c (patch)
treedb74e5c92200956269aebbe7bba2755c86189968 /emulators
parent360722355b61b54fdfc7b3a73c18e33d65a801d2 (diff)
downloadfreebsd-ports-gnome-48473102a3e4f8dc76ab3937411cd71b2bba3e0c.tar.gz
freebsd-ports-gnome-48473102a3e4f8dc76ab3937411cd71b2bba3e0c.tar.zst
freebsd-ports-gnome-48473102a3e4f8dc76ab3937411cd71b2bba3e0c.zip
Stagify. Small fixes while being there.
The port doesn't build with std=c++11. Even though it's an upstream problem, the maintainer might want to look into fixing this. Reviewed by: flo (mentor) Approved by: flo (mentor)
Diffstat (limited to 'emulators')
-rw-r--r--emulators/snes9x/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/emulators/snes9x/Makefile b/emulators/snes9x/Makefile
index cc1a9a306104..81c8970464ba 100644
--- a/emulators/snes9x/Makefile
+++ b/emulators/snes9x/Makefile
@@ -12,7 +12,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= acm@FreeBSD.org
COMMENT= Super Nintendo Entertainment System(SNES) Emulator
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
USE_XORG= x11 sm ice xext
USES= gmake tar:bzip2
@@ -38,7 +38,6 @@ MMX_DESC= Enable MMX
JMA_DESC= Enable JMA archive decompression support
NETPLAY_DESC= Enable network support
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MDOCS}
@@ -77,7 +76,6 @@ SNES9X_BIN= snes9x
.endif
.if ${PORT_OPTIONS:MSCREENSHOT}
-LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
CONFIGURE_ARGS+= --with-screenshot
.else
CONFIGURE_ARGS+= --without-screenshot
@@ -106,16 +104,13 @@ post-patch:
do-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for FILE in control* changes.txt hardware.txt porting.html faqs.txt \
snapshots.txt snes9x.conf.default
- ${INSTALL_DATA} ${WRKSRC}/doc/${FILE} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${FILE} ${STAGEDIR}${DOCSDIR}
.endfor
- ${INSTALL_DATA} ${WRKSRC}/unix/docs/readme_unix.txt ${DOCSDIR}/README
+ ${INSTALL_DATA} ${WRKSRC}/unix/docs/readme_unix.txt ${STAGEDIR}${DOCSDIR}/README
.endif
- ${INSTALL_PROGRAM} ${WRKSRC}/${SNES9X_BIN} ${PREFIX}/bin/${PORTNAME}
-
-post-install:
- @${CAT} ${PKGMESSAGE}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${SNES9X_BIN} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.post.mk>