aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2008-12-10 15:35:19 +0800
committerlinimon <linimon@FreeBSD.org>2008-12-10 15:35:19 +0800
commit5dba952df544cb22578a4420dc76372bf8c11096 (patch)
tree63368d4aae4db9efc2ca032511e7db5f40e56105 /emulators
parent812b68b187731c45d5704e2e36d4a4d9ad5606b7 (diff)
downloadfreebsd-ports-gnome-5dba952df544cb22578a4420dc76372bf8c11096.tar.gz
freebsd-ports-gnome-5dba952df544cb22578a4420dc76372bf8c11096.tar.zst
freebsd-ports-gnome-5dba952df544cb22578a4420dc76372bf8c11096.zip
Mark as broken on sparc64.
Hat: portmgr
Diffstat (limited to 'emulators')
-rw-r--r--emulators/mame-devel/Makefile4
-rw-r--r--emulators/mame/Makefile4
-rw-r--r--emulators/mess/Makefile4
-rw-r--r--emulators/sdlmame-devel/Makefile4
-rw-r--r--emulators/sdlmame/Makefile4
-rw-r--r--emulators/sdlmess/Makefile4
6 files changed, 24 insertions, 0 deletions
diff --git a/emulators/mame-devel/Makefile b/emulators/mame-devel/Makefile
index 1be57e0d3130..8c05a0b68b11 100644
--- a/emulators/mame-devel/Makefile
+++ b/emulators/mame-devel/Makefile
@@ -54,4 +54,8 @@ post-install:
USE_GCC= 4.2+
.endif
+.if ${ARCH} == "sparc64"
+BROKEN= Does not compile on sparc64
+.endif
+
.include <bsd.port.post.mk>
diff --git a/emulators/mame/Makefile b/emulators/mame/Makefile
index 1be57e0d3130..8c05a0b68b11 100644
--- a/emulators/mame/Makefile
+++ b/emulators/mame/Makefile
@@ -54,4 +54,8 @@ post-install:
USE_GCC= 4.2+
.endif
+.if ${ARCH} == "sparc64"
+BROKEN= Does not compile on sparc64
+.endif
+
.include <bsd.port.post.mk>
diff --git a/emulators/mess/Makefile b/emulators/mess/Makefile
index fc3fbb50a674..76f93e02f8a9 100644
--- a/emulators/mess/Makefile
+++ b/emulators/mess/Makefile
@@ -32,6 +32,10 @@ SUB_FILES= ${PORTNAME} pkg-message
USE_GCC= 4.2+
.endif
+.if ${ARCH} == "sparc64"
+BROKEN= Does not compile on sparc64
+.endif
+
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
${MKDIR} ${PREFIX}/libexec/sdlmess
diff --git a/emulators/sdlmame-devel/Makefile b/emulators/sdlmame-devel/Makefile
index 1be57e0d3130..8c05a0b68b11 100644
--- a/emulators/sdlmame-devel/Makefile
+++ b/emulators/sdlmame-devel/Makefile
@@ -54,4 +54,8 @@ post-install:
USE_GCC= 4.2+
.endif
+.if ${ARCH} == "sparc64"
+BROKEN= Does not compile on sparc64
+.endif
+
.include <bsd.port.post.mk>
diff --git a/emulators/sdlmame/Makefile b/emulators/sdlmame/Makefile
index 1be57e0d3130..8c05a0b68b11 100644
--- a/emulators/sdlmame/Makefile
+++ b/emulators/sdlmame/Makefile
@@ -54,4 +54,8 @@ post-install:
USE_GCC= 4.2+
.endif
+.if ${ARCH} == "sparc64"
+BROKEN= Does not compile on sparc64
+.endif
+
.include <bsd.port.post.mk>
diff --git a/emulators/sdlmess/Makefile b/emulators/sdlmess/Makefile
index fc3fbb50a674..76f93e02f8a9 100644
--- a/emulators/sdlmess/Makefile
+++ b/emulators/sdlmess/Makefile
@@ -32,6 +32,10 @@ SUB_FILES= ${PORTNAME} pkg-message
USE_GCC= 4.2+
.endif
+.if ${ARCH} == "sparc64"
+BROKEN= Does not compile on sparc64
+.endif
+
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
${MKDIR} ${PREFIX}/libexec/sdlmess