aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2014-10-19 23:43:33 +0800
committermva <mva@FreeBSD.org>2014-10-19 23:43:33 +0800
commit68713e63a873487d61e13839964717ad31707a77 (patch)
tree007c8519a6455a0a0c70a67ca551339c6c99673c /emulators
parent4448b190fd5abad17e3c075074dea29adb16f0db (diff)
downloadfreebsd-ports-gnome-68713e63a873487d61e13839964717ad31707a77.tar.gz
freebsd-ports-gnome-68713e63a873487d61e13839964717ad31707a77.tar.zst
freebsd-ports-gnome-68713e63a873487d61e13839964717ad31707a77.zip
- Convert ports from dns/, editors/ and emulators/ to new
USES=python Approved by: portmgr (implicit)
Diffstat (limited to 'emulators')
-rw-r--r--emulators/catapult/Makefile3
-rw-r--r--emulators/dynagen/Makefile5
-rw-r--r--emulators/dynagui/Makefile4
-rw-r--r--emulators/gns3/Makefile4
-rw-r--r--emulators/loemu/Makefile5
-rw-r--r--emulators/openmsx/Makefile3
-rw-r--r--emulators/swine/Makefile3
-rw-r--r--emulators/virtualbox-ose-additions/Makefile3
-rw-r--r--emulators/virtualbox-ose/Makefile8
-rw-r--r--emulators/wxmupen64plus/Makefile2
10 files changed, 17 insertions, 23 deletions
diff --git a/emulators/catapult/Makefile b/emulators/catapult/Makefile
index 1fe8cacf98cd..4a15fea31f97 100644
--- a/emulators/catapult/Makefile
+++ b/emulators/catapult/Makefile
@@ -18,13 +18,12 @@ RUN_DEPENDS= openmsx:${PORTSDIR}/emulators/openmsx
OPTIONS_DEFINE= DEBUG DOCS
-USES= gmake pkgconfig
+USES= gmake pkgconfig python:build
USE_GCC= yes
USE_CXXSTD= gnu++0x
USE_GNOME= gtk20 libxml2
USE_WX= 2.8
WX_UNICODE= yes
-USE_PYTHON_BUILD=yes
MAKEFILE= GNUmakefile
MAKE_ARGS= INSTALL_BASE="${PREFIX}" \
INSTALL_SHARE_DIR="${DATADIR}" \
diff --git a/emulators/dynagen/Makefile b/emulators/dynagen/Makefile
index f087cef122e5..a40c60f887a0 100644
--- a/emulators/dynagen/Makefile
+++ b/emulators/dynagen/Makefile
@@ -41,9 +41,8 @@ PORTDOCS= *
PORTEXAMPLES= *
PORTDATA= *
-USES= dos2unix
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
+USES= dos2unix python
+USE_PYTHON= distutils
ALL_TARGET= # empty
post-install:
diff --git a/emulators/dynagui/Makefile b/emulators/dynagui/Makefile
index 77c120d13015..68e262f10726 100644
--- a/emulators/dynagui/Makefile
+++ b/emulators/dynagui/Makefile
@@ -13,8 +13,8 @@ COMMENT= GUI frontend to the dynamips router simulator
BUILD_DEPENDS= dynagen:${PORTSDIR}/emulators/dynagen
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
+USES= python
+USE_PYTHON= distutils
IMGDIR= ${STAGEDIR}${PREFIX}/share/${PORTNAME}/img
post-install:
diff --git a/emulators/gns3/Makefile b/emulators/gns3/Makefile
index d481e5ef3b1b..df2a720fa69e 100644
--- a/emulators/gns3/Makefile
+++ b/emulators/gns3/Makefile
@@ -22,8 +22,8 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/PyQt4/QtGui.so:${PORTSDIR}/x11-toolkits/py-qt4
WRKSRC= ${WRKDIR}/${PORTNAME}-legacy-GNS3-${PORTVERSION}
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
+USES= python
+USE_PYTHON= distutils
PYDISTUTILS_PKGNAME= GNS3
DESKTOP_ENTRIES= "GNS3" "${COMMENT}" "" "${PORTNAME}" "System;Emulator;" true
diff --git a/emulators/loemu/Makefile b/emulators/loemu/Makefile
index ce6bdcb5e03b..af2d7400be4e 100644
--- a/emulators/loemu/Makefile
+++ b/emulators/loemu/Makefile
@@ -14,9 +14,8 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gtk-2.0/gtk/__init__.py:${PORTSDIR}/x11-toolki
${PYTHON_SITELIBDIR}/libxml2.py:${PORTSDIR}/textproc/py-libxml2 \
${PYTHON_SITELIBDIR}/libxslt.py:${PORTSDIR}/textproc/py-libxslt
-USES= gettext
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
+USES= gettext python
+USE_PYTHON= distutils
NO_BUILD= yes
OPTIONS_DEFINE= MAME SNES9X ZSNES
diff --git a/emulators/openmsx/Makefile b/emulators/openmsx/Makefile
index 2ef0d805de21..792861819732 100644
--- a/emulators/openmsx/Makefile
+++ b/emulators/openmsx/Makefile
@@ -23,11 +23,10 @@ MAKE_ARGS+= INSTALL_BINARY_DIR=${PREFIX}/bin \
CXXFLAGS="${CXXFLAGS}"
MAKEFILE= GNUmakefile
-USES= gmake tcl
+USES= gmake python tcl
USE_GCC= yes
USE_GL= glew
USE_SDL= sdl ttf
-USE_PYTHON= yes
PLIST_FILES= bin/openmsx
PORTDATA= *
diff --git a/emulators/swine/Makefile b/emulators/swine/Makefile
index 3e1979ed3a5d..f31860aec1ab 100644
--- a/emulators/swine/Makefile
+++ b/emulators/swine/Makefile
@@ -25,8 +25,7 @@ GH_PROJECT= Swine
GH_TAGNAME= ${GH_COMMIT}
GH_COMMIT= 1770c40
-USES= gmake
-USE_PYTHON= yes
+USES= gmake python
NO_BUILD= yes
USE_QT4= linguist_build
ONLY_FOR_ARCHS= i386 amd64
diff --git a/emulators/virtualbox-ose-additions/Makefile b/emulators/virtualbox-ose-additions/Makefile
index 443ce3ae14be..9339d4a0e74e 100644
--- a/emulators/virtualbox-ose-additions/Makefile
+++ b/emulators/virtualbox-ose-additions/Makefile
@@ -27,9 +27,8 @@ UNIQUENAME= ${PORTNAME}${PKGNAMESUFFIX}
PATCHDIR= ${.CURDIR}/../${PORTNAME}/files
WRKSRC= ${WRKDIR}/VirtualBox-${PORTVERSION}
USE_RC_SUBR= vboxguest vboxservice
-USES= compiler:features cpe iconv kmod tar:bzip2
+USES= compiler:features cpe iconv kmod python:build tar:bzip2
ONLY_FOR_ARCHS= i386 amd64
-USE_PYTHON_BUILD= yes
MAKE_JOBS_UNSAFE= yes
HAS_CONFIGURE= yes
diff --git a/emulators/virtualbox-ose/Makefile b/emulators/virtualbox-ose/Makefile
index 0da912babba0..1b989a9b0f01 100644
--- a/emulators/virtualbox-ose/Makefile
+++ b/emulators/virtualbox-ose/Makefile
@@ -35,7 +35,6 @@ WRKSRC= ${WRKDIR}/VirtualBox-${PORTVERSION}
ONLY_FOR_ARCHS= i386 amd64
USES= compiler cpe iconv pkgconfig tar:bzip2
USE_GNOME= libidl
-USE_PYTHON_BUILD= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS+= --disable-java --passive-mesa
@@ -133,11 +132,12 @@ USE_TEX= dvipsk:build formats:build texlive
.endif
.if ${PORT_OPTIONS:MPYTHON}
-USE_PYTHON= 2
-USE_PYDISTUTILS= yes
+USES+= python:2
+USE_PYTHON= distutils noegginfo
PYDISTUTILS_PKGNAME= vboxapi
PYDISTUTILS_PKGVERSION= 1.0
-PYDISTUTILS_NOEGGINFO= yes
+.else
+USES+= python:build
.endif
.if ${PORT_OPTIONS:MQT4}
diff --git a/emulators/wxmupen64plus/Makefile b/emulators/wxmupen64plus/Makefile
index 75476d7eaab8..a76a905bb007 100644
--- a/emulators/wxmupen64plus/Makefile
+++ b/emulators/wxmupen64plus/Makefile
@@ -22,10 +22,10 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libmupen64plus.so.2:${PORTSDIR}/emulators/mupen64p
mupen64plus:${PORTSDIR}/emulators/mupen64plus-ui-console
PROJECTHOST= bsdistfiles
+USES= python
USE_SDL= yes
USE_WX= 3.0
WX_UNICODE= yes
-USE_PYTHON= yes
WAF_SCRIPT= waf
post-patch: