aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2013-04-27 16:50:46 +0800
committermva <mva@FreeBSD.org>2013-04-27 16:50:46 +0800
commit79452c6dc80b634c3ef9c985a517d911cf038f4a (patch)
tree5b8de344e457d5da2cf746d56e495a2ce03e1d99 /emulators
parent6901fd0c6d72632658ac11df799e604b6039ac64 (diff)
downloadfreebsd-ports-gnome-79452c6dc80b634c3ef9c985a517d911cf038f4a.tar.gz
freebsd-ports-gnome-79452c6dc80b634c3ef9c985a517d911cf038f4a.tar.zst
freebsd-ports-gnome-79452c6dc80b634c3ef9c985a517d911cf038f4a.zip
- Convert USE_ICONV=yes to USES=iconv
- Change USE_GNOME=pkgconfig|gnomehack to USES=pathfix|pkgconfig while here Reviewed by: bapt, kwm
Diffstat (limited to 'emulators')
-rw-r--r--emulators/catapult/Makefile3
-rw-r--r--emulators/dolphin-emu-devel/Makefile3
-rw-r--r--emulators/mtools/Makefile2
-rw-r--r--emulators/pcsxr/Makefile2
-rw-r--r--emulators/tme/Makefile3
-rw-r--r--emulators/vmw/Makefile2
-rw-r--r--emulators/xcpc/Makefile5
7 files changed, 8 insertions, 12 deletions
diff --git a/emulators/catapult/Makefile b/emulators/catapult/Makefile
index e87dd033c682..bb942bc84fbb 100644
--- a/emulators/catapult/Makefile
+++ b/emulators/catapult/Makefile
@@ -34,8 +34,7 @@ USE_GNOME= gdkpixbuf2 glib20 gtk20 libxml2
USE_WX= 2.6+
USE_PYTHON_BUILD=yes
USE_GMAKE= yes
-USES= gettext
-USE_ICONV= yes
+USES= gettext iconv
USE_XORG= ice pixman sm x11 xau xcomposite xcursor xdamage xdmcp \
xext xfixes xi xinerama xrandr xrender xxf86vm
MAKEFILE= GNUmakefile
diff --git a/emulators/dolphin-emu-devel/Makefile b/emulators/dolphin-emu-devel/Makefile
index 9c954915af65..ffbca9f5ab06 100644
--- a/emulators/dolphin-emu-devel/Makefile
+++ b/emulators/dolphin-emu-devel/Makefile
@@ -21,7 +21,6 @@ LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo \
REVDATE= 20130415
-USE_ICONV= yes
USE_SDL= sdl
USE_OPENAL= yes
USE_XORG= ice xext x11 xrandr
@@ -37,7 +36,7 @@ DOS2UNIX_REGEX= .*\.(h|c|cpp)
USE_GCC= 4.6+
.endif
-USES= cmake pkgconfig
+USES= cmake pkgconfig iconv
CMAKE_BUILD_TYPE= Release
# Disable ao (seems buggy) and ALSA (emulated)
CMAKE_ARGS+= -DDISABLE_AO:BOOL=ON \
diff --git a/emulators/mtools/Makefile b/emulators/mtools/Makefile
index 7caf6b3e65ea..47f97a2d626a 100644
--- a/emulators/mtools/Makefile
+++ b/emulators/mtools/Makefile
@@ -35,7 +35,7 @@ OPTIONS_DEFAULT=ICONV X11
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MICONV}
-USE_ICONV= yes
+USES+= iconv
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -liconv
.else
diff --git a/emulators/pcsxr/Makefile b/emulators/pcsxr/Makefile
index 4d38943049e9..c50890407377 100644
--- a/emulators/pcsxr/Makefile
+++ b/emulators/pcsxr/Makefile
@@ -32,7 +32,7 @@ USE_DOS2UNIX= yes
DOS2UNIX_REGEX= .*\.(c|h|cpp|hpp|am)
USE_GNOME= gtk30 desktopfileutils glib20
-USE_ICONV= yes
+USES= iconv
USE_XORG= x11 xv xext xxf86vm xtst
USE_SDL= sdl
USE_GL= gl
diff --git a/emulators/tme/Makefile b/emulators/tme/Makefile
index 932db7faaab4..9a67841acc2b 100644
--- a/emulators/tme/Makefile
+++ b/emulators/tme/Makefile
@@ -22,11 +22,10 @@ LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
xcb:${PORTSDIR}/x11/libxcb
-USES= pkgconfig gettext
+USES= pkgconfig gettext iconv
USE_GNOME= gdkpixbuf2 gtk20
USE_PERL5= yes
USE_GMAKE= yes
-USE_ICONV= yes
USE_AUTOTOOLS= libtool libltdl
CONFIGURE_ENV= ac_cv_have_isinff=no
CONFIGURE_ARGS= --datadir=${WRKDIR}/tmproot --disable-warnings
diff --git a/emulators/vmw/Makefile b/emulators/vmw/Makefile
index c6d1221edc00..091b481db822 100644
--- a/emulators/vmw/Makefile
+++ b/emulators/vmw/Makefile
@@ -10,7 +10,7 @@ COMMENT= VM Back Command Line Tools for VMware
ONLY_FOR_ARCHS= i386
WRKSRC= ${WRKDIR}/${PORTNAME}/src
-USE_ICONV= yes
+USES= iconv
SBINS= vmw vmshrink vmftp
diff --git a/emulators/xcpc/Makefile b/emulators/xcpc/Makefile
index 15e4173e107e..3f3fef5556c0 100644
--- a/emulators/xcpc/Makefile
+++ b/emulators/xcpc/Makefile
@@ -16,9 +16,8 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+=--prefix=${PREFIX}
USE_XORG= ice
-USE_GNOME= pkgconfig glib20
-USE_ICONV= yes
-USES= gettext
+USE_GNOME= glib20
+USES= gettext iconv pkgconfig
LIB_DEPENDS+= icui18n:${PORTSDIR}/devel/icu \
pcre.3:${PORTSDIR}/devel/pcre \