aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-11-16 04:20:56 +0800
committermarcus <marcus@FreeBSD.org>2003-11-16 04:20:56 +0800
commit88499cb92bbe3bbe15f34d4e1cdc37bc0c8e5c96 (patch)
tree591a3908c8533ba359a276ec65b31005e72d0b01 /emulators
parent847244c6859b9f017c70cf74593bdbd08529fb21 (diff)
downloadfreebsd-ports-gnome-88499cb92bbe3bbe15f34d4e1cdc37bc0c8e5c96.tar.gz
freebsd-ports-gnome-88499cb92bbe3bbe15f34d4e1cdc37bc0c8e5c96.tar.zst
freebsd-ports-gnome-88499cb92bbe3bbe15f34d4e1cdc37bc0c8e5c96.zip
unPERLify and use REINPLACE_CMD and USE_PERL5 where appropriate.
PR: 48249 Submitted by: Simon 'portlint' Schubert <corecode@corecode.ath.cx>
Diffstat (limited to 'emulators')
-rw-r--r--emulators/gngb/Makefile9
-rw-r--r--emulators/vmware2/Makefile1
-rw-r--r--emulators/xmame/Makefile1
3 files changed, 7 insertions, 4 deletions
diff --git a/emulators/gngb/Makefile b/emulators/gngb/Makefile
index b22df0ffa022..ee9b618bea02 100644
--- a/emulators/gngb/Makefile
+++ b/emulators/gngb/Makefile
@@ -18,6 +18,7 @@ COMMENT= GameBoy(tm) emulator
LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
USE_GETOPT_LONG=yes
USE_XLIB= yes
@@ -41,13 +42,13 @@ PORT_CFLAGS+= -DSDL_GL
.endif
pre-configure:
- @${PERL} -pi -e 's|sdl-config|sdl11-config|g' ${WRKSRC}/configure
- @${PERL} -pi -e 's|-lSDL|-lSDL-1.1|g' ${WRKSRC}/configure
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|sdl-config|sdl11-config|g; \
+ s|-lSDL|-lSDL-1.1|g; \
+ s|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
post-configure:
.if !defined(WITH_OPTIMIZED_CFLAGS)
- @${PERL} -pi -e 's|(CFLAGS =).*|\1 ${PORT_CFLAGS} ${CFLAGS}|' ${WRKSRC}/src/Makefile
+ @${REINPLACE_CMD} -e 's|\(CFLAGS =\).*|\1 ${PORT_CFLAGS} ${CFLAGS}|' ${WRKSRC}/src/Makefile
.endif
.include <bsd.port.mk>
diff --git a/emulators/vmware2/Makefile b/emulators/vmware2/Makefile
index af4d40a98dcf..7244c5c3f642 100644
--- a/emulators/vmware2/Makefile
+++ b/emulators/vmware2/Makefile
@@ -39,6 +39,7 @@ FREEBSD_MODULE_SITES= \
USE_SUBMAKE= yes
USE_LINUX= yes
+USE_PERL5= yes
VMDIR= ${PREFIX}/lib/vmware
SRC_BASE?= /usr/src
diff --git a/emulators/xmame/Makefile b/emulators/xmame/Makefile
index 96060acf155a..e87d7e0e92b6 100644
--- a/emulators/xmame/Makefile
+++ b/emulators/xmame/Makefile
@@ -21,6 +21,7 @@ MAINTAINER?= refugee@vt.edu
COMMENT?= UNIX/X11 port of the Multi Arcade Machine Emulator (MAME)
USE_BZIP2= yes
+USE_PERL5= yes
USE_GMAKE= yes
USE_REINPLACE= yes