aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2005-09-09 12:12:55 +0800
committerdinoex <dinoex@FreeBSD.org>2005-09-09 12:12:55 +0800
commit89b239a230c4b84b4763e414f13d7992c0aa31d2 (patch)
tree7f58205c332f3d5ec48093f43355168ec4acc831 /emulators
parentd8b021b23c7e71885193cc827b655ac6ddf838ad (diff)
downloadfreebsd-ports-gnome-89b239a230c4b84b4763e414f13d7992c0aa31d2.tar.gz
freebsd-ports-gnome-89b239a230c4b84b4763e414f13d7992c0aa31d2.tar.zst
freebsd-ports-gnome-89b239a230c4b84b4763e414f13d7992c0aa31d2.zip
- unbreak fetch
Approved by: Tobias Reifenberger (maintainer)
Diffstat (limited to 'emulators')
-rw-r--r--emulators/stonx/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/emulators/stonx/Makefile b/emulators/stonx/Makefile
index 50b668e35913..0b3221dcefd0 100644
--- a/emulators/stonx/Makefile
+++ b/emulators/stonx/Makefile
@@ -16,17 +16,12 @@ COMMENT= AtariST emulator
RESTRICTED= "tos.img is copyrighted"
-TOSIMG= tos.img
+TOSIMG?= tos.img
USE_X_PREFIX= yes
HAS_CONFIGURE= yes
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
-IGNORE="Please get a ROM dump from your AtariST and save it as"\
-"\"${TOSIMG}\" in \"${DISTDIR}\" manually, and then make install again"
-.endif
-
pre-build:
- ${CP} ${DISTDIR}/tos.img ${WRKSRC}
+ ${CP} ${DISTDIR}/${TOSIMG} ${WRKSRC}/tos.img
post-build:
(cd ${WRKSRC}; make fnttobdf fonts)
@@ -79,4 +74,11 @@ do-install:
post-install:
${X11BASE}/bin/mkfontdir ${FNTDIR}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if !exists(${DISTDIR}/${TOSIMG})
+IGNORE="Please get a ROM dump from your AtariST and save it as"\
+"\"${TOSIMG}\" in \"${DISTDIR}\" manually, and then make install again"
+.endif
+
+.include <bsd.port.post.mk>