aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-27 22:36:07 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-27 22:36:07 +0800
commit8e4acb7895d94a162063901f09090a9d27cfa5f5 (patch)
tree7707b5559bf6bb4992c2f8b31ce0fc28f4428d60 /emulators
parent740d08199084a22ce94a934aca06bafde8541623 (diff)
downloadfreebsd-ports-gnome-8e4acb7895d94a162063901f09090a9d27cfa5f5.tar.gz
freebsd-ports-gnome-8e4acb7895d94a162063901f09090a9d27cfa5f5.tar.zst
freebsd-ports-gnome-8e4acb7895d94a162063901f09090a9d27cfa5f5.zip
Support staging
Diffstat (limited to 'emulators')
-rw-r--r--emulators/mastergear/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/emulators/mastergear/Makefile b/emulators/mastergear/Makefile
index 5084c41b36da..ab98c597950c 100644
--- a/emulators/mastergear/Makefile
+++ b/emulators/mastergear/Makefile
@@ -20,15 +20,14 @@ ONLY_FOR_ARCHS= i386
NO_BUILD= yes
STRIP=
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/mg ${PREFIX}/bin
- @${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/CART.ROM ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/SF7000.ROM ${DATADIR}
-.if(!defined(NOPORTDOCS))
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/MG.html ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/mg ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/CART.ROM ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/SF7000.ROM ${STAGEDIR}${DATADIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/MG.html ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>