aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authormbr <mbr@FreeBSD.org>2010-11-16 07:59:05 +0800
committermbr <mbr@FreeBSD.org>2010-11-16 07:59:05 +0800
commit90084cd2feda93a5b8b770151dffc17994b2ebe0 (patch)
treec6f33afb7fb306323a156e4c852d1019e3f58546 /emulators
parent290bec88f481d133a95e65f9beff2b0832ac0837 (diff)
downloadfreebsd-ports-gnome-90084cd2feda93a5b8b770151dffc17994b2ebe0.tar.gz
freebsd-ports-gnome-90084cd2feda93a5b8b770151dffc17994b2ebe0.tar.zst
freebsd-ports-gnome-90084cd2feda93a5b8b770151dffc17994b2ebe0.zip
Add new patches for build 313025
Diffstat (limited to 'emulators')
-rw-r--r--emulators/open-vm-tools/files/patch-hostinfoPosix.c10
-rw-r--r--emulators/open-vm-tools/files/patch-libguestlib-Makefile22
-rw-r--r--emulators/open-vm-tools/files/patch-scripts-network10
-rw-r--r--emulators/open-vm-tools/files/patch-vm_basic_types.h10
-rw-r--r--emulators/open-vm-tools/files/patch-vmhgfs-Makefile26
5 files changed, 78 insertions, 0 deletions
diff --git a/emulators/open-vm-tools/files/patch-hostinfoPosix.c b/emulators/open-vm-tools/files/patch-hostinfoPosix.c
new file mode 100644
index 000000000000..342a0c0fabd6
--- /dev/null
+++ b/emulators/open-vm-tools/files/patch-hostinfoPosix.c
@@ -0,0 +1,10 @@
+--- ./lib/misc/hostinfoPosix.c.orig 2010-04-28 03:17:27.000000000 +0900
++++ ./lib/misc/hostinfoPosix.c 2010-11-11 22:37:23.000000000 +0900
+@@ -31,7 +31,6 @@
+ #include <sys/wait.h>
+ #include <signal.h>
+ #include <sys/time.h>
+-#include <sys/timeb.h>
+ #include <pwd.h>
+ #include <pthread.h>
+ #include <sys/resource.h>
diff --git a/emulators/open-vm-tools/files/patch-libguestlib-Makefile b/emulators/open-vm-tools/files/patch-libguestlib-Makefile
new file mode 100644
index 000000000000..ab5d4d2d6609
--- /dev/null
+++ b/emulators/open-vm-tools/files/patch-libguestlib-Makefile
@@ -0,0 +1,22 @@
+--- ./libguestlib/Makefile.am.orig 2010-04-28 03:17:28.000000000 +0900
++++ ./libguestlib/Makefile.am 2010-11-11 22:21:38.000000000 +0900
+@@ -41,7 +41,7 @@
+
+ EXTRA_DIST = vmguestlib.pc.in
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(DESTDIR)$(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = vmguestlib.pc
+
+ $(pkgconfig_DATA): $(top_builddir)/config.status
+--- ./libguestlib/Makefile.in.orig 2010-04-28 03:18:19.000000000 +0900
++++ ./libguestlib/Makefile.in 2010-11-11 22:22:04.000000000 +0900
+@@ -298,7 +298,7 @@
+ $(top_srcdir)/lib/include/vmSessionId.h \
+ $(top_srcdir)/lib/include/vm_basic_types.h
+ EXTRA_DIST = vmguestlib.pc.in
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(DESTDIR)$(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = vmguestlib.pc
+ all: all-am
+
diff --git a/emulators/open-vm-tools/files/patch-scripts-network b/emulators/open-vm-tools/files/patch-scripts-network
new file mode 100644
index 000000000000..2feb534b5ac4
--- /dev/null
+++ b/emulators/open-vm-tools/files/patch-scripts-network
@@ -0,0 +1,10 @@
+--- ./scripts/freebsd/network.orig 2010-04-28 03:17:28.000000000 +0900
++++ ./scripts/freebsd/network 2010-11-11 22:18:23.000000000 +0900
+@@ -59,6 +59,7 @@
+
+ for intf in `list_net_interfaces dhcp`; do
+ /etc/rc.d/netif $1 $intf
++ /etc/rc.d/dhclient $1 $intf
+ ec=$?
+
+ # Failure to stop an interface should not interfere with suspend.
diff --git a/emulators/open-vm-tools/files/patch-vm_basic_types.h b/emulators/open-vm-tools/files/patch-vm_basic_types.h
new file mode 100644
index 000000000000..f1aaf24d585b
--- /dev/null
+++ b/emulators/open-vm-tools/files/patch-vm_basic_types.h
@@ -0,0 +1,10 @@
+--- ./lib/include/vm_basic_types.h.orig 2010-10-20 05:19:54.000000000 +0900
++++ ./lib/include/vm_basic_types.h 2010-10-29 20:11:03.000000000 +0900
+@@ -333,6 +333,7 @@
+ #define FMTPD ""
+ #endif
+ #elif defined(__linux__) \
++ || (defined(__clang__)) \
+ || (defined(_POSIX_C_SOURCE) && _POSIX_C_SOURCE >= 200112L) \
+ || (defined(_POSIX_VERSION) && _POSIX_VERSION >= 200112L) \
+ || (defined(_POSIX2_VERSION) && _POSIX2_VERSION >= 200112L)
diff --git a/emulators/open-vm-tools/files/patch-vmhgfs-Makefile b/emulators/open-vm-tools/files/patch-vmhgfs-Makefile
new file mode 100644
index 000000000000..fd267d3a573c
--- /dev/null
+++ b/emulators/open-vm-tools/files/patch-vmhgfs-Makefile
@@ -0,0 +1,26 @@
+--- ./modules/freebsd/vmhgfs/Makefile.orig 2010-10-20 05:19:54.000000000 +0900
++++ ./modules/freebsd/vmhgfs/Makefile 2010-11-11 23:06:07.000000000 +0900
+@@ -90,22 +90,7 @@
+ CFLAGS += -Ishared
+ .endif
+
+-#
+-# FreeBSD's kernel module build system defines a bunch of additional warning
+-# flags for the compiler in addition to -Wall -Werror. However, some of these,
+-# like -Wredundant-decls, are overkill. To get around this, I copied their list
+-# of warning flags, but explicitly disabled a few.
+-#
+-CWARNFLAGS := -Wall
+-CWARNFLAGS += -Werror
+-CWARNFLAGS += -Wno-redundant-decls
+-CWARNFLAGS += -Wnested-externs
+-CWARNFLAGS += -Wstrict-prototypes
+-CWARNFLAGS += -Wno-missing-prototypes
+-CWARNFLAGS += -Wpointer-arith
+-CWARNFLAGS += -Winline
+-CWARNFLAGS += -Wcast-qual
+-
+ EXPORT_SYMS = NO
+
++.include <bsd.own.mk>
+ .include <bsd.kmod.mk>