aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2009-08-03 03:36:34 +0800
committermezz <mezz@FreeBSD.org>2009-08-03 03:36:34 +0800
commitaf1fc7a24eda71b11fbfc0bc73c1d53d079e5b57 (patch)
treeb69e5428d2c59fc0cebf129e7ba703a374c1bcf7 /emulators
parent3a0a9794815da3b9ae9bf959990263eabe231698 (diff)
downloadfreebsd-ports-gnome-af1fc7a24eda71b11fbfc0bc73c1d53d079e5b57.tar.gz
freebsd-ports-gnome-af1fc7a24eda71b11fbfc0bc73c1d53d079e5b57.tar.zst
freebsd-ports-gnome-af1fc7a24eda71b11fbfc0bc73c1d53d079e5b57.zip
-Repocopy devel/libtool15 -> libtool22 and libltdl15 -> libltdl22.
-Update libtool and libltdl to 2.2.6a. -Remove devel/libtool15 and devel/libltdl15. -Fix ports build with libtool22/libltdl22. -Bump ports that depend on libltdl22 due to shared library version change. -Explain what to do update in the UPDATING. It has been tested with GNOME2, XFCE4, KDE3, KDE4 and other many wm/desktop and applications in the runtime. With help: marcus and kwm Pointyhat-exp: a few times by pav Tested by: pgollucci, "Romain Tartière" <romain@blogreen.org>, and a few MarcusCom CVS users. Also, I might have missed a few. Repocopy by: marcus Approved by: portmgr
Diffstat (limited to 'emulators')
-rw-r--r--emulators/bochs/Makefile2
-rw-r--r--emulators/hercules/Makefile9
-rw-r--r--emulators/hercules/files/patch-libtool2275
-rw-r--r--emulators/lib765/Makefile2
-rw-r--r--emulators/libdsk/Makefile2
-rw-r--r--emulators/xsystem35/Makefile2
6 files changed, 86 insertions, 6 deletions
diff --git a/emulators/bochs/Makefile b/emulators/bochs/Makefile
index c9b4891931d3..3feb277c09b3 100644
--- a/emulators/bochs/Makefile
+++ b/emulators/bochs/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= An IA-32 (x86) PC emulator that runs DOS, Win 95, and more
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-docbook
diff --git a/emulators/hercules/Makefile b/emulators/hercules/Makefile
index 7efce1494770..efe3e839e3f2 100644
--- a/emulators/hercules/Makefile
+++ b/emulators/hercules/Makefile
@@ -7,7 +7,7 @@
PORTNAME= hercules
PORTVERSION= 3.05
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators
MASTER_SITES= http://www.hercules-390.org/
@@ -18,10 +18,13 @@ OPTIONS= PTHREADS "Build with pthreads instead of fthreads." on \
NLS "Build with native language support." on \
DEBUG "Enable for debugging hercules itself." off
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22 libltdl:22
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+post-extract:
+ ${RM} ${WRKSRC}/ltdl.*
+
post-patch:
@${REINPLACE_CMD} -e 's@-lpthread@${PTHREAD_LIBS}@g' ${WRKSRC}/configure
.if defined(NOPORTDOCS)
@@ -29,6 +32,8 @@ post-patch:
.else
@${REINPLACE_CMD} -e 's,^datadir = @datadir@,datadir = ${PREFIX}/share/doc/,' ${WRKSRC}/html/Makefile.in
.endif
+ @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
+ '/^libherc_la_LIBADD/s|=|= -lltdl |g'
MAN1= cckddiag.1 dasdseq.1
MAN4= cckd.4
diff --git a/emulators/hercules/files/patch-libtool22 b/emulators/hercules/files/patch-libtool22
new file mode 100644
index 000000000000..273885ebc59c
--- /dev/null
+++ b/emulators/hercules/files/patch-libtool22
@@ -0,0 +1,75 @@
+--- Makefile.in.orig 2009-07-13 15:39:03.000000000 -0500
++++ Makefile.in 2009-07-13 15:39:06.000000000 -0500
+@@ -257,13 +257,13 @@
+ libhercu_la_DEPENDENCIES = $(am__DEPENDENCIES_1) libhercs.la
+ am__libhercu_la_SOURCES_DIST = version.c hscutl.c hscutl2.c codepage.c \
+ logger.c logmsg.c hdl.c hostinfo.c hsocket.c memrchr.c \
+- parser.c pttrace.c fthreads.c fishhang.c ltdl.c
++ parser.c pttrace.c fthreads.c fishhang.c
+ am__objects_5 = fthreads.lo
+ @BUILD_FTHREADS_TRUE@am__objects_8 = $(am__objects_5)
+ am__objects_6 = fishhang.lo
+ @BUILD_FISHHANG_TRUE@@BUILD_FTHREADS_TRUE@am__objects_9 = \
+ @BUILD_FISHHANG_TRUE@@BUILD_FTHREADS_TRUE@ $(am__objects_6)
+-@OPTION_DYNAMIC_LOAD_TRUE@am__objects_10 = ltdl.lo
++@OPTION_DYNAMIC_LOAD_TRUE@am__objects_10 =
+ am_libhercu_la_OBJECTS = version.lo hscutl.lo hscutl2.lo codepage.lo \
+ logger.lo logmsg.lo hdl.lo hostinfo.lo hsocket.lo memrchr.lo \
+ parser.lo pttrace.lo $(am__objects_8) $(am__objects_9) \
+@@ -626,7 +626,7 @@
+ @OPTION_DYNAMIC_LOAD_FALSE@DYNSRC = $(dyndev_SRC)
+ @OPTION_DYNAMIC_LOAD_TRUE@DYNSRC =
+ @OPTION_DYNAMIC_LOAD_FALSE@LTDL =
+-@OPTION_DYNAMIC_LOAD_TRUE@LTDL = ltdl.c
++@OPTION_DYNAMIC_LOAD_TRUE@LTDL =
+ @OPTION_DYNAMIC_LOAD_FALSE@DYNMOD_LD_FLAGS =
+ @OPTION_DYNAMIC_LOAD_TRUE@DYNMOD_LD_FLAGS = -module \
+ @OPTION_DYNAMIC_LOAD_TRUE@ -no-undefined \
+@@ -843,8 +843,7 @@
+ memrchr.c \
+ $(dynamic_SRC) \
+ $(extra_SRC) \
+- $(dyndev_SRC) \
+- ltdl.c
++ $(dyndev_SRC)
+
+ libherc_la_LDFLAGS = $(LIB_LD_FLAGS)
+ libherc_la_LIBADD = libhercs.la \
+@@ -1089,7 +1088,6 @@
+ hdl.h \
+ crypto.h \
+ sockdev.h \
+- ltdl.h \
+ herc_getopt.h \
+ service.h \
+ chsc.h \
+@@ -1465,7 +1463,6 @@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/loadparm.Plo@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/logger.Plo@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/logmsg.Plo@am__quote@
+-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ltdl.Plo@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/machchk.Plo@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/memrchr.Plo@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/opcode.Plo@am__quote@
+--- crypto/Makefile.in.orig 2009-07-13 15:39:40.000000000 -0500
++++ crypto/Makefile.in 2009-07-13 15:39:44.000000000 -0500
+@@ -244,7 +244,7 @@
+ @OPTION_DYNAMIC_LOAD_FALSE@DYNSRC = $(dyndev_SRC)
+ @OPTION_DYNAMIC_LOAD_TRUE@DYNSRC =
+ @OPTION_DYNAMIC_LOAD_FALSE@LTDL =
+-@OPTION_DYNAMIC_LOAD_TRUE@LTDL = ../ltdl.c
++@OPTION_DYNAMIC_LOAD_TRUE@LTDL =
+ @OPTION_DYNAMIC_LOAD_FALSE@DYNMOD_LD_FLAGS =
+ @OPTION_DYNAMIC_LOAD_TRUE@DYNMOD_LD_FLAGS = -module \
+ @OPTION_DYNAMIC_LOAD_TRUE@ -no-undefined \
+--- decNumber/Makefile.in.orig 2009-07-13 15:40:23.000000000 -0500
++++ decNumber/Makefile.in 2009-07-13 15:40:25.000000000 -0500
+@@ -258,7 +258,7 @@
+ @BUILD_SHARED_FALSE@XSTATIC = -static
+ @BUILD_SHARED_TRUE@XSTATIC =
+ @OPTION_DYNAMIC_LOAD_FALSE@LTDL =
+-@OPTION_DYNAMIC_LOAD_TRUE@LTDL = ../ltdl.c
++@OPTION_DYNAMIC_LOAD_TRUE@LTDL =
+ @OPTION_DYNAMIC_LOAD_FALSE@LIB_LD_FLAGS = $(XSTATIC) \
+ @OPTION_DYNAMIC_LOAD_FALSE@ -no-undefined \
+ @OPTION_DYNAMIC_LOAD_FALSE@ -avoid-version
diff --git a/emulators/lib765/Makefile b/emulators/lib765/Makefile
index 0fa5df719851..e258782c22be 100644
--- a/emulators/lib765/Makefile
+++ b/emulators/lib765/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= http://www.seasip.demon.co.uk/Unix/LibDsk/
MAINTAINER= ports@FreeBSD.org
COMMENT= Emulation of uPD765a Floppy Disc Controller
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_LDCONFIG= yes
OPTIONS= LIBDSK "With LIBDSK support (recommended)" on
diff --git a/emulators/libdsk/Makefile b/emulators/libdsk/Makefile
index 33df36c6908e..d8bdc887ba29 100644
--- a/emulators/libdsk/Makefile
+++ b/emulators/libdsk/Makefile
@@ -14,7 +14,7 @@ MASTER_SITES= http://www.seasip.info/Unix/LibDsk/ \
MAINTAINER= pixel@hugbox.org
COMMENT= Enables access to disks and disk images; also via serial line
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:22
USE_LDCONFIG= yes
MAN1= apriboot.1 dskdump.1 dskform.1 dskid.1 dskscan.1 dsktrans.1\
diff --git a/emulators/xsystem35/Makefile b/emulators/xsystem35/Makefile
index 17aab6247829..b16a206712e5 100644
--- a/emulators/xsystem35/Makefile
+++ b/emulators/xsystem35/Makefile
@@ -17,7 +17,7 @@ COMMENT= AliceSoft System 3.5/3.6/3.8/3.9 on X Window System
LIB_DEPENDS= vorbis.4:${PORTSDIR}/audio/libvorbis \
jpeg.10:${PORTSDIR}/graphics/jpeg
-USE_AUTOTOOLS= autoconf:262 libtool:15
+USE_AUTOTOOLS= autoconf:262 libtool:22
USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= gtk12