aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2014-02-22 05:22:56 +0800
committerjkim <jkim@FreeBSD.org>2014-02-22 05:22:56 +0800
commitbe9345da8c51a837227bb685c9f5b62cae9a3a74 (patch)
treeb826ef1492b6bb1f9c53cb5b8d04a53d0afd6a27 /emulators
parent979479dc48ff602de978aec7aeb3b6d0830c6d79 (diff)
downloadfreebsd-ports-gnome-be9345da8c51a837227bb685c9f5b62cae9a3a74.tar.gz
freebsd-ports-gnome-be9345da8c51a837227bb685c9f5b62cae9a3a74.tar.zst
freebsd-ports-gnome-be9345da8c51a837227bb685c9f5b62cae9a3a74.zip
Fix build after re-appearance of converters/libiconv on 10+ (r341775).
Obtained from: svn.redports.org/virtualbox PR: ports/186847
Diffstat (limited to 'emulators')
-rw-r--r--emulators/virtualbox-ose-additions/Makefile1
-rw-r--r--emulators/virtualbox-ose-additions/files/patch-src-VBox-Runtime-Makefile.kmk14
-rw-r--r--emulators/virtualbox-ose-legacy/Makefile1
-rw-r--r--emulators/virtualbox-ose-legacy/files/patch-src-VBox-Runtime-Makefile.kmk18
-rw-r--r--emulators/virtualbox-ose/Makefile1
-rw-r--r--emulators/virtualbox-ose/files/patch-src-VBox-Runtime-Makefile.kmk18
6 files changed, 47 insertions, 6 deletions
diff --git a/emulators/virtualbox-ose-additions/Makefile b/emulators/virtualbox-ose-additions/Makefile
index 1bde6987f60b..7b2b34300421 100644
--- a/emulators/virtualbox-ose-additions/Makefile
+++ b/emulators/virtualbox-ose-additions/Makefile
@@ -108,6 +108,7 @@ post-patch:
.if empty(ICONV_LIB)
@${REINPLACE_CMD} -e 's|iconv||' ${WRKSRC}/Config.kmk ${WRKSRC}/src/VBox/Runtime/Makefile.kmk \
${WRKSRC}/src/VBox/Additions/x11/VBoxClient/Makefile.kmk
+ @${ECHO} 'VBOX_ICONV_DEFS = LIBICONV_PLUG' >> ${WRKSRC}/LocalConfig.kmk
.endif
pre-build:
diff --git a/emulators/virtualbox-ose-additions/files/patch-src-VBox-Runtime-Makefile.kmk b/emulators/virtualbox-ose-additions/files/patch-src-VBox-Runtime-Makefile.kmk
new file mode 100644
index 000000000000..4da15d3e545a
--- /dev/null
+++ b/emulators/virtualbox-ose-additions/files/patch-src-VBox-Runtime-Makefile.kmk
@@ -0,0 +1,14 @@
+--- src/VBox/Runtime/Makefile.kmk.orig 2013-12-18 11:10:31.000000000 -0500
++++ src/VBox/Runtime/Makefile.kmk 2014-02-20 18:14:28.000000000 -0500
+@@ -157,6 +157,11 @@
+ IPRT_BLDCFG_TYPE=\"$(KBUILD_TYPE)\"
+
+ #
++# Set the defines that utf8-posix.cpp needs. It's used by several targets.
++#
++r3/posix/utf8-posix.cpp_DEFS.freebsd = $(VBOX_ICONV_DEFS)
++
++#
+ # Unicode Specification reader used to regenerate unidata.cpp.
+ #
+ uniread_TEMPLATE = VBOXBLDPROG
diff --git a/emulators/virtualbox-ose-legacy/Makefile b/emulators/virtualbox-ose-legacy/Makefile
index 5af302e16842..2fcc25067f89 100644
--- a/emulators/virtualbox-ose-legacy/Makefile
+++ b/emulators/virtualbox-ose-legacy/Makefile
@@ -212,6 +212,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|\$$KBUILDDIR_BIN/kmk_sed|${LOCALBASE}/bin/kmk_sed|g' ${WRKSRC}/configure
.if empty(ICONV_LIB)
@${REINPLACE_CMD} -e 's|iconv||' ${WRKSRC}/Config.kmk ${WRKSRC}/src/VBox/Runtime/Makefile.kmk
+ @${ECHO} 'VBOX_ICONV_DEFS = LIBICONV_PLUG' >> ${WRKSRC}/LocalConfig.kmk
.endif
pre-build:
diff --git a/emulators/virtualbox-ose-legacy/files/patch-src-VBox-Runtime-Makefile.kmk b/emulators/virtualbox-ose-legacy/files/patch-src-VBox-Runtime-Makefile.kmk
index 32325a580314..436cabc019f5 100644
--- a/emulators/virtualbox-ose-legacy/files/patch-src-VBox-Runtime-Makefile.kmk
+++ b/emulators/virtualbox-ose-legacy/files/patch-src-VBox-Runtime-Makefile.kmk
@@ -1,6 +1,18 @@
---- src/VBox/Runtime/Makefile.kmk.orig 2013-06-21 16:27:18.000000000 +0400
-+++ src/VBox/Runtime/Makefile.kmk 2013-06-30 14:57:33.248215681 +0400
-@@ -844,7 +844,7 @@
+--- src/VBox/Runtime/Makefile.kmk.orig 2014-01-11 03:17:44.000000000 -0500
++++ src/VBox/Runtime/Makefile.kmk 2014-02-20 19:18:26.000000000 -0500
+@@ -141,6 +141,11 @@
+ IPRT_BLDCFG_TYPE=\"$(KBUILD_TYPE)\"
+
+ #
++# Set the defines that utf8-posix.cpp needs. It's used by several targets.
++#
++r3/posix/utf8-posix.cpp_DEFS.freebsd = $(VBOX_ICONV_DEFS)
++
++#
+ # Unicode Specification reader used to regenerate unidata.cpp.
+ #
+ uniread_TEMPLATE = VBOXBLDPROG
+@@ -844,7 +849,7 @@
r3/posix/RTMemProtect-posix.cpp \
r3/posix/RTPathUserHome-posix.cpp \
r3/posix/RTSystemQueryOSInfo-posix.cpp \
diff --git a/emulators/virtualbox-ose/Makefile b/emulators/virtualbox-ose/Makefile
index edcd6e0ce492..721fa3eb4066 100644
--- a/emulators/virtualbox-ose/Makefile
+++ b/emulators/virtualbox-ose/Makefile
@@ -221,6 +221,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|\$$KBUILDDIR_BIN/kmk_sed|${LOCALBASE}/bin/kmk_sed|g' ${WRKSRC}/configure
.if empty(ICONV_LIB)
@${REINPLACE_CMD} -e 's|iconv||' ${WRKSRC}/Config.kmk ${WRKSRC}/src/VBox/Runtime/Makefile.kmk
+ @${ECHO} 'VBOX_ICONV_DEFS = LIBICONV_PLUG' >> ${WRKSRC}/LocalConfig.kmk
.endif
pre-build:
diff --git a/emulators/virtualbox-ose/files/patch-src-VBox-Runtime-Makefile.kmk b/emulators/virtualbox-ose/files/patch-src-VBox-Runtime-Makefile.kmk
index 32325a580314..b97bedd1591a 100644
--- a/emulators/virtualbox-ose/files/patch-src-VBox-Runtime-Makefile.kmk
+++ b/emulators/virtualbox-ose/files/patch-src-VBox-Runtime-Makefile.kmk
@@ -1,6 +1,18 @@
---- src/VBox/Runtime/Makefile.kmk.orig 2013-06-21 16:27:18.000000000 +0400
-+++ src/VBox/Runtime/Makefile.kmk 2013-06-30 14:57:33.248215681 +0400
-@@ -844,7 +844,7 @@
+--- src/VBox/Runtime/Makefile.kmk.orig 2013-12-18 11:10:31.000000000 -0500
++++ src/VBox/Runtime/Makefile.kmk 2014-02-20 18:14:28.000000000 -0500
+@@ -157,6 +157,11 @@
+ IPRT_BLDCFG_TYPE=\"$(KBUILD_TYPE)\"
+
+ #
++# Set the defines that utf8-posix.cpp needs. It's used by several targets.
++#
++r3/posix/utf8-posix.cpp_DEFS.freebsd = $(VBOX_ICONV_DEFS)
++
++#
+ # Unicode Specification reader used to regenerate unidata.cpp.
+ #
+ uniread_TEMPLATE = VBOXBLDPROG
+@@ -906,7 +911,7 @@
r3/posix/RTMemProtect-posix.cpp \
r3/posix/RTPathUserHome-posix.cpp \
r3/posix/RTSystemQueryOSInfo-posix.cpp \