aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2011-06-12 00:22:34 +0800
committernox <nox@FreeBSD.org>2011-06-12 00:22:34 +0800
commitc02ef24c0865e2051372edc20c98138e5fad0f0c (patch)
treedac7d8a0ff412bbae0718a52f3089f91004f1563 /emulators
parent31088b8ed8cf359ae65eb981cc94fc03336eb82d (diff)
downloadfreebsd-ports-gnome-c02ef24c0865e2051372edc20c98138e5fad0f0c.tar.gz
freebsd-ports-gnome-c02ef24c0865e2051372edc20c98138e5fad0f0c.tar.zst
freebsd-ports-gnome-c02ef24c0865e2051372edc20c98138e5fad0f0c.zip
- Update to 0.14.1 .
- Change ALL_TARGETS knob to only affect the bsd-user targets that are still incomplete. (they would be for emulating a single process instead of an entire OS; default off i.e. don't build them.) - Fix ADD_AUDIO knob to also emulate hda sound hardware. - Change CONFLICTS to CONFLICTS_INSTALL in case people that already have emulators/qemu installed want to test this version from below the work/ dir. - Prepare Makefile for sparc64 host build in case someone wants to debug the runtime problems there. [1] (Add sparc64 to ONLY_FOR_ARCHS then.) PR: ports/138772 [1] Submitted by: Nathaniel Filardo <nwf@cs.jhu.edu> [1]
Diffstat (limited to 'emulators')
-rw-r--r--emulators/qemu-devel/Makefile24
-rw-r--r--emulators/qemu-devel/distinfo4
-rw-r--r--emulators/qemu-devel/pkg-plist30
3 files changed, 33 insertions, 25 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index c2dfa2c380ce..48a772b3969f 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= qemu
-PORTVERSION= 0.14.0
-PORTREVISION= 1
+PORTVERSION= 0.14.1
CATEGORIES= emulators
MASTER_SITES= SAVANNAH:release \
LOCAL:snapshot
@@ -26,8 +25,8 @@ PATCH_STRIP= -p1
MAKE_ENV+= BSD_MAKE="${MAKE}" LDFLAGS="${LDFLAGS}"
MAN1= qemu.1 qemu-img.1
MAN8= qemu-nbd.8
-ONLY_FOR_ARCHS= amd64 i386 powerpc
-CONFLICTS= qemu-[0-9]*
+ONLY_FOR_ARCHS= amd64 i386 powerpc # XXX someone wants to debug sparc64 hosts?
+CONFLICTS_INSTALL= qemu-[0-9]*
MAKE_JOBS_SAFE= yes
OPTIONS= SAMBA "samba dependency (for -smb)" Off \
@@ -37,20 +36,25 @@ OPTIONS= SAMBA "samba dependency (for -smb)" Off \
PCAP "pcap dependency (networking with bpf)" On \
CDROM_DMA "IDE CDROM DMA" On \
ADD_AUDIO "Emulate more audio hardware (experimental!)" Off \
- ALL_TARGETS "Also build non-x86 and user targets" On
+ ALL_TARGETS "Also build bsd-user targets (for testing)" Off
.include <bsd.port.pre.mk>
.if defined(WITHOUT_ALL_TARGETS)
-CONFIGURE_ARGS+= --target-list=i386-softmmu,x86_64-softmmu
+CONFIGURE_ARGS+= --disable-bsd-user
PLIST_SUB+= ALLTARGETS="@comment "
.else
PLIST_SUB+= ALLTARGETS=""
+.if ${ARCH} == "sparc64"
+IGNORE= bsd-user targets not tested on sparc64
+.endif
.endif
WITHOUT_CPU_CFLAGS=yes #to avoid problems with register allocation
CFLAGS:= ${CFLAGS:C/-fno-tree-vrp//}
CONFIGURE_ARGS+= --prefix=${PREFIX} --cc=${CC} --enable-docs \
+ --disable-linux-user --disable-linux-aio \
+ --disable-darwin-user --disable-kvm --disable-xen \
--extra-cflags=-DSMBD_COMMAND=\\\"${LOCALBASE}/sbin/smbd\\\"\ -I${WRKSRC}\ -I${LOCALBASE}/include\ -DPREFIX=\\\"${PREFIX}\\\"
.if defined(WITHOUT_SDL)
@@ -76,7 +80,7 @@ CONFIGURE_ARGS+= --enable-pcap
.endif
.if defined(WITH_ADD_AUDIO)
-CONFIGURE_ARGS+= --audio-card-list=ac97,es1370,sb16,cs4231a,adlib,gus
+CONFIGURE_ARGS+= --audio-card-list=ac97,es1370,sb16,cs4231a,adlib,gus,hda
.endif
.if defined(WITH_SAMBA)
@@ -97,6 +101,10 @@ MAKE_ARGS+= ARCH=x86_64
MAKE_ARGS+= ARCH=ppc
.endif
+.if ${ARCH} == "sparc64"
+CONFIGURE_ARGS+= --sparc_cpu=v9
+.endif
+
.if ${OSVERSION} < 900033 && ${ARCH} == "amd64"
BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
CONFIGURE_ENV+= COMPILER_PATH=${LOCALBASE}/bin
@@ -109,7 +117,7 @@ pre-patch:
done
post-patch:
-.if ${ARCH} == "powerpc"
+.if (${ARCH} == "powerpc" || ${ARCH} == "sparc64")
.if ${OSVERSION} < 800030
# These OSVERSION don't have all the needed long double fns in their
# libc so just disable 80 bit floats completely.
diff --git a/emulators/qemu-devel/distinfo b/emulators/qemu-devel/distinfo
index 75cf3c2517dd..3e099794638b 100644
--- a/emulators/qemu-devel/distinfo
+++ b/emulators/qemu-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (qemu/qemu-0.14.0.tar.gz) = ba21e84d7853217830e167dae9999cdbff481189c6a0bb600ac7fb7201453108
-SIZE (qemu/qemu-0.14.0.tar.gz) = 5439695
+SHA256 (qemu/qemu-0.14.1.tar.gz) = 33ceae3fbe516f2cbb151dc98d16c8ccfec74b1056674ad715e75a2f7fed45c3
+SIZE (qemu/qemu-0.14.1.tar.gz) = 5439697
diff --git a/emulators/qemu-devel/pkg-plist b/emulators/qemu-devel/pkg-plist
index 8c42f0990522..8f0206e40690 100644
--- a/emulators/qemu-devel/pkg-plist
+++ b/emulators/qemu-devel/pkg-plist
@@ -2,21 +2,21 @@ bin/qemu
bin/qemu-img
bin/qemu-io
bin/qemu-nbd
-%%ALLTARGETS%%bin/qemu-system-arm
-%%ALLTARGETS%%bin/qemu-system-cris
-%%ALLTARGETS%%bin/qemu-system-m68k
-%%ALLTARGETS%%bin/qemu-system-microblaze
-%%ALLTARGETS%%bin/qemu-system-mips
-%%ALLTARGETS%%bin/qemu-system-mips64
-%%ALLTARGETS%%bin/qemu-system-mips64el
-%%ALLTARGETS%%bin/qemu-system-mipsel
-%%ALLTARGETS%%bin/qemu-system-ppc
-%%ALLTARGETS%%bin/qemu-system-ppc64
-%%ALLTARGETS%%bin/qemu-system-ppcemb
-%%ALLTARGETS%%bin/qemu-system-sh4
-%%ALLTARGETS%%bin/qemu-system-sh4eb
-%%ALLTARGETS%%bin/qemu-system-sparc
-%%ALLTARGETS%%bin/qemu-system-sparc64
+bin/qemu-system-arm
+bin/qemu-system-cris
+bin/qemu-system-m68k
+bin/qemu-system-microblaze
+bin/qemu-system-mips
+bin/qemu-system-mips64
+bin/qemu-system-mips64el
+bin/qemu-system-mipsel
+bin/qemu-system-ppc
+bin/qemu-system-ppc64
+bin/qemu-system-ppcemb
+bin/qemu-system-sh4
+bin/qemu-system-sh4eb
+bin/qemu-system-sparc
+bin/qemu-system-sparc64
%%ALLTARGETS%%bin/qemu-i386
%%ALLTARGETS%%bin/qemu-sparc
%%ALLTARGETS%%bin/qemu-sparc64