aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authordim <dim@FreeBSD.org>2016-01-25 00:25:26 +0800
committerdim <dim@FreeBSD.org>2016-01-25 00:25:26 +0800
commitd3358adc516b2ebb1f1771358633ece89646c43b (patch)
tree18dc148b9f14f66bde92887b5d8117b2c2521c06 /emulators
parent7c780659c9f4a02ce86521a2301231753ec5c941 (diff)
downloadfreebsd-ports-gnome-d3358adc516b2ebb1f1771358633ece89646c43b.tar.gz
freebsd-ports-gnome-d3358adc516b2ebb1f1771358633ece89646c43b.tar.zst
freebsd-ports-gnome-d3358adc516b2ebb1f1771358633ece89646c43b.zip
During the exp-run in bug 206074, it was found that emulators/simh gives
errors with a recent clang 3.8.0 snapshot [1]: /usr/bin/ld: unrecognized option '-plugin' And more of such linking errors. This is because the simh main Makefile attempts to use -flto -fwhole-program with clang, but this support depends on the correctly link time optimization infrastructure being installed (e.g. the LLVMgold.so plugin, and more). Since LTO is not available yet in base, here is a patch to disable the use of these options more thorougly. Approved by: koobs (ports) PR: 206411 MFH: 2016Q1
Diffstat (limited to 'emulators')
-rw-r--r--emulators/simh/Makefile2
-rw-r--r--emulators/simh/files/patch-makefile15
2 files changed, 16 insertions, 1 deletions
diff --git a/emulators/simh/Makefile b/emulators/simh/Makefile
index df78e0c08311..fb22cb03877f 100644
--- a/emulators/simh/Makefile
+++ b/emulators/simh/Makefile
@@ -13,7 +13,7 @@ COMMENT= Emulates classic DEC, HP, GRI, IBM, Altair, SDS, Honeywell, and others
NO_WRKSUBDIR= yes
USES= gmake dos2unix zip
-DOS2UNIX_FILES= VAX/vax_sysdev.c
+DOS2UNIX_FILES= makefile VAX/vax_sysdev.c
MAKE_ENV= GCC="${CC}" CFLAGS_O="${CFLAGS}" USE_NETWORK=1
MAKEFILE= makefile
diff --git a/emulators/simh/files/patch-makefile b/emulators/simh/files/patch-makefile
new file mode 100644
index 000000000000..c82ad74e8401
--- /dev/null
+++ b/emulators/simh/files/patch-makefile
@@ -0,0 +1,15 @@
+--- makefile.orig 2012-04-23 16:28:04.000000000 +0200
++++ makefile 2016-01-19 20:21:21.371550000 +0100
+@@ -332,8 +332,10 @@
+ endif
+ ifeq (,$(NO_LTO))
+ ifneq (,$(findstring -flto,$(GCC_OPTIMIZERS)))
+- CFLAGS_O += -flto -fwhole-program
+- LDFLAGS_O += -flto -fwhole-program
++ ifneq (,$(findstring -fwhole-program,$(GCC_OPTIMIZERS)))
++ CFLAGS_O += -flto -fwhole-program
++ LDFLAGS_O += -flto -fwhole-program
++ endif
+ endif
+ endif
+ BUILD_FEATURES = - compiler optimizations and no debugging support