aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2011-12-21 07:46:34 +0800
committeracm <acm@FreeBSD.org>2011-12-21 07:46:34 +0800
commitdcaa32fc853583873b17df622d16c315713be772 (patch)
tree4e77ab45ae9a9bfcf547a42c1c9275a9b493a0ca /emulators
parente0221530daea89999c5a2175c13617a7a740ccf7 (diff)
downloadfreebsd-ports-gnome-dcaa32fc853583873b17df622d16c315713be772.tar.gz
freebsd-ports-gnome-dcaa32fc853583873b17df622d16c315713be772.tar.zst
freebsd-ports-gnome-dcaa32fc853583873b17df622d16c315713be772.zip
- New port: emulators/mupen64plus-rsp-z64
Low-level RSP processor plugin for the Mupen64Plus
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/mupen64plus-rsp-z64/Makefile30
2 files changed, 31 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 0d1ec87499d7..d3867656c9ff 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -113,6 +113,7 @@
SUBDIR += mupen64plus-core
SUBDIR += mupen64plus-input-sdl
SUBDIR += mupen64plus-rsp-hle
+ SUBDIR += mupen64plus-rsp-z64
SUBDIR += mupen64plus-ui-console
SUBDIR += mupen64plus-video-rice
SUBDIR += nonpareil
diff --git a/emulators/mupen64plus-rsp-z64/Makefile b/emulators/mupen64plus-rsp-z64/Makefile
new file mode 100644
index 000000000000..4b2c053f3cec
--- /dev/null
+++ b/emulators/mupen64plus-rsp-z64/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: mupen64plus-rsp-z64
+# Date created: 2011-12-20
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+PKGNAMESUFFIX= -rsp-z64
+DISTFILES= ${PORTNAME}${PKGNAMESUFFIX}-src-${PORTVERSION}${EXTRACT_SUFX}:plugin
+
+COMMENT= Low-level RSP processor plugin for the Mupen64Plus
+
+LIB_DEPENDS= mupen64plus.2:${PORTSDIR}/emulators/mupen64plus-core
+
+USE_GL= #
+USE_SDL= #
+
+MASTERDIR= ${.CURDIR}/../mupen64plus-core
+
+OPTIONS= #
+
+CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/${PORTNAME}
+LDFLAGS+= -L${LOCALBASE}/lib
+
+EXTRACT_AFTER_ARGS= | ${TAR} -xf -
+BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}${PKGNAMESUFFIX}/projects/unix
+WRKSRC= ${WRKDIR}
+
+.include "${MASTERDIR}/Makefile"