aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2014-03-24 08:03:39 +0800
committeracm <acm@FreeBSD.org>2014-03-24 08:03:39 +0800
commitf8901fbb40a11054bfc198f0881ccfd3acfbfe8e (patch)
treec42e4c71b411814d3a3a976cc2120138955f1729 /emulators
parent91d4f6e68290d3d6ea033b68143afe608070bdc6 (diff)
downloadfreebsd-ports-gnome-f8901fbb40a11054bfc198f0881ccfd3acfbfe8e.tar.gz
freebsd-ports-gnome-f8901fbb40a11054bfc198f0881ccfd3acfbfe8e.tar.zst
freebsd-ports-gnome-f8901fbb40a11054bfc198f0881ccfd3acfbfe8e.zip
- Fix build with clang
Reported by: pkg-fallout
Diffstat (limited to 'emulators')
-rw-r--r--emulators/mupen64plus-core/Makefile2
-rw-r--r--emulators/mupen64plus-core/Makefile.common11
2 files changed, 12 insertions, 1 deletions
diff --git a/emulators/mupen64plus-core/Makefile b/emulators/mupen64plus-core/Makefile
index 09e2852e2602..e4041da9f3ed 100644
--- a/emulators/mupen64plus-core/Makefile
+++ b/emulators/mupen64plus-core/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mupen64plus
PORTVERSION?= 2.0
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
${MASTER_SITE_LOCAL:S,$,acm/${PORTNAME}/,} \
diff --git a/emulators/mupen64plus-core/Makefile.common b/emulators/mupen64plus-core/Makefile.common
index a586d35afdbb..4693a0c35199 100644
--- a/emulators/mupen64plus-core/Makefile.common
+++ b/emulators/mupen64plus-core/Makefile.common
@@ -29,11 +29,19 @@ LIB_DEPENDS+= libboost_thread.so:${PORTSDIR}/devel/boost-libs
.if ${PKGNAMESUFFIX} != "-core"
post-patch:
+ @cd ${BUILD_WRKSRC} && ${REINPLACE_CMD} -e 's|gcc|${CC}|g' -e \
+ 's|g++|${CXX}|g' Makefile
. if ${PKGNAMESUFFIX} == "-video-glide64mk2"
@cd ${WRKSRC}/source/${PORTNAME}${PKGNAMESUFFIX}/src && \
${REINPLACE_CMD} -e 's|#include <thread>||g' \
GlideHQ/TxQuantize.cpp GlideHQ/TxFilter.cpp
. endif
+. if ${PKGNAMESUFFIX} == "-video-glide64"
+ @cd ${WRKSRC}/${PORTNAME}${PKGNAMESUFFIX}/src && \
+ ${REINPLACE_CMD} -e 's|__builtin_ia32_loadups|_mm_loadu_ps|g' -e \
+ 's|__builtin_ia32_storeups|_mm_storeu_ps|g' \
+ 3dmath.cpp
+. endif
pre-install:
@${RM} -f ${PLIST}
@@ -60,6 +68,9 @@ pre-install:
. else
@${ECHO_CMD} "bin/${PORTNAME}" >> ${PLIST}
. endif
+.else
+ @cd ${BUILD_WRKSRC} && ${REINPLACE_CMD} -e 's|gcc|${CC}|g' -e \
+ 's|g++|${CXX}|g' Makefile
.endif
do-install: