aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2007-02-25 23:14:46 +0800
committeralepulver <alepulver@FreeBSD.org>2007-02-25 23:14:46 +0800
commit1716fc226925ab5541e594c979734df895ff71d6 (patch)
treea8f3d35afb4605fb422882b208c5adb5065c8e7e /emulators
parent2d5d1eb7e8b1e0172844a8673046c77d8579a136 (diff)
downloadfreebsd-ports-gnome-1716fc226925ab5541e594c979734df895ff71d6.tar.gz
freebsd-ports-gnome-1716fc226925ab5541e594c979734df895ff71d6.tar.zst
freebsd-ports-gnome-1716fc226925ab5541e594c979734df895ff71d6.zip
AdvanceMENU is a frontend for AdvanceMAME, MAME, MESS, RAINE and any other
emulator. It runs in Linux, Mac OS X, DOS, Windows and in all the other platforms supported by the SDL library. The main features are: * Auto update of the rom info. * Vertical and horizontal orientation. * Support for any TV/Arcade Monitor like AdvanceMAME but it's good also for a normal PC monitor. * Static and Animated image and clip preview (PNG/PCX/ICO/MNG). Up to 192 images at the same time! * Sound preview. (MP3/WAV). You can select a special sound for every game played when the cursor move on it. * Sound backgrounds (MP3/WAV). Play your favourite songs or radio records in background. * Sound effects (MP3/WAV) for key press, program start, game start, program exit... * Support for zipped images and sounds archives. * Screensaver. A slide show of the game images. * Selectable background and help images with translucency. WWW: http://advancemame.sourceforge.net/
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/advancemenu/Makefile56
-rw-r--r--emulators/advancemenu/distinfo3
-rw-r--r--emulators/advancemenu/pkg-descr23
-rw-r--r--emulators/advancemenu/pkg-plist30
5 files changed, 113 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 14929fdd7850..76b2350068e6 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -5,6 +5,7 @@
SUBDIR += adamem
SUBDIR += advancemame
+ SUBDIR += advancemenu
SUBDIR += advancemess
SUBDIR += aftp
SUBDIR += atari800
diff --git a/emulators/advancemenu/Makefile b/emulators/advancemenu/Makefile
new file mode 100644
index 000000000000..c7e68a632645
--- /dev/null
+++ b/emulators/advancemenu/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: advancemenu
+# Date created: 2007-01-10
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= advancemenu
+PORTVERSION= 2.4.13
+CATEGORIES= emulators
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= advancemame
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= AdvanceMENU is a frontend for AdvanceMAME, MAME, MESS, RAINE
+
+LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
+
+USE_GL= yes
+USE_GMAKE= yes
+USE_SDL= sdl
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+
+OPTIONS= FREETYPE "Enable FreeType2 support" off \
+ SLANG "Enable sLang support (for video driver)" off
+
+MAN1= advmenu.1
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "i386"
+BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
+.endif
+
+.if defined(WITH_FREETYPE)
+LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
+.else
+CONFIGURE_ARGS+=--disable-freetype
+.endif
+
+.if defined(WITH_SLANG)
+LIB_DEPENDS+= slang.2:${PORTSDIR}/devel/libslang2
+.else
+CONFIGURE_ARGS+=--disable-slang
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -Ee 's|^(pkg.*)/advance|\1/${PORTNAME}|' \
+ ${WRKSRC}/advance/advance.mak
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '/pkgdocdir/d' ${WRKSRC}/advance/advance.mak
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/emulators/advancemenu/distinfo b/emulators/advancemenu/distinfo
new file mode 100644
index 000000000000..035bf0952262
--- /dev/null
+++ b/emulators/advancemenu/distinfo
@@ -0,0 +1,3 @@
+MD5 (advancemenu-2.4.13.tar.gz) = c75e4254cb9159c18ccb521c0b5aae47
+SHA256 (advancemenu-2.4.13.tar.gz) = 1e5099ff3aadc07153153a7c898c987b20f69a67740e05d6d21fc4582c4a685b
+SIZE (advancemenu-2.4.13.tar.gz) = 2235347
diff --git a/emulators/advancemenu/pkg-descr b/emulators/advancemenu/pkg-descr
new file mode 100644
index 000000000000..02e096377686
--- /dev/null
+++ b/emulators/advancemenu/pkg-descr
@@ -0,0 +1,23 @@
+AdvanceMENU is a frontend for AdvanceMAME, MAME, MESS, RAINE and any other
+emulator.
+
+It runs in Linux, Mac OS X, DOS, Windows and in all the other platforms
+supported by the SDL library. The main features are:
+
+* Auto update of the rom info.
+* Vertical and horizontal orientation.
+* Support for any TV/Arcade Monitor like AdvanceMAME but it's good also for a
+ normal PC monitor.
+* Static and Animated image and clip preview (PNG/PCX/ICO/MNG). Up to 192
+ images at the same time!
+* Sound preview. (MP3/WAV). You can select a special sound for every game
+ played when the cursor move on it.
+* Sound backgrounds (MP3/WAV). Play your favourite songs or radio records in
+ background.
+* Sound effects (MP3/WAV) for key press, program start, game start, program
+ exit...
+* Support for zipped images and sounds archives.
+* Screensaver. A slide show of the game images.
+* Selectable background and help images with translucency.
+
+WWW: http://advancemame.sourceforge.net/
diff --git a/emulators/advancemenu/pkg-plist b/emulators/advancemenu/pkg-plist
new file mode 100644
index 000000000000..3225c96ac92b
--- /dev/null
+++ b/emulators/advancemenu/pkg-plist
@@ -0,0 +1,30 @@
+bin/advmenu
+%%PORTDOCS%%%%DOCSDIR%%/advcfg.html
+%%PORTDOCS%%%%DOCSDIR%%/advcfg.txt
+%%PORTDOCS%%%%DOCSDIR%%/advdev.html
+%%PORTDOCS%%%%DOCSDIR%%/advdev.txt
+%%PORTDOCS%%%%DOCSDIR%%/advmenu.html
+%%PORTDOCS%%%%DOCSDIR%%/advmenu.txt
+%%PORTDOCS%%%%DOCSDIR%%/advv.html
+%%PORTDOCS%%%%DOCSDIR%%/advv.txt
+%%PORTDOCS%%%%DOCSDIR%%/authors.html
+%%PORTDOCS%%%%DOCSDIR%%/authors.txt
+%%PORTDOCS%%%%DOCSDIR%%/build.html
+%%PORTDOCS%%%%DOCSDIR%%/build.txt
+%%PORTDOCS%%%%DOCSDIR%%/carddos.html
+%%PORTDOCS%%%%DOCSDIR%%/carddos.txt
+%%PORTDOCS%%%%DOCSDIR%%/cardlinx.html
+%%PORTDOCS%%%%DOCSDIR%%/cardlinx.txt
+%%PORTDOCS%%%%DOCSDIR%%/cost.html
+%%PORTDOCS%%%%DOCSDIR%%/cost.txt
+%%PORTDOCS%%%%DOCSDIR%%/faq.html
+%%PORTDOCS%%%%DOCSDIR%%/faq.txt
+%%PORTDOCS%%%%DOCSDIR%%/histmenu.html
+%%PORTDOCS%%%%DOCSDIR%%/histmenu.txt
+%%PORTDOCS%%%%DOCSDIR%%/install.html
+%%PORTDOCS%%%%DOCSDIR%%/install.txt
+%%PORTDOCS%%%%DOCSDIR%%/readmenu.html
+%%PORTDOCS%%%%DOCSDIR%%/readmenu.txt
+%%PORTDOCS%%%%DOCSDIR%%/relemenu.html
+%%PORTDOCS%%%%DOCSDIR%%/relemenu.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%