aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorgreen <green@FreeBSD.org>2003-08-09 21:21:14 +0800
committergreen <green@FreeBSD.org>2003-08-09 21:21:14 +0800
commit4397e5cf59b974a0e80d7f821ccddcb81a38d6a8 (patch)
treeb681c02e656ae8b7134c5ffc40c81285cf6e9ec6 /emulators
parent2d902b91bf7756bdaa3329384e7b1b0ec26c3197 (diff)
downloadfreebsd-ports-gnome-4397e5cf59b974a0e80d7f821ccddcb81a38d6a8.tar.gz
freebsd-ports-gnome-4397e5cf59b974a0e80d7f821ccddcb81a38d6a8.tar.zst
freebsd-ports-gnome-4397e5cf59b974a0e80d7f821ccddcb81a38d6a8.zip
Now that there's a download site again, upgrade to version 1.40.
Submitted by: KATO Tsuguru <tkato@prontomail.com> PR: ports/44225
Diffstat (limited to 'emulators')
-rw-r--r--emulators/snes9x/Makefile76
-rw-r--r--emulators/snes9x/distinfo2
-rw-r--r--emulators/snes9x/files/patch-2XSAI.CPP21
-rw-r--r--emulators/snes9x/files/patch-aa83
-rw-r--r--emulators/snes9x/files/patch-ad21
-rw-r--r--emulators/snes9x/files/patch-ae31
-rw-r--r--emulators/snes9x/files/patch-af55
-rw-r--r--emulators/snes9x/files/patch-aj6
-rw-r--r--emulators/snes9x/files/patch-ak6
9 files changed, 132 insertions, 169 deletions
diff --git a/emulators/snes9x/Makefile b/emulators/snes9x/Makefile
index 2045fda18739..7a90e2c59c6d 100644
--- a/emulators/snes9x/Makefile
+++ b/emulators/snes9x/Makefile
@@ -6,48 +6,64 @@
#
PORTNAME= snes9x
-PORTVERSION= 1.37c
+PORTVERSION= 1.40
CATEGORIES= emulators
-# MASTER_SITES= http://www.snes9x.com/zips/ is nonexistant right now
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= green
-DISTNAME= s9xs137c
+MASTER_SITES= http://www.lysator.liu.se/snes9x/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src-2
MAINTAINER= green@FreeBSD.org
COMMENT= Super Nintendo Entertainment System(SNES) Emulator
-.if ${MACHINE_ARCH} == i386
-BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
-.elif ${MACHINE_ARCH} == alpha
-MAKEFILE= Makefile.alpha
-BROKEN= currently does not work on alpha
-.endif
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-src/snes9x
-USE_GMAKE= YES
USE_X_PREFIX= YES
-MAKE_ENV= CC="${CC}" CXX="${CXX}" CFLAGS="${CFLAGS}" \
- CXXFLAGS="${CXXFLAGS}"
-USE_ZIP= YES
-WRKSRC= ${WRKDIR}/release
+USE_GMAKE= YES
+MAKE_ARGS= CC="${CC} ${CFLAGS}" CCC="${CXX} ${CXXFLAGS}" \
+ INCLUDES="-I${X11BASE}/include ${PTHREAD_CFLAGS}" \
+ LDLIBS="-L${X11BASE}/lib ${PTHREAD_LIBS}" \
+ THREAD_SOUND=1 NETPLAY=1 UNZIP=1
-.if exists(/usr/lib/libusbhid.a)
-MAKE_ENV+= USB_JOYSTICK_SUPPORT=yes
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "i386"
+BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
+MAKE_ARGS+= ZSNESFX=1 ZSNESC4=1 ASMCPU=1 NASM="nasm" I386SPC="i386/SPC.O"
+.if defined(WITH_MMX)
+MAKE_ARGS+= ASMKREED=1
+.endif
.endif
-ONLY_FOR_ARCHS= i386
-
-.if ${MACHINE_ARCH} == alpha
-post-patch:
- @${SED} -e '/^ZSNESFX/d' \
- -e '/^ASMCPU/d' \
- -e '/^OPTIMISE/s/-mpentium //' \
- -e '/^-Ii386/d' \
- -e '/offsets >/s:i386/::' \
- < ${WRKSRC}/Makefile \
- > ${WRKSRC}/Makefile.alpha
+.if exists(/usr/lib/libusbhid.a)
+JOYDEFINES= -DJOYSTICK_SUPPORT
+SYSLIBS= -lusbhid
.endif
+do-configure:
+ @cd ${WRKSRC} && ${SED} \
+ 's:@ZSNESFX@:: ; \
+ s:@ZSNESC4@::g ; \
+ s:@ASMCPU@::g ; \
+ s:@SPC700ASM@::g ; \
+ s:@GLIDE@::g ; \
+ s:@OPENGL@::g ; \
+ s:@AIDO@::g ; \
+ s:@THREAD_SOUND@::g ; \
+ s:@ASMKREED@::g ; \
+ s:@I386SPC@:$${I386SPC}:g ; \
+ s:@JOYDEFINES@:${JOYDEFINES}:g ; \
+ s:@CXX@::g ; \
+ s:@RTTIFLAG@::g ; \
+ s:@CC@::g ; \
+ s:@NASM@::g ; \
+ s:@XINCLUDES@::g ; \
+ s:@OPTIMIZE@::g ; \
+ s:@CPUINC@::g ; \
+ s:@SYSDEFINES@:-DZLIB:g ; \
+ s:@SYSLIBS@:${SYSLIBS}:g ; \
+ s: -lpthread::g ; \
+ s: \.\./zlib/libz\.a::g' < Makefile.in > Makefile
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/snes9x ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/emulators/snes9x/distinfo b/emulators/snes9x/distinfo
index 465d5020bbf4..c440a415dee9 100644
--- a/emulators/snes9x/distinfo
+++ b/emulators/snes9x/distinfo
@@ -1 +1 @@
-MD5 (s9xs137c.zip) = 45a29cb3ba2354c3fa7ad936ac655a07
+MD5 (snes9x-1.40-src-2.tar.gz) = 81c1f8c687fb45fc20d631dd17702a20
diff --git a/emulators/snes9x/files/patch-2XSAI.CPP b/emulators/snes9x/files/patch-2XSAI.CPP
new file mode 100644
index 000000000000..3a00cac91e40
--- /dev/null
+++ b/emulators/snes9x/files/patch-2XSAI.CPP
@@ -0,0 +1,21 @@
+--- 2XSAI.CPP.orig Fri Jul 25 23:20:19 2003
++++ 2XSAI.CPP Sat Aug 9 00:54:02 2003
+@@ -81,12 +81,12 @@
+ #include "port.h"
+ #include "gfx.h"
+
+-#if (!defined(NOASM) && defined (__i386__) || defined (__i486__) || \
+- defined (__i586__) || defined (__WIN32__) || defined (__DJGPP))
+-# ifndef MMX
+-# define MMX
+-# endif
+-#endif
++//#if (!defined(NOASM) && defined (__i386__) || defined (__i486__) || \
++// defined (__i586__) || defined (__WIN32__) || defined (__DJGPP))
++//# ifndef MMX
++//# define MMX
++//# endif
++//#endif
+
+ extern "C"
+ {
diff --git a/emulators/snes9x/files/patch-aa b/emulators/snes9x/files/patch-aa
deleted file mode 100644
index b86fedec824e..000000000000
--- a/emulators/snes9x/files/patch-aa
+++ /dev/null
@@ -1,83 +0,0 @@
---- Makefile.orig Wed Feb 28 12:29:58 2001
-+++ Makefile Sat Sep 28 20:50:19 2002
-@@ -4,7 +4,6 @@
- #SPC700ASM=1
- NETPLAY=1
- UNZIP=1
--GLIDE=1
- #GUI=1
- THREAD_SOUND=1
- ASMKREED=1
-@@ -81,11 +80,6 @@
- UNZIPDEFINES=-DUNZIP_SUPPORT
- endif
-
--ifdef THREAD_SOUND
--CPUDEFINES += -DUSE_THREADS
--EXTRALIBS += -lpthread
--endif
--
- ifdef GLIDE
- GLIDEOBJS = unix/glide.o
- GLIDEDEFINES = -DUSE_GLIDE -I/usr/include/glide
-@@ -98,13 +92,13 @@
- endif
-
- MOC = $(QTDIR)/bin/moc
--CCC = g++ -fno-rtti
-+CCC = $(CXX) -fno-rtti
- CC = gcc
- NASM = nasm
-
--INCLUDES=-I/usr/X11R6/include -I/usr/local/include
-+INCLUDES=-I$(X11BASE)/include -I$(LOCALBASE)/include
-
--OPTIMISE= -O6 -mpentium -fomit-frame-pointer -fno-exceptions -Wall -W -pedantic -pipe
-+OPTIMISE= $(CFLAGS) -fomit-frame-pointer -fno-exceptions -Wall -W -pedantic -pipe
-
- #OPTIMISE=-g -fno-exceptions
- #-DMITSHM
-@@ -119,6 +113,7 @@
- -DDEBUGGER \
- -DCPU_SHUTDOWN \
- -DSPC700_SHUTDOWN \
-+-DSOUND \
- $(LINUXDEFINES) \
- $(FXDEFINES) \
- $(C4DEFINES) \
-@@ -131,6 +126,11 @@
- $(KREEDDEFINES)
- #-DNO_INLINE_SET_GET
-
-+ifdef USB_JOYSTICK_SUPPORT
-+CCFLAGS += -DJOYSTICK_SUPPORT
-+EXTRALIBS += -lusbhid
-+endif
-+
- #-DSOUND
- #-DDEBUGGER
- #-DNO_INLINE_SET_GET
-@@ -138,12 +138,10 @@
- #-DCPU_SHUTDOWN
- #-DSPC700_SHUTDOWN
-
--CFLAGS=$(CCFLAGS)
--
- .SUFFIXES: .o .cpp .c .cc .h .m .i .S .asm .obj
--LDLIBS = -L/usr/X11R6/lib frame.o
-+LDLIBS = -L$(X11BASE)/lib
-
--all: offsets snes9x ssnes9x
-+all: offsets snes9x
-
- #ggisnes9x
- #xf86snes9x
-@@ -165,7 +163,7 @@
- ./offsets >i386/offsets.h
-
- snes9x: $(OBJECTS) unix/x11.o $(GLIDEOBJS) $(GUIOBJS)
-- $(CCC) $(INCLUDES) -o $@ $(OBJECTS) $(GLIDEOBJS) unix/x11.o $(GUIOBJS) $(LDLIBS) $(GLIDELIBS) $(GUILIBS) -lXxf86dga -lXxf86vm -lXext -lX11 $(EXTRALIBS) -lz -lm
-+ $(CCC) $(INCLUDES) $(OPTIMISE) -o $@ $(OBJECTS) $(GLIDEOBJS) unix/x11.o $(GUIOBJS) $(LDLIBS) $(GLIDELIBS) $(GUILIBS) -lXxf86dga -lXxf86vm -lXext -lX11 $(EXTRALIBS) -lz -lm
-
- ssnes9x: $(OBJECTS) unix/svga.o $(GLIDEOBJS)
- $(CCC) $(INCLUDES) -o $@ $(OBJECTS) $(GLIDEOBJS) unix/svga.o $(LDLIBS) $(GLIDELIBS) -lvga -lvgagl -lz $(EXTRALIBS) -lm
diff --git a/emulators/snes9x/files/patch-ad b/emulators/snes9x/files/patch-ad
index 3c75d946a057..eb743156a502 100644
--- a/emulators/snes9x/files/patch-ad
+++ b/emulators/snes9x/files/patch-ad
@@ -1,8 +1,7 @@
-diff -ru ../../work/release/memmap.cpp ./memmap.cpp
---- ../../work/release/memmap.cpp Thu Sep 23 19:56:48 1999
-+++ ./memmap.cpp Wed Dec 29 01:54:04 1999
-@@ -39,7 +39,7 @@
- #include <string.h>
+--- MEMMAP.CPP.orig Fri Jul 25 23:20:19 2003
++++ MEMMAP.CPP Sat Aug 9 01:08:05 2003
+@@ -79,7 +79,7 @@
+ #endif
#include <ctype.h>
-#ifdef __linux
@@ -10,12 +9,12 @@ diff -ru ../../work/release/memmap.cpp ./memmap.cpp
#include <unistd.h>
#endif
-@@ -737,7 +737,7 @@
- {
- fwrite ((char *) ::SRAM, size, 1, file);
- fclose (file);
+@@ -1443,7 +1443,7 @@
+ {
+ fwrite ((char *) ::SRAM, size, 1, file);
+ fclose (file);
-#if defined(__linux)
+#if defined(__linux) || defined(__FreeBSD__)
- chown (filename, getuid (), getgid ());
+ chown (filename, getuid (), getgid ());
#endif
- return (TRUE);
+ if(Settings.SPC7110RTC)
diff --git a/emulators/snes9x/files/patch-ae b/emulators/snes9x/files/patch-ae
index b7b120bf16dd..d5d078ee1a01 100644
--- a/emulators/snes9x/files/patch-ae
+++ b/emulators/snes9x/files/patch-ae
@@ -1,30 +1,31 @@
---- port.h.orig Fri Oct 6 17:02:39 2000
-+++ port.h Fri Oct 13 18:37:38 2000
-@@ -56,15 +56,15 @@
-
+--- port.h.orig Fri Jul 25 23:20:20 2003
++++ port.h Sat Aug 9 01:14:02 2003
+@@ -124,16 +124,16 @@
#ifndef snes9x_types_defined
#define snes9x_types_defined
+
+-typedef unsigned char bool8;
++typedef u_int8_t bool8;
+
+ #ifndef __WIN32__
-typedef unsigned char uint8;
-typedef unsigned short uint16;
--typedef unsigned int uint32;
--typedef unsigned char bool8;
-typedef signed char int8;
-typedef short int16;
+-typedef int int32;
+-typedef unsigned int uint32;
+-typedef long long int64;
+typedef u_int8_t uint8;
+typedef u_int16_t uint16;
-+typedef u_int32_t uint32;
-+typedef u_int8_t bool8;
+typedef int8_t int8;
+typedef int16_t int16;
- #ifndef __WIN32__
--typedef int int32;
--typedef long long int64;
+typedef int32_t int32;
++typedef u_int32_t uint32;
+typedef int64_t int64;
- #else
- #ifndef WSAAPI
- // winsock2.h typedefs int32 as well.
-@@ -162,6 +162,10 @@
+ #else /* __WIN32__ */
+
+ #ifdef __BORLANDC__
+@@ -255,6 +255,10 @@
#ifdef __linux
#define TITLE "Snes9X: Linux"
diff --git a/emulators/snes9x/files/patch-af b/emulators/snes9x/files/patch-af
index 881ab83aa813..5c68e30ab73e 100644
--- a/emulators/snes9x/files/patch-af
+++ b/emulators/snes9x/files/patch-af
@@ -1,8 +1,8 @@
---- unix/unix.cpp.orig Wed Feb 28 16:12:23 2001
-+++ unix/unix.cpp Tue May 13 13:07:48 2003
-@@ -51,9 +51,11 @@
+--- unix/unix.cpp.orig Fri Jul 25 23:20:19 2003
++++ unix/unix.cpp Sat Aug 9 00:58:34 2003
+@@ -97,9 +97,11 @@
#include <ctype.h>
-
+ #include <dirent.h>
-#if defined(__linux) || defined(__sun)
+#if defined(__linux) || defined(__sun) || defined(__FreeBSD__)
@@ -13,7 +13,7 @@
#include <unistd.h>
#include <sys/types.h>
#include <sys/ioctl.h>
-@@ -68,8 +70,12 @@
+@@ -114,8 +116,12 @@
pthread_mutex_t mutex;
#endif
@@ -27,9 +27,9 @@
#include <sys/mman.h>
#endif
-@@ -85,6 +91,11 @@
- typedef void (*SIG_PF)();
- #endif
+@@ -132,6 +138,11 @@
+ //typedef void (*SIG_PF)();
+ //#endif
+#if defined(__FreeBSD__)
+typedef sig_t SIG_PF;
@@ -37,9 +37,9 @@
+#endif
+
#include "snes9x.h"
- #include "memmap.h"
+ #include "MEMMAP.H"
#include "debug.h"
-@@ -111,7 +122,10 @@
+@@ -158,7 +169,10 @@
int NumControllers = 5;
#ifdef JOYSTICK_SUPPORT
@@ -50,7 +50,7 @@
#include <linux/joystick.h>
int js_fd [4] = {-1, -1, -1, -1};
int js_map_button [4][16] = {
-@@ -158,6 +172,68 @@
+@@ -205,6 +219,68 @@
char *js_device [4] = {"/dev/js0", "/dev/js1", "/dev/js2", "/dev/js3"};
#endif
@@ -119,7 +119,7 @@
void InitJoysticks ();
void ReadJoysticks ();
#endif
-@@ -168,7 +244,7 @@
+@@ -215,7 +291,7 @@
char *rom_filename = NULL;
char *snapshot_filename = NULL;
@@ -128,7 +128,7 @@
static void sigbrkhandler(int)
{
#ifdef DEBUGGER
-@@ -195,91 +271,43 @@
+@@ -242,91 +318,43 @@
if (strcmp (argv [i], "-j") == 0 ||
strcasecmp (argv [i], "-nojoy") == 0)
Settings.JoystickEnabled = FALSE;
@@ -255,7 +255,7 @@
}
else
#endif
-@@ -418,7 +446,7 @@
+@@ -469,7 +497,7 @@
#if !defined(__MSDOS) && defined(DEBUGGER)
#if defined(__unix) && !defined(__NeXT__)
struct sigaction sa;
@@ -264,7 +264,7 @@
sa.sa_handler = sigbrkhandler;
#else
sa.sa_handler = (SIG_PF) sigbrkhandler;
-@@ -610,6 +638,7 @@
+@@ -661,6 +689,7 @@
}
#ifdef JOYSTICK_SUPPORT
@@ -272,7 +272,7 @@
void InitJoysticks ()
{
#ifdef JSIOCGVERSION
-@@ -730,6 +759,189 @@
+@@ -781,6 +810,189 @@
}
#endif
}
@@ -462,7 +462,7 @@
#endif // defined (JOYSTICK_SUPPORT)
const char *GetHomeDirectory ()
-@@ -1422,7 +1634,7 @@
+@@ -1568,7 +1780,7 @@
}
#endif
@@ -470,17 +470,26 @@
+#if defined(__linux) || defined(__FreeBSD__)
static int Rates[8] =
{
- 0, 8192, 11025, 16500, 22050, 29300, 36600, 44000
-@@ -1541,7 +1753,7 @@
- }
+ 0, 8000, 11025, 16000, 22050, 32000, 44100, 48000
+@@ -1688,7 +1900,7 @@
#endif
--#if defined (__linux) || defined (__sun)
-+#if defined (__linux) || defined (__sun) || defined(__FreeBSD__)
+
+-#if defined (__linux) || defined (__sun) || defined(NOSOUND)
++#if defined(__linux) || defined(__sun) || defined(__FreeBSD__) || defined(NOSOUND)
void S9xUnixProcessSound (void)
{
}
-@@ -1640,7 +1852,7 @@
+@@ -1729,7 +1941,7 @@
+ }
+ #endif
+
+-#if defined (__linux) || defined (__sun)
++#if defined(__linux) || defined(__sun) || defined(__FreeBSD__)
+ void S9xGenerateSound ()
+ {
+ int bytes_so_far = so.sixteen_bit ? (so.samples_mixed_so_far << 1) :
+@@ -1814,7 +2026,7 @@
void *S9xProcessSound (void *)
{
diff --git a/emulators/snes9x/files/patch-aj b/emulators/snes9x/files/patch-aj
index 1230887f0cb2..09cbf1e05c4b 100644
--- a/emulators/snes9x/files/patch-aj
+++ b/emulators/snes9x/files/patch-aj
@@ -1,6 +1,6 @@
---- netplay.cpp.orig Fri Oct 13 18:44:41 2000
-+++ netplay.cpp Fri Oct 13 18:56:53 2000
-@@ -682,22 +682,24 @@
+--- NETPLAY.CPP.orig Fri Jul 25 23:20:20 2003
++++ NETPLAY.CPP Sat Aug 9 01:16:22 2003
+@@ -719,22 +719,24 @@
return;
}
char fname [L_tmpnam];
diff --git a/emulators/snes9x/files/patch-ak b/emulators/snes9x/files/patch-ak
index f91abc7d2a31..9eb539267827 100644
--- a/emulators/snes9x/files/patch-ak
+++ b/emulators/snes9x/files/patch-ak
@@ -1,6 +1,6 @@
---- server.cpp.orig Fri Oct 13 18:57:43 2000
-+++ server.cpp Fri Oct 13 19:02:56 2000
-@@ -940,11 +940,18 @@
+--- SERVER.CPP.orig Fri Jul 25 23:20:20 2003
++++ SERVER.CPP Sat Aug 9 01:17:35 2003
+@@ -976,11 +976,18 @@
void S9xNPSyncClient (int client)
{
char fname [L_tmpnam];
ICTS_INSTALL linepawel2013-09-041-0/+2 | * Horde package update:mm2013-09-0416-28/+26 | | | | | | | | | | | Horde_ActiveSync 2.7.0 -> 2.7.2 Horde_Auth 2.0.6 -> 2.1.0 Horde_Core 2.7.0 -> 2.8.0 Horde_Queue 1.1.0 -> 1.1.1 Horde_Smtp 1.2.0 -> 1.2.1 Horde_Support 2.1.0 -> 2.1.1 horde-base 5.1.3 -> 5.1.4 horde-webmail 5.1.1 -> 5.1.2 * Remove Horde_Smtp dependency from horde-impmm2013-09-041-2/+1 | * Use MAKE_ARGS to simplify patches.jkim2013-09-042-11/+1 | | | | Suggested by: danfe * Add an explicit dependency on pkgconfantoine2013-09-041-0/+1 | | | | Approved by: portmgr (bapt) * Add an explicit dependency on pkgconfantoine2013-09-041-1/+1 | | | | Approved by: portmgr (bapt) * Add an explicit dependency on pkgconfantoine2013-09-041-6/+2 | | | | Approved by: portmgr (bapt) * Fix USES conversionantoine2013-09-041-2/+1 | | | | Approved by: portmgr (bapt) * Add an explicit dependency on pkgconfantoine2013-09-041-1/+1 | | | | Approved by: portmgr (bapt) * Fix PORT_OPTIONS conversionantoine2013-09-041-1/+1 | * Add an explicit dependency on pkgconfantoine2013-09-041-6/+2 | | | | Approved by: portmgr (bapt) * Add an explicit dependency on pkgconfantoine2013-09-041-7/+2 | | | | Approved by: portmgr (bapt) * Add an explicit dependency on pkgconfantoine2013-09-041-2/+1 | | | | | | (needed for proper detection of PANGOCAIRO and maybe other things) Approved by: portmgr (bapt) * Add an explicit dependency on pkgconfbapt2013-09-041-2/+1 | * Add an explicit dependency on pkgconfantoine2013-09-041-1/+1 | | | | Approved by: portmgr (bapt) * Add an explicit dependency on pkgconfantoine2013-09-041-1/+1 | | | | Approved by: portmgr (bapt) * Add an explicit dependency on pkgconfantoine2013-09-041-1/+1 | | | | Approved by: portmgr (bapt) * Magick-config and friends run depend on pkgconfantoine2013-09-041-1/+1 | | | | Approved by: portmgr (bapt) * Add an explicit dependency on pkgconfantoine2013-09-041-1/+1 | | | | Approved by: portmgr (bapt) * Add an explicit dependency on pkgconfantoine2013-09-041-1/+1 | | | | Approved by: portmgr (bapt) * Re-use gmakeantoine2013-09-041-1/+1 | | | | Approved by: portmgr (bapt) * Add an explicit dependency on pkgconfantoine2013-09-041-1/+1 | | | | Approved by: portmgr (bapt) * Add an explicit dependency on pkgconfbapt2013-09-041-2/+1 | * Update to 1.2skreuzer2013-09-043-11/+34 | | | | | PR: ports/178240 Submitted by: Stas Timokhin <devel@stasyan.com> * Add an explicit dependency on pkgconfbapt2013-09-041-2/+1 | * Update to 3.2.1skreuzer2013-09-043-6/+5 | | | | | PR: ports/178239 Submitted by: Stas Timokhin <devel@stasyan.com> * Add an explicit dependency on pkgconfbapt2013-09-041-2/+1 | * Add an explicit dependency on pkgconfbapt2013-09-041-2/+1 | * Update to 2.4.2, a brand new version rewritten in Python. Also, assumemarcus2013-09-044-318/+54 | | | | | | | maintainership. Note: the convenience scripts for txt, html and nroff are gone, but the functionality still exists with --text, --html and --nroff. * Allow to build with clang and libc++bapt2013-09-042-1/+13 | * devel/py-robotframework-selenium2library: update to 1.3.0wg2013-09-042-3/+3 | | | | | | | - Update to 1.3.0 PR: ports/181775 Submitted by: Vladimir Chukharev <Vladimir.Chukharev gmail.com> (maintainer) * Fix build with clangbapt2013-09-041-6/+3 | * - convert to the new perl5 frameworkaz2013-09-0419-19/+35 | | | | Approved by: portmgr (bapt@, blanket) * Use correct value of DISTFILES if TEST is off.rene2013-09-041-1/+1 | * - Update to 29.0.1547.65, which fixes a bug in Google Sync.rene2013-09-0427-62/+491 | | | | | | | | | | - Add an option to run regression test, default off. [1] If this option is selected, an extra distribution file containing test data is downloaded from an upstream mastersite. - Rename the CLANG option to GCC and flip the default to off, as clang is the default compiler for this port for quite some time now. [2] Submitted by: George Liaskos [1,2] * mail/{gmime2,gmime24}: convert docs to options ngwg2013-09-042-6/+12 | | | | | | | | | - NOPORTDOCS -> PORT_OPTIONS:MDOCS [1] - Convert to USES gmake - Define DOCS option PR: ports/181778 [1] Submitted by: Alan Hicks <ahicks p-o.co.uk> (maintainer) * Add an explicit dependency on pkgconfbapt2013-09-031-7/+2 | * mail/gmime26: update to 2.6.17wg2013-09-032-5/+4 | | | | | | | | - Update to 2.6.17 [1] - Convert to USES gmake PR: ports/181777 Submitted by: Alan Hicks <ahicks p-o.co.uk> (maintainer) * - convert to the new perl5 frameworkaz2013-09-0319-19/+38 | | | | Approved by: portmgr (bapt@, blanket) * Add an explicit dependency on pkgconfbapt2013-09-032-13/+4 | * Add en explicit dependency on pkgconfbapt2013-09-036-12/+6 | * Fix typobapt2013-09-031-1/+1 | * - Add p5-Pithub 0.01020sunpoet2013-09-035-0/+129 | | | | | | | | | Pithub provides a set of modules to access the Github v3 API in an object oriented way. There is also Net::GitHub which does the same for all the versions (v1, v2, v3) of the Github API. Pithub supports all API calls so far, but only for v3. http://search.cpan.org/dist/Pithub/ WWW: http://search.cpan.org/dist/Pithub/ * - convert to the new perl5 frameworkaz2013-09-0319-19/+37 | | | | Approved by: portmgr (bapt@, blanket) * - Update to 1.8.004.20130831sunpoet2013-09-032-5/+5 | | | | | | Changes: http://svn.stylite.de/viewvc/egroupware/branches/1.8/egroupware/doc/rpm-build/debian.changes?view=markup PR: ports/181769 Submitted by: Danilo Egea Gondolfo <danilogondolfo@gmail.com> (maintainer) * Fix building without libstdc++bapt2013-09-031-0/+1 | * Further cleanupfeld2013-09-032-25/+24 | | | | Approved by: crees (mentor) * Add an explicit dependency on pkgconfbapt2013-09-031-7/+2 | * Add an explicit dependency on pkgconfbapt2013-09-0323-76/+32 | * - convert to the new perl5 frameworkaz2013-09-0319-19/+38 | | | | Approved by: portmgr (bapt@, blanket) * Update MAINTAINER to rodrigo@bebik.netskreuzer2013-09-031-1/+1 | * - convert to the new perl5 frameworkaz2013-09-0319-19/+35 | | | | Approved by: portmgr (bapt@, blanket) * Add an explicit dependency on pkgconfbapt2013-09-033-15/+5 | * Add an explicit dependency on pkgconfbapt2013-09-031-7/+2 | * Add an explicit dependency on pkgconfbapt2013-09-031-6/+2 | * Fix typobapt2013-09-031-1/+1 | * - Followup to r325807, with USE_PACKAGE_DEPENDS_ONLY, still allowbdrewery2013-09-031-1/+1 | | | | | | | | | | | | ports framework to use the port for *_DEPENDS= ${NONEXISTENT}:PORT:target dependencies An example port is irc/gseen.mod, it depends on another port being extracted, not an installed pkg. PR: ports/180725 Reported by: antoine With hat: portmgr * Add an explicit dependency on pkgconfbapt2013-09-035-23/+8 | * Add an explicit dependency on pkgconfbapt2013-09-031-1/+1 | * Fix stupid mistakebapt2013-09-031-2/+1 | * - convert to the new perl5 frameworkaz2013-09-0319-19/+37 | | | | Approved by: portmgr (bapt@, blanket) * devel/py-celery: update to 3.0.23wg2013-09-032-4/+4 | | | | | | - Update to 3.0.23 Changes: https://github.com/celery/celery/blob/v3.0.23/Changelog * Add an explicit dependency on pkgconfbapt2013-09-0377-294/+117 | * - login(3), logout(3), and logwtmp(3) were removed in base r202216bdrewery2013-09-031-3/+0 | | | | | | | | due to utmpx This fixes build for at least security/openssh-portable With hat: portmgr * Add an explicit dependency on pkgconfbapt2013-09-031-1/+1 | * Add an explicit dependency on pkgconfbapt2013-09-031-1/+1 | * Add an explicit dependency on pkgconfbapt2013-09-0329-75/+38 | * Add an explicit dependency on pkgconfbapt2013-09-0320-67/+27 | * - Unbreak parallel (-jX) builds by calling sub-makes correctly (via -C)danfe2013-09-031-4/+8 | | | | | | - Drop leading indefinite article from the COMMENT line - Use new, more robust syntax for LIB_DEPENDS (available since r322328) - Sort the knobs, remove no longer required (and deprecated) USE_GMAKE * Get rid of /proc dependency.kevlo2013-09-032-0/+31 | | | | | PR: ports/181659 Submitted by: Jan Beich <jbeich at tormail dot org> * Add an explicit dependency on pkgconfbapt2013-09-0353-168/+78 | * Update to 1.04.tobez2013-09-032-3/+3 | | | | Changes: http://search.cpan.org/dist/Parallel-ForkManager/Changes * Update to 0.29.tobez2013-09-032-3/+3 | | | | Changes: http://search.cpan.org/dist/WWW-Scraper-ISBN/Changes * Update to 0.41.tobez2013-09-032-3/+3 | | | | Changes: http://search.cpan.org/dist/MooseX-Storage/Changes * Update to 0.99(.)04.tobez2013-09-032-3/+3 | | | | Changes: http://search.cpan.org/dist/version/Changes * Add an explicit dependency on pkgconfbapt2013-09-031-2/+1 | * Fix typobapt2013-09-031-1/+1 | * Add an explicit dependency on pkgconfbapt2013-09-03148-403/+211 | * - fix segfault on 64bit with option XFTdinoex2013-09-032-1/+18 | * - update to 4.2.2dinoex2013-09-034-4/+24 | * - revert r325819dinoex2013-09-031-0/+2 | * - update to 1.1.2jgh2013-09-034-19/+17 | | | | | | | | | | - move to new lib_depends format - shift perl build inclusion to USES framework - fix formatting of pkg-descr Note: this should fix building on CURRENT Changes: http://www.libvirt.org/news.html * - Fix regression from r325805 and allow 'make fetch' to workbdrewery2013-09-031-1/+1 | | | | | | | without distinfo Reported by: sunpoet With hat: portmgr * Corrected log for previous commit:eadler2013-09-032-22/+0 | | | | | | | - Update to 2.4.2 - Remove now unneeded patches Tested by: redports * cause you need to commit from the porteadler2013-09-032-3/+4 | * Update to 0.50eadler2013-09-032-3/+3 | | | | | | | Changes: No functional changes. Tested by: redports * Add an explicit dependency on pkgconfbapt2013-09-037-9/+8 | * Fix stupid mistakebapt2013-09-031-2/+1 | * Add an explicit dependency on pkgconfbapt2013-09-0312-32/+17 | * - Update to 4.0.2zi2013-09-032-3/+3 | * Add an explicit dependency on pkgconfbapt2013-09-039-19/+12 | * Fix build after removal or artsbapt2013-09-031-3/+1 | | | | Submitted by: Herbert J. Skuhra <h.skuhra@gmail.com> * Add an explicit dependency on pkgconfbapt2013-09-0317-55/+27 | * - Update to 2.4.6zi2013-09-033-3/+26 | * Add an explicit dependency on pkgconfbapt2013-09-038-16/+10 | * - Update to 1.9.4zi2013-09-034-6/+9 | * Add an explicit dependency on pkgconfbapt2013-09-0312-30/+16 | * - Remove USE_GCC=any and fix building with clang by disabling -Werror.tijl2013-09-031-4/+3 | | | | | | | - Convert USE_GMAKE to USES=gmake. PR: 181761 Approved by: Naram Qashat <cyberbotx@cyberbotx.com> (maintainer) * Do not overwrite USESbapt2013-09-031-1/+1 | * Add an explicit dependency on pkgconfbapt2013-09-031-2/+1 | * Fix stupid mistakebapt2013-09-031-2/+2 | * Fix a typo that prevented the port from buildingflo2013-09-031-1/+1 | * Update to 5.6.13-rc60.5flo2013-09-033-13/+14 | * Add an explicit dependency on pkgconfantoine2013-09-031-1/+1 | | | | Approved by: portmgr (bapt) * Add an explicit dependency on pkgconfbapt2013-09-0310-19/+12 | * Add an explicit dependency on pkgconfantoine2013-09-031-1/+1 | | | | Approved by: portmgr (bapt) * Add an explicit dependency on pkgconfantoine2013-09-031-1/+1 | | | | Approved by: portmgr (bapt) * Add an explicit dependency on pkgconfbapt2013-09-0328-91/+40 | * Update to the 20130901 snapshot of GCC 4.9.0.gerald2013-09-032-3/+3 | * Add an explicit dependency on pkgconfbapt2013-09-0330-82/+41 | * Add an explicit dependency on pkgconfbapt2013-09-0330-56/+35 | * Add an explicit dependency on pkgconfbapt2013-09-0318-42/+21 | * Add an explicit dependency on pkgconfantoine2013-09-031-1/+1 | | | | Approved by: portmgr (bapt) * Fix build without libstdc++bapt2013-09-031-2/+2 | * Add an explicit dependency on pkgconfbapt2013-09-031-1/+1 | * Add an explicit dependency on pkgconfantoine2013-09-031-1/+1 | | | | Approved by: portmgr (bapt) * Fix a hidden USE_GNOME=pkgconfigbapt2013-09-031-9/+3 | * Fix build without libstdc++bapt2013-09-031-0/+3 | * - Pet portlint: remove DISTVERSIONsunpoet2013-09-031-1/+1 | * Add an explicit dependency on pkgconfantoine2013-09-031-0/+1 | | | | Approved by: portmgr (bapt) * Add an explicit dependency on pkgconfbapt2013-09-031-1/+1 | * Update to 1.03(0).tobez2013-09-032-3/+3 | | | | Changes: http://search.cpan.org/dist/enum/Changes * Add an explicit dependency on pkgconfantoine2013-09-031-1/+1 | | | | Approved by: portmgr (bapt) * Update to 0.10(.)01.tobez2013-09-033-4/+6 | | | | Changes: http://search.cpan.org/dist/XML-MyXML/Changes * Add an explicit dependency on pkgconfantoine2013-09-031-1/+1 | | | | Approved by: portmgr (bapt) * Add an explicit dependency on pkgconfantoine2013-09-031-0/+1 | | | | Approved by: portmgr (bapt) * - CVE-2013-4277 fixohauer2013-09-032-1/+15 | | | | | | Approved by: lev@ (explicit) Security: f8a913cc-1322-11e3-8ffa-20cf30e32f6d CVE-2013-4277 * Add an explicit dependency on pkgconfbapt2013-09-032-8/+5 | * Add an explicit dependency on pkgconfbapt2013-09-037-26/+16 | * Add an explicit dependency on pkgconfbapt2013-09-0332-89/+49 | * - Convert to the new perl5 frameworkaz2013-09-031-6/+3 | | | | - Trim Makefile header * - Convert to the new perl5 frameworkaz2013-09-037-42/+21 | | | | - Trim Makefile header * - Update to 0.17sahil2013-09-032-4/+4 | | | | - Pass maintainership to perl@ * - Update to 0.64sahil2013-09-032-4/+4 | | | | - Pass maintainership to perl@ * - Update to 2.03sahil2013-09-032-4/+4 | | | | - Pass maintainership to perl@ * - Update to 0.22sahil2013-09-032-4/+4 | | | | - Pass maintainership to perl@ * - Update to 0.26sahil2013-09-032-4/+4 | | | | - Pass maintainership to perl@ * - Update to 0.64sahil2013-09-032-4/+4 | | | | - Pass maintainership to perl@ * - Update to 1.35sahil2013-09-032-4/+3 | * - Update to 1.4.4sahil2013-09-032-3/+4 | * - Update to 0.78sahil2013-09-032-4/+4 | | | | - Pass maintainership to perl@ * - Update to 1.219sahil2013-09-032-4/+4 | | | | - Pass maintainership to perl@ * - update devel/subversion to 1.8.3 [1]ohauer2013-09-039-64/+100 | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | - update devel/subversion17 to 1.7.13 [1] - add vuxml entry Version 1.7.13 (29 Aug 2013, from /branches/1.7.x) http://svn.apache.org/repos/asf/subversion/tags/1.7.13/CHANGES User-visible changes: - General * merge: fix bogus mergeinfo with conflicting file merges (issue #4306) * diff: fix duplicated path component in '--summarize' output (issue #4408) * ra_serf: ignore case when checking certificate common names (r1514763) - Server-side bugfixes: * svnserve: fix creation of pid files (r1516556) * mod_dav_svn: better status codes for commit failures (r1490684) * mod_dav_svn: do not map requests to filesystem (r1512432 et al) Developer-visible changes: - General: * support linking against gssapi on Solaris 10 (r1515068) * don't use uninitialized variable to produce an error code (r1482282) - Bindings: * swig-pl: fix SVN::Client not honoring config file settings (r150744) * swig-pl & swig-py: disable unusable svn_fs_set_warning_func (r1515119) Version 1.8.3 (29 August 2013, from /branches/1.8.x) http://svn.apache.org/repos/asf/subversion/tags/1.8.3/CHANGES User-visible changes: - Client- and server-side bugfixes: * translation updates for Swedish * enforce strict version equality between tools and libraries (r1502267) * consistently output revisions as "r%ld" in error messags (r1499044 et al) - Client-side bugfixes: * status: always use absolute paths in XML output (issue #4398) * ra_serf: 'svn log -v' fails with a 1.2.x server (issue #4044) * ra_serf: fix crash when committing cp with deep deletion (issue #4400) * diff: issue an error for files that can't fit in memory (r1513119 et al) * svnmucc: generate proper error for mismatched URLs (r1511353) * update: fix a crash when a temp file doesn't exist (r1513156) * commit & update: improve sleep for timestamps performance (r1508438) * diff: continue on missing or obstructing files (issue #4396) * ra_serf: use runtime serf version for User-Agent (r1514315, r1514628) * ra_serf: ignore case when checking certificate common names (r1514763) * ra_serf: format distinguished names properly (r1514804) * ra_serf: do not retry HTTP requests if we started to parse them (r1503318) * ra_serf: output ssl cert verification failure reason (r1514785 et al) * ra_serf: allow session reuse after SVN_ERR_CEASE_INVOCATION (r1502901) * ra_serf: include library version in '--version' output (r1514295 et al) * info: fix spurious error on wc root with child in conflict (r1515366) - Server-side bugfixes: * svnserve: fix creation of pid files (r1516556) * svnadmin: fix output encoding in non-UTF8 environments (r1506966) * svnsync: fix high memory usage when running over ra_serf (r1515249 et al) * mod_dav_svn: do not map requests to filesystem (r1512432 et al) * svnauthz: improve help strings (r1511272) * fsfs: fixed manifest file growth with revprop changes (r1513874) * fsfs: fix packed revprops causing loss of revprops (r1513879 et al) - Other tool improvements and bugfixes: * svnwcsub/irkerbridge: fix symlink attack via pid file (r175 from upstream) Developer-visible changes: - General: * describe APR unimplemented errors as coming from APR (r1503010 et al) * mod_dav_svn: update INSTALL to reflect configure defaults (r1515141) * davautocheck: use the correct apxs binary by default (r1507889, r1507891) - API changes: * svn_config_walk_auth_data() config_dir arg: permit NULL (r1507382 et al) - Bindings: * swig-pl: fix SVN::Client not honoring config file settings (r150744) * swig-pl & swig-py: disable unusable svn_fs_set_warning_func (r1515119) Approved by: lev@ (explicit per PM) Security: f8a913cc-1322-11e3-8ffa-20cf30e32f6d CVE-2013-4277 [1] * - Fix issue when spamd crashes because of memory problems in Logger.pmaz2013-09-032-1/+108 | | | | | | | | | | | | For more details see Bug 6745 - Do not bump portrevision since issue not global While I'm here: - convert to the new perl5 framework PR: ports/181242 Submitted by: Igor Roshchin <spamd-pr@str.komkon.org> Tested by: Igor Roshchin <spamd-pr@str.komkon.org> (two weeks) Approved by: maintainer (timeout) * - Fix plist problems with PostgreSQL version > 9.0 bypawel2013-09-032-5/+12 | | | | | | | | | setting target moduledir in make enviroment - With default PostgreSQL version hashtypes.control file is not installed while newer versions do install it, fix this by adding post-install check Approved by: maintainer via private mail * - convert to the new perl5 frameworkaz2013-09-0319-19/+37 | | | | Approved by: portmgr (bapt@, blanket) * - convert to the new perl5 frameworkaz2013-09-0319-19/+38 | | | | Approved by: portmgr (bapt@, blanket) * Add an explicit dependency on pkgconfantoine2013-09-031-0/+1 | | | | Approved by: portmgr (bapt) * Add an explicit dependency on pkgconfbapt2013-09-03