aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2015-03-18 05:59:32 +0800
committernox <nox@FreeBSD.org>2015-03-18 05:59:32 +0800
commit639fd0f969a2512d8c9483af32073fc3b987f7b5 (patch)
tree557c88c9c129a5d27227ee97e50eb81ce28c19ff /emulators
parentcfe756403eb528e6c9957d851f5146b7d0184d8b (diff)
downloadfreebsd-ports-gnome-639fd0f969a2512d8c9483af32073fc3b987f7b5.tar.gz
freebsd-ports-gnome-639fd0f969a2512d8c9483af32073fc3b987f7b5.tar.zst
freebsd-ports-gnome-639fd0f969a2512d8c9483af32073fc3b987f7b5.zip
- Fix procctl check.
- Bump PORTREVISION. PR: 198667 Submitted by: garga
Diffstat (limited to 'emulators')
-rw-r--r--emulators/qemu-sbruno/Makefile1
-rw-r--r--emulators/qemu-sbruno/files/patch-bsd-user-freebsd-os-proc.c13
2 files changed, 9 insertions, 5 deletions
diff --git a/emulators/qemu-sbruno/Makefile b/emulators/qemu-sbruno/Makefile
index 92d17586f32e..d450f40f0607 100644
--- a/emulators/qemu-sbruno/Makefile
+++ b/emulators/qemu-sbruno/Makefile
@@ -3,6 +3,7 @@
PORTNAME= qemu
PORTVERSION= 2.2.50.g20150310
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= GH GHC \
LOCAL/nox \
diff --git a/emulators/qemu-sbruno/files/patch-bsd-user-freebsd-os-proc.c b/emulators/qemu-sbruno/files/patch-bsd-user-freebsd-os-proc.c
index e9a250ca0e20..3da008cb4ec6 100644
--- a/emulators/qemu-sbruno/files/patch-bsd-user-freebsd-os-proc.c
+++ b/emulators/qemu-sbruno/files/patch-bsd-user-freebsd-os-proc.c
@@ -1,11 +1,14 @@
--- a/bsd-user/freebsd/os-proc.c
+++ b/bsd-user/freebsd/os-proc.c
-@@ -364,7 +364,7 @@ execve_end:
- #error __FreeBSD_version not defined!
+@@ -365,8 +365,10 @@ execve_end:
#endif
--#if defined(__FreeBSD_version) && __FreeBSD_version >= 1001510
-+#if defined(__FreeBSD_version) && __FreeBSD_version >= 1001510 && defined(PROC_REAP_ACQUIRE)
-
+ #if defined(__FreeBSD_version) && __FreeBSD_version >= 1001510
+-
#include <sys/procctl.h>
++#endif
++
++#if defined(__FreeBSD_version) && __FreeBSD_version >= 1001510 && defined(PROC_REAP_ACQUIRE)
+ static abi_long
+ t2h_procctl_cmd(int target_cmd, int *host_cmd)