aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-10-12 06:37:23 +0800
committeredwin <edwin@FreeBSD.org>2004-10-12 06:37:23 +0800
commit69d6faaaafdb40c57183d338d0d08ef4cf6628cb (patch)
tree06e3d60069ada05889e08a0f2e860d7678408120 /emulators
parent5e62710047eb84708bf4d2ce04335492944f289d (diff)
downloadfreebsd-ports-gnome-69d6faaaafdb40c57183d338d0d08ef4cf6628cb.tar.gz
freebsd-ports-gnome-69d6faaaafdb40c57183d338d0d08ef4cf6628cb.tar.zst
freebsd-ports-gnome-69d6faaaafdb40c57183d338d0d08ef4cf6628cb.zip
[Maintainer update] emulators/xmame to 0.86
I was holding this in hope they would get networking fixed. No dice. *NETWORKING DOESN'T WORK IN THIS VERSION* and is disabled in the Makefile. Some people have reported success on !i386, so I've removed the ARCH restriction for now. We'll see how it turns out. This version makes gxmame stop working, see the other PR about gxmame for a fix. PR: ports/71252 Submitted by: Miguel Mendez <flynn@energyhq.es.eu.org>
Diffstat (limited to 'emulators')
-rw-r--r--emulators/xmame/Makefile42
-rw-r--r--emulators/xmame/distinfo4
-rw-r--r--emulators/xmame/files/patch-src-sha1.h14
-rw-r--r--emulators/xmame/files/patch-src-unix-joystick-drivers-joy_usb.c11
-rw-r--r--emulators/xmame/pkg-plist1
5 files changed, 35 insertions, 37 deletions
diff --git a/emulators/xmame/Makefile b/emulators/xmame/Makefile
index 19cf703b52a3..6d389a6dd93d 100644
--- a/emulators/xmame/Makefile
+++ b/emulators/xmame/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME?= xmame
-PORTVERSION?= 0.83.1
+PORTVERSION?= 0.86
CATEGORIES= emulators
MASTER_SITES= http://x.mame.net/download/:xmame \
http://www.sys2064.com/files/util/:history \
@@ -126,12 +126,13 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
post-extract:
cd ${WRKDIR} && \
- unzip -q ${DISTDIR}/${DIST_SUBDIR}/uhsdat${HIVER}.zip \
+ ${UNZIP_CMD} -q ${DISTDIR}/${DIST_SUBDIR}/uhsdat${HIVER}.zip \
hiscore.dat
cd ${WRKDIR} && \
- unzip -q ${DISTDIR}/${DIST_SUBDIR}/history.dat.zip history.dat
+ ${UNZIP_CMD} -q ${DISTDIR}/${DIST_SUBDIR}/history.dat.zip \
+ history.dat
cd ${WRKDIR} && \
- unzip -q ${DISTDIR}/${DIST_SUBDIR}/cheat.zip cheat.dat
+ ${UNZIP_CMD} -q ${DISTDIR}/${DIST_SUBDIR}/cheat.zip cheat.dat
.else
PLIST_SUB+= DATFILES="@comment "
.endif
@@ -214,29 +215,22 @@ USE_GNOME= esound
ESOUNDCOMMENT=\#
.endif
+# XXX Network support is *broken* in 0.85+, leave commented out for now
# Option WITH_NETWORK
-.if ${MAMEMESS} == "mame"
-.if !defined(WITH_NETWORK)
-WITH_NETWORK= yes
-.endif
+#.if ${MAMEMESS} == "mame"
+#.if !defined(WITH_NETWORK)
+WITH_NETWORK= no
+#.endif
.if ${WITH_NETWORK:L} != "no"
NETWORK=
.else
NETWORK=\#
.endif
-.endif
+#.endif
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
-.if ${ARCH} != "i386" && ${OSVERSION} >= 502102
-BROKEN= "Does not compile on 5.x !i386"
-.endif
-
#
# Regular targets
#
@@ -282,12 +276,15 @@ do-configure:
-e "s@^SDL_CONFIG.*@SDL_CONFIG = ${SDL_CONFIG}@g" \
-e "s@^GLLIBS += .*@GLLIBS += ${PTHREAD_LIBS}@g" \
${WRKSRC}/makefile.unix
+.if ${DISPLAY_TARGET:L} == "sdl"
+ ${REINPLACE_CMD} -e "s@# JOY_SDL = 1@JOY_SDL = 1@g" ${WRKSRC}/makefile.unix
+.endif
# png.h conflicts with libpng.
-.for file in mess/artworkx.c mess/artworkx.h src/artwork.c \
+.for f in mess/artworkx.c mess/artworkx.h src/artwork.c \
src/common.c src/png.c src/unix/video-drivers/glexport.c
- ${REINPLACE_CMD} -e "s@\"png.h\"@\"mame_png.h\"@g" ${WRKSRC}/${file}
+ ${REINPLACE_CMD} -e "s@\"png.h\"@\"mame_png.h\"@g" ${WRKSRC}/${f}
.endfor
${LN} -s ${WRKSRC}/src/png.h ${WRKSRC}/src/mame_png.h
@@ -304,6 +301,9 @@ post-build:
${WRKSRC}/doc/x${MAMEMESS}rc.dist.sed > ${WRKSRC}/doc/x${MAMEMESS}rc.dist
post-install:
+.if ${MAMEMESS} == "mame"
+ ${INSTALL_PROGRAM} ${WRKSRC}/xml2info ${PREFIX}/bin
+.endif
${MV} ${PREFIX}/bin/x${MAMEMESS}.${DISPLAY_METHOD} \
${PREFIX}/bin/x${MAMEMESS}
${CHOWN} root:games ${PREFIX}/bin/x${MAMEMESS}
@@ -319,8 +319,8 @@ post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/x${MAMEMESS}
${MKDIR} ${PREFIX}/share/doc/x${MAMEMESS}/img
-.for file in ${ALLDOCS}
- ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${PREFIX}/share/doc/x${MAMEMESS}
+.for f in ${ALLDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${f} ${PREFIX}/share/doc/x${MAMEMESS}
.endfor
.endif
.if ${MAMEMESS} == "mess"
diff --git a/emulators/xmame/distinfo b/emulators/xmame/distinfo
index 1003ef65cad1..910c2dcdba55 100644
--- a/emulators/xmame/distinfo
+++ b/emulators/xmame/distinfo
@@ -1,5 +1,5 @@
-MD5 (xmame/xmame-0.83.1.tar.bz2) = d524570f1a2aa516798c873be9c25ebd
-SIZE (xmame/xmame-0.83.1.tar.bz2) = 12914490
+MD5 (xmame/xmame-0.86.tar.bz2) = b16782cd620ef970233eacd65462ad74
+SIZE (xmame/xmame-0.86.tar.bz2) = 14538952
MD5 (xmame/uhsdat795.zip) = c30956e15cd8218f558f41013a47f22e
SIZE (xmame/uhsdat795.zip) = 43750
MD5 (xmame/history.dat.zip) = 8c758537d5f5bc90fc3224b19421ae12
diff --git a/emulators/xmame/files/patch-src-sha1.h b/emulators/xmame/files/patch-src-sha1.h
deleted file mode 100644
index 58c8167fd686..000000000000
--- a/emulators/xmame/files/patch-src-sha1.h
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/sha1.h.orig Fri Jan 30 21:43:41 2004
-+++ src/sha1.h Fri Jan 30 21:45:58 2004
-@@ -26,10 +26,7 @@
- #ifndef NETTLE_SHA1_H_INCLUDED
- #define NETTLE_SHA1_H_INCLUDED
-
--#ifndef _STDINT_H
--typedef unsigned int uint32_t;
--typedef unsigned char uint8_t;
--#endif
-+#include <sys/types.h>
-
- #define SHA1_DIGEST_SIZE 20
- #define SHA1_DATA_SIZE 64
diff --git a/emulators/xmame/files/patch-src-unix-joystick-drivers-joy_usb.c b/emulators/xmame/files/patch-src-unix-joystick-drivers-joy_usb.c
new file mode 100644
index 000000000000..90ae5e29424f
--- /dev/null
+++ b/emulators/xmame/files/patch-src-unix-joystick-drivers-joy_usb.c
@@ -0,0 +1,11 @@
+--- src/unix/joystick-drivers/joy_usb.c.orig Sun Aug 22 15:31:47 2004
++++ src/unix/joystick-drivers/joy_usb.c Sun Aug 22 15:32:30 2004
+@@ -20,7 +20,7 @@
+ };
+
+ #ifdef USB_JOYSTICK
+-
++#define __ARCH_freebsd
+ #if !defined(__ARCH_netbsd) && !defined(__ARCH_freebsd)
+ #error "USB joysticks are only supported under NetBSD and FreeBSD. Patches to support other archs are welcome ;)"
+ #endif
diff --git a/emulators/xmame/pkg-plist b/emulators/xmame/pkg-plist
index 9fb9c56ff50c..b35c8d56a87f 100644
--- a/emulators/xmame/pkg-plist
+++ b/emulators/xmame/pkg-plist
@@ -1,4 +1,5 @@
bin/%%MAMEMESS%%
+%%MAMEONLY%%bin/xml2info
etc/%%MAMEMESS%%rc.sample
share/%%MAMEMESS%%/%%MAMEMESS%%rc
%%PORTDOCS%%share/doc/%%MAMEMESS%%/changes.unix