aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2016-11-14 15:47:48 +0800
committerlinimon <linimon@FreeBSD.org>2016-11-14 15:47:48 +0800
commit838928d485d368f4515500d257a95110325c0de8 (patch)
tree7ec4df2815d7f09e29b4d6b281de31a97163b786 /emulators
parent853a8b0cdb31b5ed58d0338a5834b90d61b0a48d (diff)
downloadfreebsd-ports-gnome-838928d485d368f4515500d257a95110325c0de8.tar.gz
freebsd-ports-gnome-838928d485d368f4515500d257a95110325c0de8.tar.zst
freebsd-ports-gnome-838928d485d368f4515500d257a95110325c0de8.zip
Mark as broken on various tier-2 archs.
While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'emulators')
-rw-r--r--emulators/dtcyber/Makefile3
-rw-r--r--emulators/open-vm-tools-nox11/Makefile1
-rw-r--r--emulators/open-vm-tools/Makefile9
-rw-r--r--emulators/ppsspp/Makefile2
4 files changed, 11 insertions, 4 deletions
diff --git a/emulators/dtcyber/Makefile b/emulators/dtcyber/Makefile
index 9b79dc6da783..33a90cb98f79 100644
--- a/emulators/dtcyber/Makefile
+++ b/emulators/dtcyber/Makefile
@@ -23,6 +23,9 @@ LDFLAGS+= -L${LOCALBASE}/lib
SUB_FILES= pkg-message
PLIST_FILES= bin/dtcyber %%EXAMPLESDIR%%/cyber.ini %%EXAMPLESDIR%%/cos.tap
+BROKEN_aarch64= Fails to compile: error: Unable to determine size of basic data types
+BROKEN_mips64= Fails to compile: error: Unable to determine size of basic data types
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/dtcyber ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
diff --git a/emulators/open-vm-tools-nox11/Makefile b/emulators/open-vm-tools-nox11/Makefile
index 130e37b268b4..bfc42c9f4720 100644
--- a/emulators/open-vm-tools-nox11/Makefile
+++ b/emulators/open-vm-tools-nox11/Makefile
@@ -5,6 +5,7 @@ MASTERDIR= ${.CURDIR}/../open-vm-tools
PKGNAMESUFFIX= -nox11
OPTIONS_EXCLUDE= X11 LIBNOTIFY
+BROKEN_mips64= Does not configure: error: Unknown architecture
BROKEN_powerpc64= Does not build
.include "${MASTERDIR}/Makefile"
diff --git a/emulators/open-vm-tools/Makefile b/emulators/open-vm-tools/Makefile
index 6a4e27b2a89b..8869cabb757d 100644
--- a/emulators/open-vm-tools/Makefile
+++ b/emulators/open-vm-tools/Makefile
@@ -64,11 +64,12 @@ CONFLICTS= open-vm-tools-nox11-[0-9]*
CONFLICTS= open-vm-tools-[0-9]*
.endif
-.include <bsd.port.pre.mk>
+BROKEN_aarch64= Fails to configure: error: Unknown architecture
-.if ${ARCH} == "sparc64"
-IGNORE= not yet ported to sparc64
-.endif
+NOT_FOR_ARCHS= sparc64
+NOT_FOR_ARCHS_REASON= not yet ported to this architecture
+
+.include <bsd.port.pre.mk>
post-build:
cd ${WRKSRC}/modules && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_ARGS}
diff --git a/emulators/ppsspp/Makefile b/emulators/ppsspp/Makefile
index b88dd3d33c65..cba162795e04 100644
--- a/emulators/ppsspp/Makefile
+++ b/emulators/ppsspp/Makefile
@@ -58,6 +58,8 @@ SDL_BUILD_DEPENDS= png>=1.6:graphics/png
SDL_LIB_DEPENDS= libpng.so:graphics/png
SDL_VARS= PORTDATA+="assets ${PORTNAME}"
+BROKEN_aarch64= Fails to compile: error: use of undeclared identifier AllocateAlignedMemory
+
post-patch:
@${REINPLACE_CMD} -e 's,/usr/share,${PREFIX}/share,' \
${WRKSRC}/UI/NativeApp.cpp