aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authormbr <mbr@FreeBSD.org>2009-04-07 06:56:31 +0800
committermbr <mbr@FreeBSD.org>2009-04-07 06:56:31 +0800
commit84611c3e866e1d2375efab8f6e7c564eaea6f620 (patch)
treea924d854aef2ec25902e248c53b6ace2e138fdae /emulators
parentf7cc698df524654ce6a2070176d3197e0ea2c9c7 (diff)
downloadfreebsd-ports-gnome-84611c3e866e1d2375efab8f6e7c564eaea6f620.tar.gz
freebsd-ports-gnome-84611c3e866e1d2375efab8f6e7c564eaea6f620.tar.zst
freebsd-ports-gnome-84611c3e866e1d2375efab8f6e7c564eaea6f620.zip
Try to fix the remaining dependencies and
back out previous commit. Also add a FUSE dependency to fix a soft error. Submitted by: kan
Diffstat (limited to 'emulators')
-rw-r--r--emulators/open-vm-tools/Makefile11
-rw-r--r--emulators/open-vm-tools/files/patch-hgfsmounter-Makefile.in15
-rw-r--r--emulators/open-vm-tools/pkg-plist4
3 files changed, 27 insertions, 3 deletions
diff --git a/emulators/open-vm-tools/Makefile b/emulators/open-vm-tools/Makefile
index 4964273e99c3..ea2890ee8d43 100644
--- a/emulators/open-vm-tools/Makefile
+++ b/emulators/open-vm-tools/Makefile
@@ -39,12 +39,21 @@ CONFIGURE_ARGS+= --disable-unity
CONFIGURE_ARGS+= --with-x --without-gtkmm
CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib" \
CPPFLAGS="-I${LOCALBASE}/include"
-USE_XORG= x11 xextproto ice xext xineramaproto xinerama xrandr xrender xtst
+USE_XORG= x11 ice sm xext xineramaproto xinerama xrandr xrender \
+ xtst
USE_GNOME= gtk20 glib20
PLIST_SUB+= X11=""
CONFLICTS= open-vm-tools-nox11-[0-9]*
.endif
+.if !defined(WITHOUT_FUSE)
+LIB_DEPENDS+= fuse.2:${PORTSDIR}/sysutils/fusefs-libs
+RUN_DEPENDS+= mount_fusefs:${PORTSDIR}/sysutils/fusefs-kmod
+PLIST_SUB+= FUSE=""
+.else
+PLIST_SUB+= FUSE="@comment "
+.endif
+
CONFLICTS+= vmware-guestd[0-9]* vmware-tools[0-9]*
SUB_FILES= pkg-message
diff --git a/emulators/open-vm-tools/files/patch-hgfsmounter-Makefile.in b/emulators/open-vm-tools/files/patch-hgfsmounter-Makefile.in
new file mode 100644
index 000000000000..854c4da01261
--- /dev/null
+++ b/emulators/open-vm-tools/files/patch-hgfsmounter-Makefile.in
@@ -0,0 +1,15 @@
+--- hgfsmounter/Makefile.in.orig 2009-04-06 17:24:30.000000000 -0400
++++ hgfsmounter/Makefile.in 2009-04-06 17:26:09.000000000 -0400
+@@ -558,9 +558,9 @@
+ @FREEBSD_TRUE@ mv $(DESTDIR)$(sbindir)/mount.vmhgfs \
+ @FREEBSD_TRUE@ $(DESTDIR)$(sbindir)/mount_vmhgfs
+ @FREEBSD_TRUE@@WITH_ROOT_PRIVILEGES_TRUE@ chmod u+s $(DESTDIR)$(sbindir)/mount_vmhgfs
+-@FREEBSD_TRUE@ -$(MKDIR_P) $(DESTDIR)/sbin
+-@FREEBSD_TRUE@ -$(LN_S) $(DESTDIR)$(sbindir)/mount_vmhgfs \
+-@FREEBSD_TRUE@ $(DESTDIR)/sbin/mount_vmhgfs &> /dev/null
++#@FREEBSD_TRUE@ -$(MKDIR_P) $(DESTDIR)/sbin
++#@FREEBSD_TRUE@ -$(LN_S) $(DESTDIR)$(sbindir)/mount_vmhgfs \
++#@FREEBSD_TRUE@ $(DESTDIR)/sbin/mount_vmhgfs &> /dev/null
+ @FREEBSD_TRUE@uninstall-hook:
+ @FREEBSD_TRUE@ rm -f $(DESTDIR)$(sbindir)/mount_vmhgfs
+ @FREEBSD_FALSE@install-exec-hook:
diff --git a/emulators/open-vm-tools/pkg-plist b/emulators/open-vm-tools/pkg-plist
index df40db51fd65..67ea2a38bc92 100644
--- a/emulators/open-vm-tools/pkg-plist
+++ b/emulators/open-vm-tools/pkg-plist
@@ -1,10 +1,10 @@
bin/vmware-checkvm
bin/vmware-hgfsclient
+bin/vmware-rpctool
bin/vmware-xferlogs
bin/vmtoolsd
bin/vmware-toolbox-cmd
-bin/vmware-vmblock-fuse
-etc/vmware-tools/tools.conf
+%%FUSE%%bin/vmware-vmblock-fuse
lib/open-vm-tools/plugins/vmsvc/libguestInfo.so
lib/open-vm-tools/plugins/vmsvc/libhgfsServer.so
lib/open-vm-tools/plugins/vmsvc/libpowerOps.so