aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2003-11-13 22:45:08 +0800
committertrevor <trevor@FreeBSD.org>2003-11-13 22:45:08 +0800
commit98d7950e05980253d33259a6aafcd5e3b6547fdb (patch)
tree1cbd7ce2d9411420b33e9f045481bd24f68ef920 /emulators
parenta959d36850b787f6723176962c2985587b2936cb (diff)
downloadfreebsd-ports-gnome-98d7950e05980253d33259a6aafcd5e3b6547fdb.tar.gz
freebsd-ports-gnome-98d7950e05980253d33259a6aafcd5e3b6547fdb.tar.zst
freebsd-ports-gnome-98d7950e05980253d33259a6aafcd5e3b6547fdb.zip
Use the FIND and XARGS macros introduced in bsd.port.mk 1.391.
Diffstat (limited to 'emulators')
-rw-r--r--emulators/linux_base-8/Makefile4
-rw-r--r--emulators/linux_base-rh-9/Makefile4
-rw-r--r--emulators/linux_base-suse-9.1/Makefile4
-rw-r--r--emulators/linux_base-suse-9.2/Makefile4
-rw-r--r--emulators/linux_base-suse-9.3/Makefile4
-rw-r--r--emulators/sim/Makefile2
-rw-r--r--emulators/simh/Makefile2
7 files changed, 12 insertions, 12 deletions
diff --git a/emulators/linux_base-8/Makefile b/emulators/linux_base-8/Makefile
index 3bf66b5c03e3..e1741a523e39 100644
--- a/emulators/linux_base-8/Makefile
+++ b/emulators/linux_base-8/Makefile
@@ -158,8 +158,8 @@ pre-install:
&& ${FIND} -d * -type d | ${SED} -e 's:^:@dirrm :' >> ${PLIST}
do-install:
- cd ${WRKSRC} && find * | cpio -dlmp ${PREFIX}
- find ${PREFIX} -type d -exec ${CHMOD} 755 \{\} \;
+ cd ${WRKSRC} && ${FIND} * | cpio -dlmp ${PREFIX}
+ ${FIND} ${PREFIX} -type d -exec ${CHMOD} 755 \{\} \;
post-install:
@${ECHO} ''
diff --git a/emulators/linux_base-rh-9/Makefile b/emulators/linux_base-rh-9/Makefile
index 3bf66b5c03e3..e1741a523e39 100644
--- a/emulators/linux_base-rh-9/Makefile
+++ b/emulators/linux_base-rh-9/Makefile
@@ -158,8 +158,8 @@ pre-install:
&& ${FIND} -d * -type d | ${SED} -e 's:^:@dirrm :' >> ${PLIST}
do-install:
- cd ${WRKSRC} && find * | cpio -dlmp ${PREFIX}
- find ${PREFIX} -type d -exec ${CHMOD} 755 \{\} \;
+ cd ${WRKSRC} && ${FIND} * | cpio -dlmp ${PREFIX}
+ ${FIND} ${PREFIX} -type d -exec ${CHMOD} 755 \{\} \;
post-install:
@${ECHO} ''
diff --git a/emulators/linux_base-suse-9.1/Makefile b/emulators/linux_base-suse-9.1/Makefile
index 3bf66b5c03e3..e1741a523e39 100644
--- a/emulators/linux_base-suse-9.1/Makefile
+++ b/emulators/linux_base-suse-9.1/Makefile
@@ -158,8 +158,8 @@ pre-install:
&& ${FIND} -d * -type d | ${SED} -e 's:^:@dirrm :' >> ${PLIST}
do-install:
- cd ${WRKSRC} && find * | cpio -dlmp ${PREFIX}
- find ${PREFIX} -type d -exec ${CHMOD} 755 \{\} \;
+ cd ${WRKSRC} && ${FIND} * | cpio -dlmp ${PREFIX}
+ ${FIND} ${PREFIX} -type d -exec ${CHMOD} 755 \{\} \;
post-install:
@${ECHO} ''
diff --git a/emulators/linux_base-suse-9.2/Makefile b/emulators/linux_base-suse-9.2/Makefile
index 3bf66b5c03e3..e1741a523e39 100644
--- a/emulators/linux_base-suse-9.2/Makefile
+++ b/emulators/linux_base-suse-9.2/Makefile
@@ -158,8 +158,8 @@ pre-install:
&& ${FIND} -d * -type d | ${SED} -e 's:^:@dirrm :' >> ${PLIST}
do-install:
- cd ${WRKSRC} && find * | cpio -dlmp ${PREFIX}
- find ${PREFIX} -type d -exec ${CHMOD} 755 \{\} \;
+ cd ${WRKSRC} && ${FIND} * | cpio -dlmp ${PREFIX}
+ ${FIND} ${PREFIX} -type d -exec ${CHMOD} 755 \{\} \;
post-install:
@${ECHO} ''
diff --git a/emulators/linux_base-suse-9.3/Makefile b/emulators/linux_base-suse-9.3/Makefile
index 3bf66b5c03e3..e1741a523e39 100644
--- a/emulators/linux_base-suse-9.3/Makefile
+++ b/emulators/linux_base-suse-9.3/Makefile
@@ -158,8 +158,8 @@ pre-install:
&& ${FIND} -d * -type d | ${SED} -e 's:^:@dirrm :' >> ${PLIST}
do-install:
- cd ${WRKSRC} && find * | cpio -dlmp ${PREFIX}
- find ${PREFIX} -type d -exec ${CHMOD} 755 \{\} \;
+ cd ${WRKSRC} && ${FIND} * | cpio -dlmp ${PREFIX}
+ ${FIND} ${PREFIX} -type d -exec ${CHMOD} 755 \{\} \;
post-install:
@${ECHO} ''
diff --git a/emulators/sim/Makefile b/emulators/sim/Makefile
index 763e2d61d63e..c56de8cfc3f2 100644
--- a/emulators/sim/Makefile
+++ b/emulators/sim/Makefile
@@ -31,7 +31,7 @@ BIN_FILES= altair h316 ibm1130 pdp11 pdp8 \
pre-patch:
@${MKDIR} ${WRKSRC}/BIN
- @for i in ${WRKSRC}/makefile `find ${WRKSRC} -name "*.[hc]"`; do \
+ @for i in ${WRKSRC}/makefile `${FIND} ${WRKSRC} -name "*.[hc]"`; do \
${CAT} $$i | ${TR} -d '\r' > $$i.new; \
${MV} $$i.new $$i; \
done
diff --git a/emulators/simh/Makefile b/emulators/simh/Makefile
index 763e2d61d63e..c56de8cfc3f2 100644
--- a/emulators/simh/Makefile
+++ b/emulators/simh/Makefile
@@ -31,7 +31,7 @@ BIN_FILES= altair h316 ibm1130 pdp11 pdp8 \
pre-patch:
@${MKDIR} ${WRKSRC}/BIN
- @for i in ${WRKSRC}/makefile `find ${WRKSRC} -name "*.[hc]"`; do \
+ @for i in ${WRKSRC}/makefile `${FIND} ${WRKSRC} -name "*.[hc]"`; do \
${CAT} $$i | ${TR} -d '\r' > $$i.new; \
${MV} $$i.new $$i; \
done